Quantcast

Error run hanoi example on Windows 7 when using Installer

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Error run hanoi example on Windows 7 when using Installer

alexa
Hello,
I am unable to run hanoi example on Windows 7

I used windows installer openrave-0.9.0-5cfc74-win32-vc100-setup.exe
to install OpenRAVE 0.9 on Windows 7 to C:\OpenRAVE-0.9.0

As it was already posted that OpenRave windows installer fails to install Boost1.44,  I manually downloaded binaries and copied the following DLL from boost1.44\lib\x86  
to the openrave bin directory C:\OpenRAVE-0.9.0\bin  (where openrave.exe is)
   boost_date_time-vc100-mt-1_44.dll
   boost_thread-vc100-mt-1_44.dll
   boost_filesystem-vc100-mt-1_44.dll
   boost_system-vc100-mt-1_44.dll
   boost_iostreams-vc100-mt-1_44.dll
   boost_regex-vc100-mt-1_44.dll
   boost_python-vc100-mt-1_44.dll

Moreover, the installer failed when downloading setuptools-0.6c11.win32-py2.6.exe : I downloaded and installed it manually,
after this the OpenRAVE windows installer completed with success.

After this I am able to run "C:\OpenRAVE-0.9.0\bin\openrave.exe" and to see GUI
But not able to run openrave.py

C:\OpenRAVE-0.9.0\bin>openrave.py --example hanoi
openravepy is not set into PYTHONPATH env variable, attempting to add
Traceback (most recent call last):
  File "C:\OpenRAVE-0.9.0\bin\openrave.py", line 49, in <module>
    import openravepy
  File "C:\OpenRAVE-0.9.0\Lib\site-packages\openravepy\__init__.py", line 30, in
<module>
    openravepy_currentversion = loadlatest()
  File "C:\OpenRAVE-0.9.0\Lib\site-packages\openravepy\__init__.py", line 16, in
loadlatest
    return _loadversion('_openravepy_')
  File "C:\OpenRAVE-0.9.0\Lib\site-packages\openravepy\__init__.py", line 19, in
_loadversion
    mainpackage = __import__("openravepy", globals(), locals(), [targetname])
  File "C:\OpenRAVE-0.9.0\Lib\site-packages\openravepy\_openravepy_\__init__.py"
, line 29, in <module>
    from openravepy_int import *
ImportError: DLL load failed: The specified module could not be found.

C:\OpenRAVE-0.9.0\bin>

Here is my PYTHONPATH environment variable:
C:\OpenRAVE-0.9.0\bin>echo %PYTHONPATH%
C:\OpenRAVE-0.9.0\Lib\site-packages

I tried to add “C:\Python26\Lib\site-packages” to the PYTHONPATH as below, but the error remained the same:
C:\OpenRAVE-0.9.0\bin>set PYTHONPATH=%PYTHONPATH%;C:\Python26\Lib\site-packages
C:\OpenRAVE-0.9.0\bin>echo %PYTHONPATH%
C:\OpenRAVE-0.9.0\Lib\site-packages;C:\Python26\Lib\site-packages

The same error message I get when using python shell and trying import openrave:

C:\OpenRAVE-0.9.0\bin>C:\Python26\python.exe
Python 2.6.6 (r266:84297, Aug 24 2010, 18:46:32) [MSC v.1500 32 bit (Intel)] on
win32
Type "help", "copyright", "credits" or "license" for more information.
>>> import openravepy
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "C:\OpenRAVE-0.9.0\Lib\site-packages\openravepy\__init__.py", line 30, in
<module>
    openravepy_currentversion = loadlatest()
  File "C:\OpenRAVE-0.9.0\Lib\site-packages\openravepy\__init__.py", line 16, in
loadlatest
    return _loadversion('_openravepy_')
  File "C:\OpenRAVE-0.9.0\Lib\site-packages\openravepy\__init__.py", line 19, in
_loadversion
    mainpackage = __import__("openravepy", globals(), locals(), [targetname])
  File "C:\OpenRAVE-0.9.0\Lib\site-packages\openravepy\_openravepy_\__init__.py"
, line 29, in <module>
    from openravepy_int import *
ImportError: DLL load failed: The specified module could not be found.
>>>

What is wrong ?

Best Regards,

Alexa
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Error run hanoi example on Windows 7 when using Installer

Malu González
Hello, I've got the same error. It will be nice if someone could answer.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Error run hanoi example on Windows 7 when using Installer

Smile4meNow
This post was updated on .
Can you add "installationDir\OpenRAVE-0.9.0\bin" in the PATH environment variable if it's not already added and try again?
Loading...