Quantcast

Error when importing openravepy

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Error when importing openravepy

behrooz
I just installed openrave for the first time and attempted to import
openravepy in Python, but the following error popped up

>>> import openravepy as rave
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/local/lib/python2.7/site-packages/openravepy/__init__.py", line
35, in <module>
    openravepy_currentversion = loadlatest()
  File "/usr/local/lib/python2.7/site-packages/openravepy/__init__.py", line
16, in loadlatest
    return _loadversion('_openravepy_')
  File "/usr/local/lib/python2.7/site-packages/openravepy/__init__.py", line
19, in _loadversion
    mainpackage = __import__("openravepy", globals(), locals(),
[targetname])
  File
"/usr/local/lib/python2.7/site-packages/openravepy/_openravepy_/__init__.py",
line 29, in <module>
    from openravepy_int import *
ImportError:
/usr/local/lib/python2.7/site-packages/openravepy/_openravepy_/openravepy_int.so:
undefined symbol: _ZTIN8OpenRAVE10SensorBase14SensorGeometryE


====
Platform: Ubuntu 14.04

Here is how I installed openrave:
1)  git clone https://github.com/rdiankov/openrave.git --branch
latest_stable
2)  cd openrave
3) mkdir build
4) sudo cmake ../
5) sudo make install
6) got the following error:   ld: cannot find -lassimpd
7) so used a symlink:   sudo ln -s /usr/local/lib/libassimp.so
/usr/local/lib/libassimpd.so
8) sudo make install (again)





--
View this message in context: http://openrave-users-list.185357.n3.nabble.com/Error-when-importing-openravepy-tp4027689.html
Sent from the OpenRAVE Users List mailing list archive at Nabble.com.

------------------------------------------------------------------------------
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Loading...