Error while running OpenRAVE on OS X El Capitan

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Error while running OpenRAVE on OS X El Capitan

Aditya Bhat
This post has NOT been accepted by the mailing list yet.
Hello,

I was able to build OpenRAVE 0.9 without errors and have completed the installation process. Now, when I try to run OpenRAVE, I get the following error:

<nabble_embed> [plugindatabase.h:929 _SysLoadLibrary] /usr/local/lib/openrave0.9-plugins/libqtcoinrave.dylib: dlopen(/usr/local/lib/openrave0.9-plugins/libqtcoinrave.dylib, 1): Library not loaded: /usr/local/opt/coin/Frameworks/Inventor.framework/Versions/C/Libraries/Inventor Referenced from: /usr/local/lib/openrave0.9-plugins/libqtcoinrave.dylib Reason: image not found [plugindatabase.h:929 _SysLoadLibrary] /usr/local/lib/openrave0.9-plugins/libqtcoinrave.dylib: dlopen(/usr/local/lib/openrave0.9-plugins/libqtcoinrave.dylib, 1): Library not loaded: /usr/local/opt/coin/Frameworks/Inventor.framework/Versions/C/Libraries/Inventor Referenced from: /usr/local/lib/openrave0.9-plugins/libqtcoinrave.dylib Reason: image not found [plugindatabase.h:857 _LoadPlugin] failed to load: /usr/local/lib/openrave0.9-plugins/libqtcoinrave.dylib [plugindatabase.h:577 Create] Failed to create name qtcoin, interface viewer [openrave.cpp:315 MainOpenRAVEThread] failed to find an OpenRAVE viewer. </nabble_embed>

I am not sure how to proceed with this. I have installed Coin. The folder "/usr/local/opt/coin/Frameworks/Inventor.framework/Versions/C/Libraries/" has the following:
libCoin.60.1.3.dylib
libCoin.60.dylib
libCoin.dylib
libCoin.la
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Error while running OpenRAVE on OS X El Capitan

edsterg
I've been trying to install OpenRave on Yosemite with no luck. Can you tell me the steps you took to install on El Capitan?
Loading...