IKFast incompatibility with newer sympy versions

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

IKFast incompatibility with newer sympy versions

Bahram Maleki-Fard
Hi,

as I haven't got any reply on the issue on github
(https://github.com/rdiankov/openrave/issues/287), I'll try asking here :)

We're working on an openrave package for Fedora, and so far it looks
very good. Except for IKFast, which seems to be incompatible with newer
sympy Versions (see link above).
Not only is that crucial for the rpm, but also for our own work with
OpenRAVE in general, as we rely on IKFast of course :) Or for anybody
else using latest Fedora.

 From our point of view, this is needed asap. Has the ticket been noted?
Is anybody working on it, or are there any plans to do so?
And what would be the best way to communicate on this? Mailing-list,
openrave-github or maybe the Review Request on Bugzilla on the
openrave-rpm ?

Thanks a lot!

Cheers,
Bahram

------------------------------------------------------------------------------
Managing the Performance of Cloud-Based Applications
Take advantage of what the Cloud has to offer - Avoid Common Pitfalls.
Read the Whitepaper.
http://pubads.g.doubleclick.net/gampad/clk?id=121054471&iu=/4140/ostg.clktrk
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Reply | Threaded
Open this post in threaded view
|

Re: IKFast incompatibility with newer sympy versions

Rosen Diankov
Administrator
dear bahram,

thanks for the ticket and the feedback on fedora!
sympy is a fast moving target and newer versions always seem to break compatibility with openrave's ikfast. unfortunately newer versions are not going to make ikfast better or robust, so it's hard to find the time to play catch-up.
i haven't looked into the problems at hand, perhaps they are really trivial and you would be able to solve them yourself. if you can, please create a ikfast_sympy0.7.4.py file and look at the CMakeLists.txt to see how we dynamically swap ikfast versions depending on the sympy version (this happens right now for sympy 0.6.7). afterwards, do a pull request on openrave

best,
rosen,



2014-02-21 2:59 GMT+09:00 Bahram Maleki-Fard <[hidden email]>:
Hi,

as I haven't got any reply on the issue on github
(https://github.com/rdiankov/openrave/issues/287), I'll try asking here :)

We're working on an openrave package for Fedora, and so far it looks
very good. Except for IKFast, which seems to be incompatible with newer
sympy Versions (see link above).
Not only is that crucial for the rpm, but also for our own work with
OpenRAVE in general, as we rely on IKFast of course :) Or for anybody
else using latest Fedora.

 From our point of view, this is needed asap. Has the ticket been noted?
Is anybody working on it, or are there any plans to do so?
And what would be the best way to communicate on this? Mailing-list,
openrave-github or maybe the Review Request on Bugzilla on the
openrave-rpm ?

Thanks a lot!

Cheers,
Bahram

------------------------------------------------------------------------------
Managing the Performance of Cloud-Based Applications
Take advantage of what the Cloud has to offer - Avoid Common Pitfalls.
Read the Whitepaper.
http://pubads.g.doubleclick.net/gampad/clk?id=121054471&iu=/4140/ostg.clktrk
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users


------------------------------------------------------------------------------
Flow-based real-time traffic analytics software. Cisco certified tool.
Monitor traffic, SLAs, QoS, Medianet, WAAS etc. with NetFlow Analyzer
Customize your own dashboards, set traffic alerts and generate reports.
Network behavioral analysis & security monitoring. All-in-one tool.
http://pubads.g.doubleclick.net/gampad/clk?id=126839071&iu=/4140/ostg.clktrk
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users