Installing OpenRAVE on Ubuntu 12.04 LTS

classic Classic list List threaded Threaded
18 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Installing OpenRAVE on Ubuntu 12.04 LTS

Felix
Hello, Rosen and others.

I got into trouble when installing OpenRAVE on Ubuntu 12.04 LTS.
Got error messages at the end.  

======================Error Messages======================================================
W: failed to fetch http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/source/Sources  404  Not Found

W: failed to fetch http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/binary-amd64/Packages  404  Not Found

W: failed to fetch http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/binary-i386/Packages  404  Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.
========================================================================================

What can I do to work this out?

Thank you very much.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Installing OpenRAVE on Ubuntu 12.04 LTS

Rosen Diankov
Administrator
hi felix,

it will be a month or two before we have debian packages for 12.04,
for now just download the sources and compile yourself:

http://openrave.org/en/coreapihtml/installation_linux.html


2012/5/2 Felix <[hidden email]>:

> Hello, Rosen and others.
>
> I got into trouble when installing OpenRAVE on Ubuntu 12.04 LTS.
> Got error messages at the end.
>
> ======================Error
> Messages======================================================
> W: failed to fetch
> http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/source/Sources
> 404  Not Found
>
> W: failed to fetch
> http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/binary-amd64/Packages
> 404  Not Found
>
> W: failed to fetch
> http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/binary-i386/Packages
> 404  Not Found
>
> E: Some index files failed to download. They have been ignored, or old ones
> used instead.
> ========================================================================================
>
> What can I do to work this out?
>
> Thank you very much.
>
> --
> View this message in context: http://openrave-users-list.185357.n3.nabble.com/Installing-OpenRAVE-on-Ubuntu-12-04-LTS-tp3954269.html
> Sent from the OpenRAVE Users List mailing list archive at Nabble.com.
>
> ------------------------------------------------------------------------------
> Live Security Virtual Conference
> Exclusive live event will cover all the ways today's security and
> threat landscape has changed and how IT managers can respond. Discussions
> will include endpoint security, mobile security and the latest in malware
> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
> _______________________________________________
> Openrave-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/openrave-users

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Installing OpenRAVE on Ubuntu 12.04 LTS

nash911
Hi Rosen,

  Following the instruction on [http://openrave.org/en/coreapihtml/installation_linux.html] for installing OpenRave by compiling the source on Ubuntu 12.04, I got the following error,


W: Failed to fetch http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/source/Sources  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/binary-i386/Packages  404  Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.
nash@nashLab:~$ sudo apt-get build-dep openrave
Reading package lists... Done
Building dependency tree      
Reading state information... Done
E: Unable to find a source package for openrave



 Please advice. Thank You.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Installing OpenRAVE on Ubuntu 12.04 LTS

Okal Billy
Hey Nash,


As you can seen in the previous mail, there wont be deb packages for 12.04 just yet (for about a month).
You can however build openrave from sources using the instructions here



Best,

billy


On Tuesday, May 8, 2012 at 9:23 PM, nash911 wrote:

Hi Rosen,

Following the instruction on
[<a href="http://openrave.org/en/coreapihtml/installation_linux.html]">http://openrave.org/en/coreapihtml/installation_linux.html] for installing
OpenRave by compiling the source on Ubuntu 12.04, I got the following error,


W: Failed to fetch
404 Not Found

W: Failed to fetch
404 Not Found

W: Failed to fetch
404 Not Found

E: Some index files failed to download. They have been ignored, or old ones
used instead.
nash@nashLab:~$ sudo apt-get build-dep openrave
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to find a source package for openrave



Please advice. Thank You.

--
Sent from the OpenRAVE Users List mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
_______________________________________________
Openrave-users mailing list


------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Installing OpenRAVE on Ubuntu 12.04 LTS

Rosen Diankov
Administrator
Hi Nash, Billy,

the "sudo apt-get build-dep openrave" is used for source installs to
bring in the dependencies. They are:

libode
boost
coin3d
soqt
python-dev
python-numpy

if you install these manually, you could ignore the build-dep step

rosen,

2012/5/9 Billy Okal <[hidden email]>:

> Hey Nash,
>
>
> As you can seen in the previous mail, there wont be deb packages for 12.04
> just yet (for about a month).
> You can however build openrave from sources using the instructions here
>
> http://openrave.org/en/coreapihtml/installation_linux.html
>
>
> Best,
>
> billy
>
>
> On Tuesday, May 8, 2012 at 9:23 PM, nash911 wrote:
>
> Hi Rosen,
>
> Following the instruction on
> [http://openrave.org/en/coreapihtml/installation_linux.html] for installing
> OpenRave by compiling the source on Ubuntu 12.04, I got the following error,
>
>
> W: Failed to fetch
> http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/source/Sources
> 404 Not Found
>
> W: Failed to fetch
> http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/binary-amd64/Packages
> 404 Not Found
>
> W: Failed to fetch
> http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/binary-i386/Packages
> 404 Not Found
>
> E: Some index files failed to download. They have been ignored, or old ones
> used instead.
> nash@nashLab:~$ sudo apt-get build-dep openrave
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> E: Unable to find a source package for openrave
>
>
>
> Please advice. Thank You.
>
> --
> View this message in context:
> http://openrave-users-list.185357.n3.nabble.com/Installing-OpenRAVE-on-Ubuntu-12-04-LTS-tp3954269p3972306.html
> Sent from the OpenRAVE Users List mailing list archive at Nabble.com.
>
> ------------------------------------------------------------------------------
> Live Security Virtual Conference
> Exclusive live event will cover all the ways today's security and
> threat landscape has changed and how IT managers can respond. Discussions
> will include endpoint security, mobile security and the latest in malware
> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
> _______________________________________________
> Openrave-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/openrave-users
>
>
>
> ------------------------------------------------------------------------------
> Live Security Virtual Conference
> Exclusive live event will cover all the ways today's security and
> threat landscape has changed and how IT managers can respond. Discussions
> will include endpoint security, mobile security and the latest in malware
> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
> _______________________________________________
> Openrave-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/openrave-users
>

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Installing OpenRAVE on Ubuntu 12.04 LTS

Beatriz León
Hi Rosen,

I am trying to install openrave from sources on Ubuntu 12.04 and it is
giving me the following error:

[ 49%] Building CXX object
src/libopenrave-core/CMakeFiles/libopenrave-core.dir/generictrajectory.cpp.o
[ 50%] Building CXX object
src/libopenrave-core/CMakeFiles/libopenrave-core.dir/colladaparser/colladareader.cpp.o
[ 50%] Building CXX object
src/libopenrave-core/CMakeFiles/libopenrave-core.dir/colladaparser/colladawriter.cpp.o
[ 51%] Building CXX object
src/libopenrave-core/CMakeFiles/libopenrave-core.dir/xfileparser/XFileParser.cpp.o
[ 52%] Building CXX object
src/libopenrave-core/CMakeFiles/libopenrave-core.dir/xfileparser/XFileBindings.cpp.o
Linking CXX shared library libopenrave-core0.7.so
/usr/bin/ld: cannot find -lassimp
/usr/bin/ld: cannot find -lassimp
collect2: ld returned 1 exit status
make[3]: *** [src/libopenrave-core/libopenrave-core0.7.so.0.7.0] Error 1
make[3]: Leaving directory `/home/len/workspace/openrave/build'
make[2]: *** [src/libopenrave-core/CMakeFiles/libopenrave-core.dir/all]
Error 2
make[2]: Leaving directory `/home/len/workspace/openrave/build'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/len/workspace/openrave/build'
make: *** [all] Error 2

Any idea how can I solve it?

Thanks,
Beatriz


On 09/05/12 06:27, Rosen Diankov wrote:

> Hi Nash, Billy,
>
> the "sudo apt-get build-dep openrave" is used for source installs to
> bring in the dependencies. They are:
>
> libode
> boost
> coin3d
> soqt
> python-dev
> python-numpy
>
> if you install these manually, you could ignore the build-dep step
>
> rosen,
>
> 2012/5/9 Billy Okal<[hidden email]>:
>> Hey Nash,
>>
>>
>> As you can seen in the previous mail, there wont be deb packages for 12.04
>> just yet (for about a month).
>> You can however build openrave from sources using the instructions here
>>
>> http://openrave.org/en/coreapihtml/installation_linux.html
>>
>>
>> Best,
>>
>> billy
>>
>>
>> On Tuesday, May 8, 2012 at 9:23 PM, nash911 wrote:
>>
>> Hi Rosen,
>>
>> Following the instruction on
>> [http://openrave.org/en/coreapihtml/installation_linux.html] for installing
>> OpenRave by compiling the source on Ubuntu 12.04, I got the following error,
>>
>>
>> W: Failed to fetch
>> http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/source/Sources
>> 404 Not Found
>>
>> W: Failed to fetch
>> http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/binary-amd64/Packages
>> 404 Not Found
>>
>> W: Failed to fetch
>> http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/binary-i386/Packages
>> 404 Not Found
>>
>> E: Some index files failed to download. They have been ignored, or old ones
>> used instead.
>> nash@nashLab:~$ sudo apt-get build-dep openrave
>> Reading package lists... Done
>> Building dependency tree
>> Reading state information... Done
>> E: Unable to find a source package for openrave
>>
>>
>>
>> Please advice. Thank You.
>>
>> --
>> View this message in context:
>> http://openrave-users-list.185357.n3.nabble.com/Installing-OpenRAVE-on-Ubuntu-12-04-LTS-tp3954269p3972306.html
>> Sent from the OpenRAVE Users List mailing list archive at Nabble.com.
>>
>> ------------------------------------------------------------------------------
>> Live Security Virtual Conference
>> Exclusive live event will cover all the ways today's security and
>> threat landscape has changed and how IT managers can respond. Discussions
>> will include endpoint security, mobile security and the latest in malware
>> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
>> _______________________________________________
>> Openrave-users mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/openrave-users
>>
>>
>>
>> ------------------------------------------------------------------------------
>> Live Security Virtual Conference
>> Exclusive live event will cover all the ways today's security and
>> threat landscape has changed and how IT managers can respond. Discussions
>> will include endpoint security, mobile security and the latest in malware
>> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
>> _______________________________________________
>> Openrave-users mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/openrave-users
>>
> ------------------------------------------------------------------------------
> Live Security Virtual Conference
> Exclusive live event will cover all the ways today's security and
> threat landscape has changed and how IT managers can respond. Discussions
> will include endpoint security, mobile security and the latest in malware
> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
> _______________________________________________
> Openrave-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/openrave-users


------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Installing OpenRAVE on Ubuntu 12.04 LTS

Rosen Diankov
Administrator
hi beatriz,

we would need the entire log of the cmake output, not just the small
part that crashed.

that's weird, the error says the assimp library does not exist. But
openrave only compiles with assimp if

pkg-config --libs assimp

returns -lassimp

can you check if you have a assimp.pc file in your system?

rosen,

2012/5/17 Beatriz <[hidden email]>:

> Hi Rosen,
>
> I am trying to install openrave from sources on Ubuntu 12.04 and it is
> giving me the following error:
>
> [ 49%] Building CXX object
> src/libopenrave-core/CMakeFiles/libopenrave-core.dir/generictrajectory.cpp.o
> [ 50%] Building CXX object
> src/libopenrave-core/CMakeFiles/libopenrave-core.dir/colladaparser/colladareader.cpp.o
> [ 50%] Building CXX object
> src/libopenrave-core/CMakeFiles/libopenrave-core.dir/colladaparser/colladawriter.cpp.o
> [ 51%] Building CXX object
> src/libopenrave-core/CMakeFiles/libopenrave-core.dir/xfileparser/XFileParser.cpp.o
> [ 52%] Building CXX object
> src/libopenrave-core/CMakeFiles/libopenrave-core.dir/xfileparser/XFileBindings.cpp.o
> Linking CXX shared library libopenrave-core0.7.so
> /usr/bin/ld: cannot find -lassimp
> /usr/bin/ld: cannot find -lassimp
> collect2: ld returned 1 exit status
> make[3]: *** [src/libopenrave-core/libopenrave-core0.7.so.0.7.0] Error 1
> make[3]: Leaving directory `/home/len/workspace/openrave/build'
> make[2]: *** [src/libopenrave-core/CMakeFiles/libopenrave-core.dir/all]
> Error 2
> make[2]: Leaving directory `/home/len/workspace/openrave/build'
> make[1]: *** [all] Error 2
> make[1]: Leaving directory `/home/len/workspace/openrave/build'
> make: *** [all] Error 2
>
> Any idea how can I solve it?
>
> Thanks,
> Beatriz
>
>
> On 09/05/12 06:27, Rosen Diankov wrote:
>> Hi Nash, Billy,
>>
>> the "sudo apt-get build-dep openrave" is used for source installs to
>> bring in the dependencies. They are:
>>
>> libode
>> boost
>> coin3d
>> soqt
>> python-dev
>> python-numpy
>>
>> if you install these manually, you could ignore the build-dep step
>>
>> rosen,
>>
>> 2012/5/9 Billy Okal<[hidden email]>:
>>> Hey Nash,
>>>
>>>
>>> As you can seen in the previous mail, there wont be deb packages for 12.04
>>> just yet (for about a month).
>>> You can however build openrave from sources using the instructions here
>>>
>>> http://openrave.org/en/coreapihtml/installation_linux.html
>>>
>>>
>>> Best,
>>>
>>> billy
>>>
>>>
>>> On Tuesday, May 8, 2012 at 9:23 PM, nash911 wrote:
>>>
>>> Hi Rosen,
>>>
>>> Following the instruction on
>>> [http://openrave.org/en/coreapihtml/installation_linux.html] for installing
>>> OpenRave by compiling the source on Ubuntu 12.04, I got the following error,
>>>
>>>
>>> W: Failed to fetch
>>> http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/source/Sources
>>> 404 Not Found
>>>
>>> W: Failed to fetch
>>> http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/binary-amd64/Packages
>>> 404 Not Found
>>>
>>> W: Failed to fetch
>>> http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/binary-i386/Packages
>>> 404 Not Found
>>>
>>> E: Some index files failed to download. They have been ignored, or old ones
>>> used instead.
>>> nash@nashLab:~$ sudo apt-get build-dep openrave
>>> Reading package lists... Done
>>> Building dependency tree
>>> Reading state information... Done
>>> E: Unable to find a source package for openrave
>>>
>>>
>>>
>>> Please advice. Thank You.
>>>
>>> --
>>> View this message in context:
>>> http://openrave-users-list.185357.n3.nabble.com/Installing-OpenRAVE-on-Ubuntu-12-04-LTS-tp3954269p3972306.html
>>> Sent from the OpenRAVE Users List mailing list archive at Nabble.com.
>>>
>>> ------------------------------------------------------------------------------
>>> Live Security Virtual Conference
>>> Exclusive live event will cover all the ways today's security and
>>> threat landscape has changed and how IT managers can respond. Discussions
>>> will include endpoint security, mobile security and the latest in malware
>>> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
>>> _______________________________________________
>>> Openrave-users mailing list
>>> [hidden email]
>>> https://lists.sourceforge.net/lists/listinfo/openrave-users
>>>
>>>
>>>
>>> ------------------------------------------------------------------------------
>>> Live Security Virtual Conference
>>> Exclusive live event will cover all the ways today's security and
>>> threat landscape has changed and how IT managers can respond. Discussions
>>> will include endpoint security, mobile security and the latest in malware
>>> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
>>> _______________________________________________
>>> Openrave-users mailing list
>>> [hidden email]
>>> https://lists.sourceforge.net/lists/listinfo/openrave-users
>>>
>> ------------------------------------------------------------------------------
>> Live Security Virtual Conference
>> Exclusive live event will cover all the ways today's security and
>> threat landscape has changed and how IT managers can respond. Discussions
>> will include endpoint security, mobile security and the latest in malware
>> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
>> _______________________________________________
>> Openrave-users mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/openrave-users
>
>
> ------------------------------------------------------------------------------
> Live Security Virtual Conference
> Exclusive live event will cover all the ways today's security and
> threat landscape has changed and how IT managers can respond. Discussions
> will include endpoint security, mobile security and the latest in malware
> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
> _______________________________________________
> Openrave-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/openrave-users

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Installing OpenRAVE on Ubuntu 12.04 LTS

k-okada@jsk.t.u-tokyo.ac.jp
In reply to this post by Beatriz León
Hi,

you can install assimp library  as
apt-get install libassimp-dev
and you have to change source code as follows.

Rosen, do you know why libassimp installed from openrave/launchpad  has
Logger::Debugging where as http://assimp.sourceforge.net/lib_html/class_assimp_1_1_logger.html#cd0b52a87d6fc11e957ed2c6e2ad75b6  has
Logger::DEBUGGING.

Best
===

Index: openrave_svn/src/libopenrave-core/xmlreaders.cpp
===================================================================
--- openrave_svn/src/libopenrave-core/xmlreaders.cpp (revision 3280)
+++ openrave_svn/src/libopenrave-core/xmlreaders.cpp (working copy)
@@ -89,7 +89,7 @@
     using namespace Assimp;
     Assimp::DefaultLogger::create("",Assimp::Logger::VERBOSE);
     // Select the kinds of messages you want to receive on this log stream
-    const unsigned int severity = Logger::Debugging|Logger::Info|Logger::Warn|Logger::Err;
+    const unsigned int severity = Logger::DEBUGGING|Logger::INFO|Logger::WARN|Logger::ERR;
 
     // Attaching it to the default logger
     DefaultLogger::get()->attachStream( new myStream(), severity );
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Installing OpenRAVE on Ubuntu 12.04 LTS

Beatriz León
In reply to this post by Rosen Diankov
Hi Rosen,

Yes, I have it in /usr/lib/pkgconfig

@k-okada, thanks for the suggestion, but when I try to install it this is the error that I get:

The following NEW packages will be installed:
  libassimp-dev
0 upgraded, 1 newly installed, 0 to remove and 2 not upgraded.
Need to get 0 B/94.4 kB of archives.
After this operation, 470 kB of additional disk space will be used.
(Reading database ... 385425 files and directories currently installed.)
Unpacking libassimp-dev (from .../libassimp-dev_2.0.863+dfsg-2_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libassimp-dev_2.0.863+dfsg-2_amd64.deb (--unpack):
 trying to overwrite '/usr/include/assimp/aiQuaternion.h', which is also in package assimp-dev 2.0.0.6-ubuntu1~natty1
Errors were encountered while processing:
 /var/cache/apt/archives/libassimp-dev_2.0.863+dfsg-2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I don't know if it is related with this issue:
http://ubuntuforums.org/showthread.php?p=11936769


This is the complete output when doing make of openrave

len@acad8088:~/workspace/openrave$ make
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Compiling OpenRAVE Version 0.7.0, soversion=0.7
-- Using cmake version 2.8.7
-- Using double precision
-- detected system processor: x86_64
-- Found PythonInterp: /usr/bin/python (found version "2.7.3")
-- Found PythonLibs: /usr/lib/libpython2.7.so
-- installing to /usr/local, python subdir is lib/python2.7/dist-packages, program suffix is '0.7'
-- Performing Test LINKER_HAS_RDYNAMIC
-- Performing Test LINKER_HAS_RDYNAMIC - Success
-- Performing Test LINKER_HAS_BSYMBOLIC
-- Performing Test LINKER_HAS_BSYMBOLIC - Success
-- Performing Test LINKER_HAS_BSYMBOLIC_FUNCTIONS
-- Performing Test LINKER_HAS_BSYMBOLIC_FUNCTIONS - Success
-- Performing Test LINKER_HAS_VISIBILITY
-- Performing Test LINKER_HAS_VISIBILITY - Success
-- Performing Test LINKER_HAS_VISIBILITY_INLINES_HIDDEN
-- Performing Test LINKER_HAS_VISIBILITY_INLINES_HIDDEN - Success
-- Boost version: 1.46.1
-- Found the following Boost libraries:
--   regex
--   filesystem
--   system
--   python
--   thread
--   iostreams
--   date_time
-- found boost version: 104601
-- Targetting Unix Makefiles
-- Using /usr/bin/c++ compiler.
-- Found GMP: /usr/lib/x86_64-linux-gnu/libgmp.so
-- Found GMPXX: /usr/lib/x86_64-linux-gnu/libgmpxx.so
-- Found MPFR: /usr/lib/x86_64-linux-gnu/libmpfr.so
-- Looking for mpfr_div_d in /usr/lib/x86_64-linux-gnu/libmpfr.so
-- Looking for mpfr_div_d in /usr/lib/x86_64-linux-gnu/libmpfr.so - found
-- Found MPFI: /usr/lib/libmpfi.so
-- Looking for crlibm_init in crlibm
-- Looking for crlibm_init in crlibm - not found
-- Looking for crlibm.h
-- Looking for crlibm.h - not found
-- Using local crlibm
-- Looking for fpu_control.h
-- Looking for fpu_control.h - found
-- Looking for fenv.h
-- Looking for fenv.h - found
-- Looking for inttypes.h
-- Looking for inttypes.h - found
-- Check size of long double
-- Check size of long double - done
-- compiling with double extended (long double) floating point
-- checking for module 'assimp'
--   found assimp, version 2.0
-- Performing Test IS_X86_64
-- Performing Test IS_X86_64 - Success
-- Looking for clock_gettime in rt
-- Looking for clock_gettime in rt - found
-- WARNING: you are using the obsolete 'PKGCONFIG' macro, use FindPkgConfig
-- Found LibXml2: /usr/lib/x86_64-linux-gnu/libxml2.so
-- libxml2 found
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
-- Found Qt4: /usr/bin/qmake (found version "4.8.1")
-- Found ZLIB: /usr/lib/x86_64-linux-gnu/libz.so (found version "1.2.3.4")
-- checking for module 'minizip'
--   package 'minizip' not found
-- Looking for qh_new_qhull in qhull
-- Looking for qh_new_qhull in qhull - found
-- Looking for qhull/qhull_a.h
-- Looking for qhull/qhull_a.h - found
-- Looking for C++ include ANN/ANN.h
-- Looking for C++ include ANN/ANN.h - not found
-- compiling local ann library
CMake Warning at CMakeLists.txt:673 (find_package):
  Could not find module FindFPARSER.cmake or a configuration file for package
  FPARSER.

  Adjust CMAKE_MODULE_PATH to find FindFPARSER.cmake or set FPARSER_DIR to
  the directory containing a CMake configuration file for FPARSER.  The file
  will have one of the following names:

    FPARSERConfig.cmake
    fparser-config.cmake



-- compiling local fparser library
-- Check size of float
-- Check size of float - done
-- Check size of long int
-- Check size of long int - done
-- Looking for alloca.h
-- Looking for alloca.h - found
-- Looking for strtof
-- Looking for strtof - found
-- Looking for strtold
-- Looking for strtold - found
-- Check size of long double
-- Check size of long double - done
-- compiling local convexdecomposition library
-- Looking for C++ include ext/hash_map
-- Looking for C++ include ext/hash_map - found
-- Looking for asinh
-- Looking for asinh - not found
-- Looking for acosh
-- Looking for acosh - not found
-- Looking for atanh
-- Looking for atanh - not found
-- Looking for exp2
-- Looking for exp2 - not found
-- Looking for log2
-- Looking for log2 - not found
-- Looking for mkstemp
-- Looking for mkstemp - found
-- Geometry Parsing: Using Open Asset Import Library (assimp)
-- Geometry Parsing: Using ivcon
-- extracting models to /home/len/workspace/openrave/src
-- Looking for _init in lapack
-- Looking for _init in lapack - not found
-- Matlab detected, compiling matlab mex files
-- Octave installation not found, is 'mkoctfile' in the system path?
-- Performing Test HAVE_ALL_PYTHON_HEADERS
-- Performing Test HAVE_ALL_PYTHON_HEADERS - Success
-- python and boost-python found
-- checking for module 'bullet'
--   found bullet, version 2.77
-- checking for modules 'libavformat;libavcodec'
--   found libavformat, version 53.21.0
--   found libavcodec, version 53.35.0
-- enabling FFMPEG support
-- checking for module 'libswscale'
--   found libswscale, version 2.1.0
-- Looking for libswscale/swscale.h
-- Looking for libswscale/swscale.h - found
-- Looking for libavformat/avformat.h
-- Looking for libavformat/avformat.h - found
-- Looking for libavcodec/avcodec.h
-- Looking for libavcodec/avcodec.h - found
-- Looking for ffmpeg/avformat.h
-- Looking for ffmpeg/avformat.h - not found
-- Looking for ffmpeg/avcodec.h
-- Looking for ffmpeg/avcodec.h - not found
-- Performing Test HAS_AVMEDIA_TYPE_VIDEO
-- Performing Test HAS_AVMEDIA_TYPE_VIDEO - Success
-- Looking for dAllocateODEDataForThread
-- Looking for dAllocateODEDataForThread - found
-- Detected ODE multi-threading extensions, but not sure if should enable them... define ODE_USE_MULTITHREAD variable to use them
-- Performing Test NEED_TRIINDEX
-- Performing Test NEED_TRIINDEX - Failed
-- ODE found, building oderave plugin, precision=DOUBLE
-- Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so
-- Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib/x86_64-linux-gnu/libX11.so
-- Found OpenGL: /usr/lib/x86_64-linux-gnu/libGL.so
-- Detected SoQt/Coin3D GUI, making plugin
-- Looking for X11/Xlib.h
-- Looking for X11/Xlib.h - found
-- boost regex found
-- Configuring done
-- Generating done
-- Build files have been written to: /home/len/workspace/openrave/build
cd build && make
make[1]: Entering directory `/home/len/workspace/openrave/build'
make[2]: Entering directory `/home/len/workspace/openrave/build'
make[3]: Entering directory `/home/len/workspace/openrave/build'
make[3]: Leaving directory `/home/len/workspace/openrave/build'
[  1%] Built target openrave-md5
make[3]: Entering directory `/home/len/workspace/openrave/build'
make[3]: Leaving directory `/home/len/workspace/openrave/build'
[  3%] Built target cpp-gen-md5
make[3]: Entering directory `/home/len/workspace/openrave/build'
Scanning dependencies of target interfacehashes_target
make[3]: Leaving directory `/home/len/workspace/openrave/build'
[  3%] Built target interfacehashes_target
make[3]: Entering directory `/home/len/workspace/openrave/build'
make[3]: Leaving directory `/home/len/workspace/openrave/build'
[ 19%] Built target crlibm
make[3]: Entering directory `/home/len/workspace/openrave/build'
make[3]: Leaving directory `/home/len/workspace/openrave/build'
[ 21%] Built target minizip
make[3]: Entering directory `/home/len/workspace/openrave/build'
make[3]: Leaving directory `/home/len/workspace/openrave/build'
[ 22%] Built target ivcon
make[3]: Entering directory `/home/len/workspace/openrave/build'
make[3]: Leaving directory `/home/len/workspace/openrave/build'
[ 30%] Built target ANN
make[3]: Entering directory `/home/len/workspace/openrave/build'
make[3]: Leaving directory `/home/len/workspace/openrave/build'
[ 31%] Built target fparser
make[3]: Entering directory `/home/len/workspace/openrave/build'
make[3]: Leaving directory `/home/len/workspace/openrave/build'
[ 37%] Built target convexdecomposition
make[3]: Entering directory `/home/len/workspace/openrave/build'
make[3]: Leaving directory `/home/len/workspace/openrave/build'
[ 38%] Built target check_libm_accuracy
make[3]: Entering directory `/home/len/workspace/openrave/build'
make[3]: Leaving directory `/home/len/workspace/openrave/build'
[ 46%] Built target libopenrave
make[3]: Entering directory `/home/len/workspace/openrave/build'
make[3]: Leaving directory `/home/len/workspace/openrave/build'
make[3]: Entering directory `/home/len/workspace/openrave/build'
Linking CXX shared library libopenrave-core0.7.so
/usr/bin/ld: cannot find -lassimp
/usr/bin/ld: cannot find -lassimp
collect2: ld returned 1 exit status
make[3]: *** [src/libopenrave-core/libopenrave-core0.7.so.0.7.0] Error 1
make[3]: Leaving directory `/home/len/workspace/openrave/build'
make[2]: *** [src/libopenrave-core/CMakeFiles/libopenrave-core.dir/all] Error 2
make[2]: Leaving directory `/home/len/workspace/openrave/build'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/len/workspace/openrave/build'
make: *** [all] Error 2

On 16/05/12 18:06, Rosen Diankov wrote:
hi beatriz,

we would need the entire log of the cmake output, not just the small
part that crashed.

that's weird, the error says the assimp library does not exist. But
openrave only compiles with assimp if

pkg-config --libs assimp

returns -lassimp

can you check if you have a assimp.pc file in your system?

rosen,

2012/5/17 Beatriz [hidden email]:
Hi Rosen,

I am trying to install openrave from sources on Ubuntu 12.04 and it is
giving me the following error:

[ 49%] Building CXX object
src/libopenrave-core/CMakeFiles/libopenrave-core.dir/generictrajectory.cpp.o
[ 50%] Building CXX object
src/libopenrave-core/CMakeFiles/libopenrave-core.dir/colladaparser/colladareader.cpp.o
[ 50%] Building CXX object
src/libopenrave-core/CMakeFiles/libopenrave-core.dir/colladaparser/colladawriter.cpp.o
[ 51%] Building CXX object
src/libopenrave-core/CMakeFiles/libopenrave-core.dir/xfileparser/XFileParser.cpp.o
[ 52%] Building CXX object
src/libopenrave-core/CMakeFiles/libopenrave-core.dir/xfileparser/XFileBindings.cpp.o
Linking CXX shared library libopenrave-core0.7.so
/usr/bin/ld: cannot find -lassimp
/usr/bin/ld: cannot find -lassimp
collect2: ld returned 1 exit status
make[3]: *** [src/libopenrave-core/libopenrave-core0.7.so.0.7.0] Error 1
make[3]: Leaving directory `/home/len/workspace/openrave/build'
make[2]: *** [src/libopenrave-core/CMakeFiles/libopenrave-core.dir/all]
Error 2
make[2]: Leaving directory `/home/len/workspace/openrave/build'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/len/workspace/openrave/build'
make: *** [all] Error 2

Any idea how can I solve it?

Thanks,
Beatriz


On 09/05/12 06:27, Rosen Diankov wrote:
Hi Nash, Billy,

the "sudo apt-get build-dep openrave" is used for source installs to
bring in the dependencies. They are:

libode
boost
coin3d
soqt
python-dev
python-numpy

if you install these manually, you could ignore the build-dep step

rosen,

2012/5/9 Billy Okal[hidden email]:
Hey Nash,


As you can seen in the previous mail, there wont be deb packages for 12.04
just yet (for about a month).
You can however build openrave from sources using the instructions here

http://openrave.org/en/coreapihtml/installation_linux.html


Best,

billy


On Tuesday, May 8, 2012 at 9:23 PM, nash911 wrote:

Hi Rosen,

Following the instruction on
[http://openrave.org/en/coreapihtml/installation_linux.html] for installing
OpenRave by compiling the source on Ubuntu 12.04, I got the following error,


W: Failed to fetch
http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/source/Sources
404 Not Found

W: Failed to fetch
http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/binary-amd64/Packages
404 Not Found

W: Failed to fetch
http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/binary-i386/Packages
404 Not Found

E: Some index files failed to download. They have been ignored, or old ones
used instead.
nash@nashLab:~$ sudo apt-get build-dep openrave
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to find a source package for openrave



Please advice. Thank You.

--
View this message in context:
http://openrave-users-list.185357.n3.nabble.com/Installing-OpenRAVE-on-Ubuntu-12-04-LTS-tp3954269p3972306.html
Sent from the OpenRAVE Users List mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users



------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users


------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Installing OpenRAVE on Ubuntu 12.04 LTS

Rosen Diankov
Administrator
Beatriz, Prof Okada

the assimp package is not available for 12.04 yet... sorry about that.

The Debugging vs DEBUGGING change is very interesting indeed. it looks
like openrave has been relying on old assimp headers..! we'll change
this with the next update to

Beatriz, please remove assimp.pc from your system and try again
rosen,

2012/5/17 Beatriz <[hidden email]>:

> Hi Rosen,
>
> Yes, I have it in /usr/lib/pkgconfig
>
> @k-okada, thanks for the suggestion, but when I try to install it this is
> the error that I get:
>
> The following NEW packages will be installed:
>   libassimp-dev
> 0 upgraded, 1 newly installed, 0 to remove and 2 not upgraded.
> Need to get 0 B/94.4 kB of archives.
> After this operation, 470 kB of additional disk space will be used.
> (Reading database ... 385425 files and directories currently installed.)
> Unpacking libassimp-dev (from .../libassimp-dev_2.0.863+dfsg-2_amd64.deb)
> ...
> dpkg: error processing
> /var/cache/apt/archives/libassimp-dev_2.0.863+dfsg-2_amd64.deb (--unpack):
>  trying to overwrite '/usr/include/assimp/aiQuaternion.h', which is also in
> package assimp-dev 2.0.0.6-ubuntu1~natty1
> Errors were encountered while processing:
>  /var/cache/apt/archives/libassimp-dev_2.0.863+dfsg-2_amd64.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)
>
> I don't know if it is related with this issue:
> http://ubuntuforums.org/showthread.php?p=11936769
>
>
> This is the complete output when doing make of openrave
>
> len@acad8088:~/workspace/openrave$ make
> -- The C compiler identification is GNU
> -- The CXX compiler identification is GNU
> -- Check for working C compiler: /usr/bin/gcc
> -- Check for working C compiler: /usr/bin/gcc -- works
> -- Detecting C compiler ABI info
> -- Detecting C compiler ABI info - done
> -- Check for working CXX compiler: /usr/bin/c++
> -- Check for working CXX compiler: /usr/bin/c++ -- works
> -- Detecting CXX compiler ABI info
> -- Detecting CXX compiler ABI info - done
> -- Compiling OpenRAVE Version 0.7.0, soversion=0.7
> -- Using cmake version 2.8.7
> -- Using double precision
> -- detected system processor: x86_64
> -- Found PythonInterp: /usr/bin/python (found version "2.7.3")
> -- Found PythonLibs: /usr/lib/libpython2.7.so
> -- installing to /usr/local, python subdir is lib/python2.7/dist-packages,
> program suffix is '0.7'
> -- Performing Test LINKER_HAS_RDYNAMIC
> -- Performing Test LINKER_HAS_RDYNAMIC - Success
> -- Performing Test LINKER_HAS_BSYMBOLIC
> -- Performing Test LINKER_HAS_BSYMBOLIC - Success
> -- Performing Test LINKER_HAS_BSYMBOLIC_FUNCTIONS
> -- Performing Test LINKER_HAS_BSYMBOLIC_FUNCTIONS - Success
> -- Performing Test LINKER_HAS_VISIBILITY
> -- Performing Test LINKER_HAS_VISIBILITY - Success
> -- Performing Test LINKER_HAS_VISIBILITY_INLINES_HIDDEN
> -- Performing Test LINKER_HAS_VISIBILITY_INLINES_HIDDEN - Success
> -- Boost version: 1.46.1
> -- Found the following Boost libraries:
> --   regex
> --   filesystem
> --   system
> --   python
> --   thread
> --   iostreams
> --   date_time
> -- found boost version: 104601
> -- Targetting Unix Makefiles
> -- Using /usr/bin/c++ compiler.
> -- Found GMP: /usr/lib/x86_64-linux-gnu/libgmp.so
> -- Found GMPXX: /usr/lib/x86_64-linux-gnu/libgmpxx.so
> -- Found MPFR: /usr/lib/x86_64-linux-gnu/libmpfr.so
> -- Looking for mpfr_div_d in /usr/lib/x86_64-linux-gnu/libmpfr.so
> -- Looking for mpfr_div_d in /usr/lib/x86_64-linux-gnu/libmpfr.so - found
> -- Found MPFI: /usr/lib/libmpfi.so
> -- Looking for crlibm_init in crlibm
> -- Looking for crlibm_init in crlibm - not found
> -- Looking for crlibm.h
> -- Looking for crlibm.h - not found
> -- Using local crlibm
> -- Looking for fpu_control.h
> -- Looking for fpu_control.h - found
> -- Looking for fenv.h
> -- Looking for fenv.h - found
> -- Looking for inttypes.h
> -- Looking for inttypes.h - found
> -- Check size of long double
> -- Check size of long double - done
> -- compiling with double extended (long double) floating point
> -- checking for module 'assimp'
> --   found assimp, version 2.0
> -- Performing Test IS_X86_64
> -- Performing Test IS_X86_64 - Success
> -- Looking for clock_gettime in rt
> -- Looking for clock_gettime in rt - found
> -- WARNING: you are using the obsolete 'PKGCONFIG' macro, use FindPkgConfig
> -- Found LibXml2: /usr/lib/x86_64-linux-gnu/libxml2.so
> -- libxml2 found
> -- Looking for Q_WS_X11
> -- Looking for Q_WS_X11 - found
> -- Looking for Q_WS_WIN
> -- Looking for Q_WS_WIN - not found.
> -- Looking for Q_WS_QWS
> -- Looking for Q_WS_QWS - not found.
> -- Looking for Q_WS_MAC
> -- Looking for Q_WS_MAC - not found.
> -- Found Qt4: /usr/bin/qmake (found version "4.8.1")
> -- Found ZLIB: /usr/lib/x86_64-linux-gnu/libz.so (found version "1.2.3.4")
> -- checking for module 'minizip'
> --   package 'minizip' not found
> -- Looking for qh_new_qhull in qhull
> -- Looking for qh_new_qhull in qhull - found
> -- Looking for qhull/qhull_a.h
> -- Looking for qhull/qhull_a.h - found
> -- Looking for C++ include ANN/ANN.h
> -- Looking for C++ include ANN/ANN.h - not found
> -- compiling local ann library
> CMake Warning at CMakeLists.txt:673 (find_package):
>   Could not find module FindFPARSER.cmake or a configuration file for
> package
>   FPARSER.
>
>   Adjust CMAKE_MODULE_PATH to find FindFPARSER.cmake or set FPARSER_DIR to
>   the directory containing a CMake configuration file for FPARSER.  The file
>   will have one of the following names:
>
>     FPARSERConfig.cmake
>     fparser-config.cmake
>
>
>
> -- compiling local fparser library
> -- Check size of float
> -- Check size of float - done
> -- Check size of long int
> -- Check size of long int - done
> -- Looking for alloca.h
> -- Looking for alloca.h - found
> -- Looking for strtof
> -- Looking for strtof - found
> -- Looking for strtold
> -- Looking for strtold - found
> -- Check size of long double
> -- Check size of long double - done
> -- compiling local convexdecomposition library
> -- Looking for C++ include ext/hash_map
> -- Looking for C++ include ext/hash_map - found
> -- Looking for asinh
> -- Looking for asinh - not found
> -- Looking for acosh
> -- Looking for acosh - not found
> -- Looking for atanh
> -- Looking for atanh - not found
> -- Looking for exp2
> -- Looking for exp2 - not found
> -- Looking for log2
> -- Looking for log2 - not found
> -- Looking for mkstemp
> -- Looking for mkstemp - found
> -- Geometry Parsing: Using Open Asset Import Library (assimp)
> -- Geometry Parsing: Using ivcon
> -- extracting models to /home/len/workspace/openrave/src
> -- Looking for _init in lapack
> -- Looking for _init in lapack - not found
> -- Matlab detected, compiling matlab mex files
> -- Octave installation not found, is 'mkoctfile' in the system path?
> -- Performing Test HAVE_ALL_PYTHON_HEADERS
> -- Performing Test HAVE_ALL_PYTHON_HEADERS - Success
> -- python and boost-python found
> -- checking for module 'bullet'
> --   found bullet, version 2.77
> -- checking for modules 'libavformat;libavcodec'
> --   found libavformat, version 53.21.0
> --   found libavcodec, version 53.35.0
> -- enabling FFMPEG support
> -- checking for module 'libswscale'
> --   found libswscale, version 2.1.0
> -- Looking for libswscale/swscale.h
> -- Looking for libswscale/swscale.h - found
> -- Looking for libavformat/avformat.h
> -- Looking for libavformat/avformat.h - found
> -- Looking for libavcodec/avcodec.h
> -- Looking for libavcodec/avcodec.h - found
> -- Looking for ffmpeg/avformat.h
> -- Looking for ffmpeg/avformat.h - not found
> -- Looking for ffmpeg/avcodec.h
> -- Looking for ffmpeg/avcodec.h - not found
> -- Performing Test HAS_AVMEDIA_TYPE_VIDEO
> -- Performing Test HAS_AVMEDIA_TYPE_VIDEO - Success
> -- Looking for dAllocateODEDataForThread
> -- Looking for dAllocateODEDataForThread - found
> -- Detected ODE multi-threading extensions, but not sure if should enable
> them... define ODE_USE_MULTITHREAD variable to use them
> -- Performing Test NEED_TRIINDEX
> -- Performing Test NEED_TRIINDEX - Failed
> -- ODE found, building oderave plugin, precision=DOUBLE
> -- Looking for XOpenDisplay in
> /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so
> -- Looking for XOpenDisplay in
> /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so -
> found
> -- Looking for gethostbyname
> -- Looking for gethostbyname - found
> -- Looking for connect
> -- Looking for connect - found
> -- Looking for remove
> -- Looking for remove - found
> -- Looking for shmat
> -- Looking for shmat - found
> -- Looking for IceConnectionNumber in ICE
> -- Looking for IceConnectionNumber in ICE - found
> -- Found X11: /usr/lib/x86_64-linux-gnu/libX11.so
> -- Found OpenGL: /usr/lib/x86_64-linux-gnu/libGL.so
> -- Detected SoQt/Coin3D GUI, making plugin
> -- Looking for X11/Xlib.h
> -- Looking for X11/Xlib.h - found
> -- boost regex found
> -- Configuring done
> -- Generating done
> -- Build files have been written to: /home/len/workspace/openrave/build
> cd build && make
> make[1]: Entering directory `/home/len/workspace/openrave/build'
> make[2]: Entering directory `/home/len/workspace/openrave/build'
> make[3]: Entering directory `/home/len/workspace/openrave/build'
>
> make[3]: Leaving directory `/home/len/workspace/openrave/build'
> [  1%] Built target openrave-md5
> make[3]: Entering directory `/home/len/workspace/openrave/build'
>
> make[3]: Leaving directory `/home/len/workspace/openrave/build'
> [  3%] Built target cpp-gen-md5
> make[3]: Entering directory `/home/len/workspace/openrave/build'
> Scanning dependencies of target interfacehashes_target
>
> make[3]: Leaving directory `/home/len/workspace/openrave/build'
> [  3%] Built target interfacehashes_target
> make[3]: Entering directory `/home/len/workspace/openrave/build'
>
> make[3]: Leaving directory `/home/len/workspace/openrave/build'
> [ 19%] Built target crlibm
> make[3]: Entering directory `/home/len/workspace/openrave/build'
>
> make[3]: Leaving directory `/home/len/workspace/openrave/build'
> [ 21%] Built target minizip
> make[3]: Entering directory `/home/len/workspace/openrave/build'
>
> make[3]: Leaving directory `/home/len/workspace/openrave/build'
> [ 22%] Built target ivcon
> make[3]: Entering directory `/home/len/workspace/openrave/build'
>
> make[3]: Leaving directory `/home/len/workspace/openrave/build'
> [ 30%] Built target ANN
> make[3]: Entering directory `/home/len/workspace/openrave/build'
>
> make[3]: Leaving directory `/home/len/workspace/openrave/build'
> [ 31%] Built target fparser
> make[3]: Entering directory `/home/len/workspace/openrave/build'
>
> make[3]: Leaving directory `/home/len/workspace/openrave/build'
> [ 37%] Built target convexdecomposition
> make[3]: Entering directory `/home/len/workspace/openrave/build'
>
> make[3]: Leaving directory `/home/len/workspace/openrave/build'
> [ 38%] Built target check_libm_accuracy
> make[3]: Entering directory `/home/len/workspace/openrave/build'
>
> make[3]: Leaving directory `/home/len/workspace/openrave/build'
> [ 46%] Built target libopenrave
> make[3]: Entering directory `/home/len/workspace/openrave/build'
>
> make[3]: Leaving directory `/home/len/workspace/openrave/build'
> make[3]: Entering directory `/home/len/workspace/openrave/build'
>
> Linking CXX shared library libopenrave-core0.7.so
> /usr/bin/ld: cannot find -lassimp
> /usr/bin/ld: cannot find -lassimp
> collect2: ld returned 1 exit status
> make[3]: *** [src/libopenrave-core/libopenrave-core0.7.so.0.7.0] Error 1
> make[3]: Leaving directory `/home/len/workspace/openrave/build'
> make[2]: *** [src/libopenrave-core/CMakeFiles/libopenrave-core.dir/all]
> Error 2
> make[2]: Leaving directory `/home/len/workspace/openrave/build'
> make[1]: *** [all] Error 2
> make[1]: Leaving directory `/home/len/workspace/openrave/build'
> make: *** [all] Error 2
>
> On 16/05/12 18:06, Rosen Diankov wrote:
>
> hi beatriz,
>
> we would need the entire log of the cmake output, not just the small
> part that crashed.
>
> that's weird, the error says the assimp library does not exist. But
> openrave only compiles with assimp if
>
> pkg-config --libs assimp
>
> returns -lassimp
>
> can you check if you have a assimp.pc file in your system?
>
> rosen,
>
> 2012/5/17 Beatriz <[hidden email]>:
>
> Hi Rosen,
>
> I am trying to install openrave from sources on Ubuntu 12.04 and it is
> giving me the following error:
>
> [ 49%] Building CXX object
> src/libopenrave-core/CMakeFiles/libopenrave-core.dir/generictrajectory.cpp.o
> [ 50%] Building CXX object
> src/libopenrave-core/CMakeFiles/libopenrave-core.dir/colladaparser/colladareader.cpp.o
> [ 50%] Building CXX object
> src/libopenrave-core/CMakeFiles/libopenrave-core.dir/colladaparser/colladawriter.cpp.o
> [ 51%] Building CXX object
> src/libopenrave-core/CMakeFiles/libopenrave-core.dir/xfileparser/XFileParser.cpp.o
> [ 52%] Building CXX object
> src/libopenrave-core/CMakeFiles/libopenrave-core.dir/xfileparser/XFileBindings.cpp.o
> Linking CXX shared library libopenrave-core0.7.so
> /usr/bin/ld: cannot find -lassimp
> /usr/bin/ld: cannot find -lassimp
> collect2: ld returned 1 exit status
> make[3]: *** [src/libopenrave-core/libopenrave-core0.7.so.0.7.0] Error 1
> make[3]: Leaving directory `/home/len/workspace/openrave/build'
> make[2]: *** [src/libopenrave-core/CMakeFiles/libopenrave-core.dir/all]
> Error 2
> make[2]: Leaving directory `/home/len/workspace/openrave/build'
> make[1]: *** [all] Error 2
> make[1]: Leaving directory `/home/len/workspace/openrave/build'
> make: *** [all] Error 2
>
> Any idea how can I solve it?
>
> Thanks,
> Beatriz
>
>
> On 09/05/12 06:27, Rosen Diankov wrote:
>
> Hi Nash, Billy,
>
> the "sudo apt-get build-dep openrave" is used for source installs to
> bring in the dependencies. They are:
>
> libode
> boost
> coin3d
> soqt
> python-dev
> python-numpy
>
> if you install these manually, you could ignore the build-dep step
>
> rosen,
>
> 2012/5/9 Billy Okal<[hidden email]>:
>
> Hey Nash,
>
>
> As you can seen in the previous mail, there wont be deb packages for 12.04
> just yet (for about a month).
> You can however build openrave from sources using the instructions here
>
> http://openrave.org/en/coreapihtml/installation_linux.html
>
>
> Best,
>
> billy
>
>
> On Tuesday, May 8, 2012 at 9:23 PM, nash911 wrote:
>
> Hi Rosen,
>
> Following the instruction on
> [http://openrave.org/en/coreapihtml/installation_linux.html] for installing
> OpenRave by compiling the source on Ubuntu 12.04, I got the following error,
>
>
> W: Failed to fetch
> http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/source/Sources
> 404 Not Found
>
> W: Failed to fetch
> http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/binary-amd64/Packages
> 404 Not Found
>
> W: Failed to fetch
> http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/binary-i386/Packages
> 404 Not Found
>
> E: Some index files failed to download. They have been ignored, or old ones
> used instead.
> nash@nashLab:~$ sudo apt-get build-dep openrave
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> E: Unable to find a source package for openrave
>
>
>
> Please advice. Thank You.
>
> --
> View this message in context:
> http://openrave-users-list.185357.n3.nabble.com/Installing-OpenRAVE-on-Ubuntu-12-04-LTS-tp3954269p3972306.html
> Sent from the OpenRAVE Users List mailing list archive at Nabble.com.
>
> ------------------------------------------------------------------------------
> Live Security Virtual Conference
> Exclusive live event will cover all the ways today's security and
> threat landscape has changed and how IT managers can respond. Discussions
> will include endpoint security, mobile security and the latest in malware
> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
> _______________________________________________
> Openrave-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/openrave-users
>
>
>
> ------------------------------------------------------------------------------
> Live Security Virtual Conference
> Exclusive live event will cover all the ways today's security and
> threat landscape has changed and how IT managers can respond. Discussions
> will include endpoint security, mobile security and the latest in malware
> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
> _______________________________________________
> Openrave-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/openrave-users
>
> ------------------------------------------------------------------------------
> Live Security Virtual Conference
> Exclusive live event will cover all the ways today's security and
> threat landscape has changed and how IT managers can respond. Discussions
> will include endpoint security, mobile security and the latest in malware
> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
> _______________________________________________
> Openrave-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/openrave-users
>
> ------------------------------------------------------------------------------
> Live Security Virtual Conference
> Exclusive live event will cover all the ways today's security and
> threat landscape has changed and how IT managers can respond. Discussions
> will include endpoint security, mobile security and the latest in malware
> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
> _______________________________________________
> Openrave-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/openrave-users
>
>

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Installing OpenRAVE on Ubuntu 12.04 LTS

Beatriz León
Thanks Rosen, now it finished without errors!

On 16/05/12 18:19, Rosen Diankov wrote:

> Beatriz, Prof Okada
>
> the assimp package is not available for 12.04 yet... sorry about that.
>
> The Debugging vs DEBUGGING change is very interesting indeed. it looks
> like openrave has been relying on old assimp headers..! we'll change
> this with the next update to
>
> Beatriz, please remove assimp.pc from your system and try again
> rosen,
>
> 2012/5/17 Beatriz<[hidden email]>:
>> Hi Rosen,
>>
>> Yes, I have it in /usr/lib/pkgconfig
>>
>> @k-okada, thanks for the suggestion, but when I try to install it this is
>> the error that I get:
>>
>> The following NEW packages will be installed:
>>    libassimp-dev
>> 0 upgraded, 1 newly installed, 0 to remove and 2 not upgraded.
>> Need to get 0 B/94.4 kB of archives.
>> After this operation, 470 kB of additional disk space will be used.
>> (Reading database ... 385425 files and directories currently installed.)
>> Unpacking libassimp-dev (from .../libassimp-dev_2.0.863+dfsg-2_amd64.deb)
>> ...
>> dpkg: error processing
>> /var/cache/apt/archives/libassimp-dev_2.0.863+dfsg-2_amd64.deb (--unpack):
>>   trying to overwrite '/usr/include/assimp/aiQuaternion.h', which is also in
>> package assimp-dev 2.0.0.6-ubuntu1~natty1
>> Errors were encountered while processing:
>>   /var/cache/apt/archives/libassimp-dev_2.0.863+dfsg-2_amd64.deb
>> E: Sub-process /usr/bin/dpkg returned an error code (1)
>>
>> I don't know if it is related with this issue:
>> http://ubuntuforums.org/showthread.php?p=11936769
>>
>>
>> This is the complete output when doing make of openrave
>>
>> len@acad8088:~/workspace/openrave$ make
>> -- The C compiler identification is GNU
>> -- The CXX compiler identification is GNU
>> -- Check for working C compiler: /usr/bin/gcc
>> -- Check for working C compiler: /usr/bin/gcc -- works
>> -- Detecting C compiler ABI info
>> -- Detecting C compiler ABI info - done
>> -- Check for working CXX compiler: /usr/bin/c++
>> -- Check for working CXX compiler: /usr/bin/c++ -- works
>> -- Detecting CXX compiler ABI info
>> -- Detecting CXX compiler ABI info - done
>> -- Compiling OpenRAVE Version 0.7.0, soversion=0.7
>> -- Using cmake version 2.8.7
>> -- Using double precision
>> -- detected system processor: x86_64
>> -- Found PythonInterp: /usr/bin/python (found version "2.7.3")
>> -- Found PythonLibs: /usr/lib/libpython2.7.so
>> -- installing to /usr/local, python subdir is lib/python2.7/dist-packages,
>> program suffix is '0.7'
>> -- Performing Test LINKER_HAS_RDYNAMIC
>> -- Performing Test LINKER_HAS_RDYNAMIC - Success
>> -- Performing Test LINKER_HAS_BSYMBOLIC
>> -- Performing Test LINKER_HAS_BSYMBOLIC - Success
>> -- Performing Test LINKER_HAS_BSYMBOLIC_FUNCTIONS
>> -- Performing Test LINKER_HAS_BSYMBOLIC_FUNCTIONS - Success
>> -- Performing Test LINKER_HAS_VISIBILITY
>> -- Performing Test LINKER_HAS_VISIBILITY - Success
>> -- Performing Test LINKER_HAS_VISIBILITY_INLINES_HIDDEN
>> -- Performing Test LINKER_HAS_VISIBILITY_INLINES_HIDDEN - Success
>> -- Boost version: 1.46.1
>> -- Found the following Boost libraries:
>> --   regex
>> --   filesystem
>> --   system
>> --   python
>> --   thread
>> --   iostreams
>> --   date_time
>> -- found boost version: 104601
>> -- Targetting Unix Makefiles
>> -- Using /usr/bin/c++ compiler.
>> -- Found GMP: /usr/lib/x86_64-linux-gnu/libgmp.so
>> -- Found GMPXX: /usr/lib/x86_64-linux-gnu/libgmpxx.so
>> -- Found MPFR: /usr/lib/x86_64-linux-gnu/libmpfr.so
>> -- Looking for mpfr_div_d in /usr/lib/x86_64-linux-gnu/libmpfr.so
>> -- Looking for mpfr_div_d in /usr/lib/x86_64-linux-gnu/libmpfr.so - found
>> -- Found MPFI: /usr/lib/libmpfi.so
>> -- Looking for crlibm_init in crlibm
>> -- Looking for crlibm_init in crlibm - not found
>> -- Looking for crlibm.h
>> -- Looking for crlibm.h - not found
>> -- Using local crlibm
>> -- Looking for fpu_control.h
>> -- Looking for fpu_control.h - found
>> -- Looking for fenv.h
>> -- Looking for fenv.h - found
>> -- Looking for inttypes.h
>> -- Looking for inttypes.h - found
>> -- Check size of long double
>> -- Check size of long double - done
>> -- compiling with double extended (long double) floating point
>> -- checking for module 'assimp'
>> --   found assimp, version 2.0
>> -- Performing Test IS_X86_64
>> -- Performing Test IS_X86_64 - Success
>> -- Looking for clock_gettime in rt
>> -- Looking for clock_gettime in rt - found
>> -- WARNING: you are using the obsolete 'PKGCONFIG' macro, use FindPkgConfig
>> -- Found LibXml2: /usr/lib/x86_64-linux-gnu/libxml2.so
>> -- libxml2 found
>> -- Looking for Q_WS_X11
>> -- Looking for Q_WS_X11 - found
>> -- Looking for Q_WS_WIN
>> -- Looking for Q_WS_WIN - not found.
>> -- Looking for Q_WS_QWS
>> -- Looking for Q_WS_QWS - not found.
>> -- Looking for Q_WS_MAC
>> -- Looking for Q_WS_MAC - not found.
>> -- Found Qt4: /usr/bin/qmake (found version "4.8.1")
>> -- Found ZLIB: /usr/lib/x86_64-linux-gnu/libz.so (found version "1.2.3.4")
>> -- checking for module 'minizip'
>> --   package 'minizip' not found
>> -- Looking for qh_new_qhull in qhull
>> -- Looking for qh_new_qhull in qhull - found
>> -- Looking for qhull/qhull_a.h
>> -- Looking for qhull/qhull_a.h - found
>> -- Looking for C++ include ANN/ANN.h
>> -- Looking for C++ include ANN/ANN.h - not found
>> -- compiling local ann library
>> CMake Warning at CMakeLists.txt:673 (find_package):
>>    Could not find module FindFPARSER.cmake or a configuration file for
>> package
>>    FPARSER.
>>
>>    Adjust CMAKE_MODULE_PATH to find FindFPARSER.cmake or set FPARSER_DIR to
>>    the directory containing a CMake configuration file for FPARSER.  The file
>>    will have one of the following names:
>>
>>      FPARSERConfig.cmake
>>      fparser-config.cmake
>>
>>
>>
>> -- compiling local fparser library
>> -- Check size of float
>> -- Check size of float - done
>> -- Check size of long int
>> -- Check size of long int - done
>> -- Looking for alloca.h
>> -- Looking for alloca.h - found
>> -- Looking for strtof
>> -- Looking for strtof - found
>> -- Looking for strtold
>> -- Looking for strtold - found
>> -- Check size of long double
>> -- Check size of long double - done
>> -- compiling local convexdecomposition library
>> -- Looking for C++ include ext/hash_map
>> -- Looking for C++ include ext/hash_map - found
>> -- Looking for asinh
>> -- Looking for asinh - not found
>> -- Looking for acosh
>> -- Looking for acosh - not found
>> -- Looking for atanh
>> -- Looking for atanh - not found
>> -- Looking for exp2
>> -- Looking for exp2 - not found
>> -- Looking for log2
>> -- Looking for log2 - not found
>> -- Looking for mkstemp
>> -- Looking for mkstemp - found
>> -- Geometry Parsing: Using Open Asset Import Library (assimp)
>> -- Geometry Parsing: Using ivcon
>> -- extracting models to /home/len/workspace/openrave/src
>> -- Looking for _init in lapack
>> -- Looking for _init in lapack - not found
>> -- Matlab detected, compiling matlab mex files
>> -- Octave installation not found, is 'mkoctfile' in the system path?
>> -- Performing Test HAVE_ALL_PYTHON_HEADERS
>> -- Performing Test HAVE_ALL_PYTHON_HEADERS - Success
>> -- python and boost-python found
>> -- checking for module 'bullet'
>> --   found bullet, version 2.77
>> -- checking for modules 'libavformat;libavcodec'
>> --   found libavformat, version 53.21.0
>> --   found libavcodec, version 53.35.0
>> -- enabling FFMPEG support
>> -- checking for module 'libswscale'
>> --   found libswscale, version 2.1.0
>> -- Looking for libswscale/swscale.h
>> -- Looking for libswscale/swscale.h - found
>> -- Looking for libavformat/avformat.h
>> -- Looking for libavformat/avformat.h - found
>> -- Looking for libavcodec/avcodec.h
>> -- Looking for libavcodec/avcodec.h - found
>> -- Looking for ffmpeg/avformat.h
>> -- Looking for ffmpeg/avformat.h - not found
>> -- Looking for ffmpeg/avcodec.h
>> -- Looking for ffmpeg/avcodec.h - not found
>> -- Performing Test HAS_AVMEDIA_TYPE_VIDEO
>> -- Performing Test HAS_AVMEDIA_TYPE_VIDEO - Success
>> -- Looking for dAllocateODEDataForThread
>> -- Looking for dAllocateODEDataForThread - found
>> -- Detected ODE multi-threading extensions, but not sure if should enable
>> them... define ODE_USE_MULTITHREAD variable to use them
>> -- Performing Test NEED_TRIINDEX
>> -- Performing Test NEED_TRIINDEX - Failed
>> -- ODE found, building oderave plugin, precision=DOUBLE
>> -- Looking for XOpenDisplay in
>> /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so
>> -- Looking for XOpenDisplay in
>> /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so -
>> found
>> -- Looking for gethostbyname
>> -- Looking for gethostbyname - found
>> -- Looking for connect
>> -- Looking for connect - found
>> -- Looking for remove
>> -- Looking for remove - found
>> -- Looking for shmat
>> -- Looking for shmat - found
>> -- Looking for IceConnectionNumber in ICE
>> -- Looking for IceConnectionNumber in ICE - found
>> -- Found X11: /usr/lib/x86_64-linux-gnu/libX11.so
>> -- Found OpenGL: /usr/lib/x86_64-linux-gnu/libGL.so
>> -- Detected SoQt/Coin3D GUI, making plugin
>> -- Looking for X11/Xlib.h
>> -- Looking for X11/Xlib.h - found
>> -- boost regex found
>> -- Configuring done
>> -- Generating done
>> -- Build files have been written to: /home/len/workspace/openrave/build
>> cd build&&  make
>> make[1]: Entering directory `/home/len/workspace/openrave/build'
>> make[2]: Entering directory `/home/len/workspace/openrave/build'
>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>
>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>> [  1%] Built target openrave-md5
>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>
>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>> [  3%] Built target cpp-gen-md5
>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>> Scanning dependencies of target interfacehashes_target
>>
>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>> [  3%] Built target interfacehashes_target
>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>
>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>> [ 19%] Built target crlibm
>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>
>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>> [ 21%] Built target minizip
>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>
>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>> [ 22%] Built target ivcon
>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>
>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>> [ 30%] Built target ANN
>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>
>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>> [ 31%] Built target fparser
>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>
>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>> [ 37%] Built target convexdecomposition
>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>
>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>> [ 38%] Built target check_libm_accuracy
>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>
>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>> [ 46%] Built target libopenrave
>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>
>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>
>> Linking CXX shared library libopenrave-core0.7.so
>> /usr/bin/ld: cannot find -lassimp
>> /usr/bin/ld: cannot find -lassimp
>> collect2: ld returned 1 exit status
>> make[3]: *** [src/libopenrave-core/libopenrave-core0.7.so.0.7.0] Error 1
>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>> make[2]: *** [src/libopenrave-core/CMakeFiles/libopenrave-core.dir/all]
>> Error 2
>> make[2]: Leaving directory `/home/len/workspace/openrave/build'
>> make[1]: *** [all] Error 2
>> make[1]: Leaving directory `/home/len/workspace/openrave/build'
>> make: *** [all] Error 2
>>
>> On 16/05/12 18:06, Rosen Diankov wrote:
>>
>> hi beatriz,
>>
>> we would need the entire log of the cmake output, not just the small
>> part that crashed.
>>
>> that's weird, the error says the assimp library does not exist. But
>> openrave only compiles with assimp if
>>
>> pkg-config --libs assimp
>>
>> returns -lassimp
>>
>> can you check if you have a assimp.pc file in your system?
>>
>> rosen,
>>
>> 2012/5/17 Beatriz<[hidden email]>:
>>
>> Hi Rosen,
>>
>> I am trying to install openrave from sources on Ubuntu 12.04 and it is
>> giving me the following error:
>>
>> [ 49%] Building CXX object
>> src/libopenrave-core/CMakeFiles/libopenrave-core.dir/generictrajectory.cpp.o
>> [ 50%] Building CXX object
>> src/libopenrave-core/CMakeFiles/libopenrave-core.dir/colladaparser/colladareader.cpp.o
>> [ 50%] Building CXX object
>> src/libopenrave-core/CMakeFiles/libopenrave-core.dir/colladaparser/colladawriter.cpp.o
>> [ 51%] Building CXX object
>> src/libopenrave-core/CMakeFiles/libopenrave-core.dir/xfileparser/XFileParser.cpp.o
>> [ 52%] Building CXX object
>> src/libopenrave-core/CMakeFiles/libopenrave-core.dir/xfileparser/XFileBindings.cpp.o
>> Linking CXX shared library libopenrave-core0.7.so
>> /usr/bin/ld: cannot find -lassimp
>> /usr/bin/ld: cannot find -lassimp
>> collect2: ld returned 1 exit status
>> make[3]: *** [src/libopenrave-core/libopenrave-core0.7.so.0.7.0] Error 1
>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>> make[2]: *** [src/libopenrave-core/CMakeFiles/libopenrave-core.dir/all]
>> Error 2
>> make[2]: Leaving directory `/home/len/workspace/openrave/build'
>> make[1]: *** [all] Error 2
>> make[1]: Leaving directory `/home/len/workspace/openrave/build'
>> make: *** [all] Error 2
>>
>> Any idea how can I solve it?
>>
>> Thanks,
>> Beatriz
>>
>>
>> On 09/05/12 06:27, Rosen Diankov wrote:
>>
>> Hi Nash, Billy,
>>
>> the "sudo apt-get build-dep openrave" is used for source installs to
>> bring in the dependencies. They are:
>>
>> libode
>> boost
>> coin3d
>> soqt
>> python-dev
>> python-numpy
>>
>> if you install these manually, you could ignore the build-dep step
>>
>> rosen,
>>
>> 2012/5/9 Billy Okal<[hidden email]>:
>>
>> Hey Nash,
>>
>>
>> As you can seen in the previous mail, there wont be deb packages for 12.04
>> just yet (for about a month).
>> You can however build openrave from sources using the instructions here
>>
>> http://openrave.org/en/coreapihtml/installation_linux.html
>>
>>
>> Best,
>>
>> billy
>>
>>
>> On Tuesday, May 8, 2012 at 9:23 PM, nash911 wrote:
>>
>> Hi Rosen,
>>
>> Following the instruction on
>> [http://openrave.org/en/coreapihtml/installation_linux.html] for installing
>> OpenRave by compiling the source on Ubuntu 12.04, I got the following error,
>>
>>
>> W: Failed to fetch
>> http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/source/Sources
>> 404 Not Found
>>
>> W: Failed to fetch
>> http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/binary-amd64/Packages
>> 404 Not Found
>>
>> W: Failed to fetch
>> http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/binary-i386/Packages
>> 404 Not Found
>>
>> E: Some index files failed to download. They have been ignored, or old ones
>> used instead.
>> nash@nashLab:~$ sudo apt-get build-dep openrave
>> Reading package lists... Done
>> Building dependency tree
>> Reading state information... Done
>> E: Unable to find a source package for openrave
>>
>>
>>
>> Please advice. Thank You.
>>
>> --
>> View this message in context:
>> http://openrave-users-list.185357.n3.nabble.com/Installing-OpenRAVE-on-Ubuntu-12-04-LTS-tp3954269p3972306.html
>> Sent from the OpenRAVE Users List mailing list archive at Nabble.com.
>>
>> ------------------------------------------------------------------------------
>> Live Security Virtual Conference
>> Exclusive live event will cover all the ways today's security and
>> threat landscape has changed and how IT managers can respond. Discussions
>> will include endpoint security, mobile security and the latest in malware
>> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
>> _______________________________________________
>> Openrave-users mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/openrave-users
>>
>>
>>
>> ------------------------------------------------------------------------------
>> Live Security Virtual Conference
>> Exclusive live event will cover all the ways today's security and
>> threat landscape has changed and how IT managers can respond. Discussions
>> will include endpoint security, mobile security and the latest in malware
>> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
>> _______________________________________________
>> Openrave-users mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/openrave-users
>>
>> ------------------------------------------------------------------------------
>> Live Security Virtual Conference
>> Exclusive live event will cover all the ways today's security and
>> threat landscape has changed and how IT managers can respond. Discussions
>> will include endpoint security, mobile security and the latest in malware
>> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
>> _______________________________________________
>> Openrave-users mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/openrave-users
>>
>> ------------------------------------------------------------------------------
>> Live Security Virtual Conference
>> Exclusive live event will cover all the ways today's security and
>> threat landscape has changed and how IT managers can respond. Discussions
>> will include endpoint security, mobile security and the latest in malware
>> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
>> _______________________________________________
>> Openrave-users mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/openrave-users
>>
>>


------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Installing OpenRAVE on Ubuntu 12.04 LTS

Chris Dellin
In reply to this post by Rosen Diankov
Rosen, just an fyi, I submitted a patch for this as part of ticket 271.
http://sourceforge.net/apps/trac/openrave/ticket/271
- Chris

On 5/16/12, Rosen Diankov <[hidden email]> wrote:

> Beatriz, Prof Okada
>
> the assimp package is not available for 12.04 yet... sorry about that.
>
> The Debugging vs DEBUGGING change is very interesting indeened. it looks
> like openrave has been relying on old assimp headers..! we'll change
> this with the next update to
>
> Beatriz, please remove assimp.pc from your system and try again
> rosen,
>
> 2012/5/17 Beatriz <[hidden email]>:
>> Hi Rosen,
>>
>> Yes, I have it in /usr/lib/pkgconfig
>>
>> @k-okada, thanks for the suggestion, but when I try to install it this is
>> the error that I get:
>>
>> The following NEW packages will be installed:
>>   libassimp-dev
>> 0 upgraded, 1 newly installed, 0 to remove and 2 not upgraded.
>> Need to get 0 B/94.4 kB of archives.
>> After this operation, 470 kB of additional disk space will be used.
>> (Reading database ... 385425 files and directories currently installed.)
>> Unpacking libassimp-dev (from .../libassimp-dev_2.0.863+dfsg-2_amd64.deb)
>> ...
>> dpkg: error processing
>> /var/cache/apt/archives/libassimp-dev_2.0.863+dfsg-2_amd64.deb
>> (--unpack):
>>  trying to overwrite '/usr/include/assimp/aiQuaternion.h', which is also
>> in
>> package assimp-dev 2.0.0.6-ubuntu1~natty1
>> Errors were encountered while processing:
>>  /var/cache/apt/archives/libassimp-dev_2.0.863+dfsg-2_amd64.deb
>> E: Sub-process /usr/bin/dpkg returned an error code (1)
>>
>> I don't know if it is related with this issue:
>> http://ubuntuforums.org/showthread.php?p=11936769
>>
>>
>> This is the complete output when doing make of openrave
>>
>> len@acad8088:~/workspace/openrave$ make
>> -- The C compiler identification is GNU
>> -- The CXX compiler identification is GNU
>> -- Check for working C compiler: /usr/bin/gcc
>> -- Check for working C compiler: /usr/bin/gcc -- works
>> -- Detecting C compiler ABI info
>> -- Detecting C compiler ABI info - done
>> -- Check for working CXX compiler: /usr/bin/c++
>> -- Check for working CXX compiler: /usr/bin/c++ -- works
>> -- Detecting CXX compiler ABI info
>> -- Detecting CXX compiler ABI info - done
>> -- Compiling OpenRAVE Version 0.7.0, soversion=0.7
>> -- Using cmake version 2.8.7
>> -- Using double precision
>> -- detected system processor: x86_64
>> -- Found PythonInterp: /usr/bin/python (found version "2.7.3")
>> -- Found PythonLibs: /usr/lib/libpython2.7.so
>> -- installing to /usr/local, python subdir is
>> lib/python2.7/dist-packages,
>> program suffix is '0.7'
>> -- Performing Test LINKER_HAS_RDYNAMIC
>> -- Performing Test LINKER_HAS_RDYNAMIC - Success
>> -- Performing Test LINKER_HAS_BSYMBOLIC
>> -- Performing Test LINKER_HAS_BSYMBOLIC - Success
>> -- Performing Test LINKER_HAS_BSYMBOLIC_FUNCTIONS
>> -- Performing Test LINKER_HAS_BSYMBOLIC_FUNCTIONS - Success
>> -- Performing Test LINKER_HAS_VISIBILITY
>> -- Performing Test LINKER_HAS_VISIBILITY - Success
>> -- Performing Test LINKER_HAS_VISIBILITY_INLINES_HIDDEN
>> -- Performing Test LINKER_HAS_VISIBILITY_INLINES_HIDDEN - Success
>> -- Boost version: 1.46.1
>> -- Found the following Boost libraries:
>> --   regex
>> --   filesystem
>> --   system
>> --   python
>> --   thread
>> --   iostreams
>> --   date_time
>> -- found boost version: 104601
>> -- Targetting Unix Makefiles
>> -- Using /usr/bin/c++ compiler.
>> -- Found GMP: /usr/lib/x86_64-linux-gnu/libgmp.so
>> -- Found GMPXX: /usr/lib/x86_64-linux-gnu/libgmpxx.so
>> -- Found MPFR: /usr/lib/x86_64-linux-gnu/libmpfr.so
>> -- Looking for mpfr_div_d in /usr/lib/x86_64-linux-gnu/libmpfr.so
>> -- Looking for mpfr_div_d in /usr/lib/x86_64-linux-gnu/libmpfr.so - found
>> -- Found MPFI: /usr/lib/libmpfi.so
>> -- Looking for crlibm_init in crlibm
>> -- Looking for crlibm_init in crlibm - not found
>> -- Looking for crlibm.h
>> -- Looking for crlibm.h - not found
>> -- Using local crlibm
>> -- Looking for fpu_control.h
>> -- Looking for fpu_control.h - found
>> -- Looking for fenv.h
>> -- Looking for fenv.h - found
>> -- Looking for inttypes.h
>> -- Looking for inttypes.h - found
>> -- Check size of long double
>> -- Check size of long double - done
>> -- compiling with double extended (long double) floating point
>> -- checking for module 'assimp'
>> --   found assimp, version 2.0
>> -- Performing Test IS_X86_64
>> -- Performing Test IS_X86_64 - Success
>> -- Looking for clock_gettime in rt
>> -- Looking for clock_gettime in rt - found
>> -- WARNING: you are using the obsolete 'PKGCONFIG' macro, use
>> FindPkgConfig
>> -- Found LibXml2: /usr/lib/x86_64-linux-gnu/libxml2.so
>> -- libxml2 found
>> -- Looking for Q_WS_X11
>> -- Looking for Q_WS_X11 - found
>> -- Looking for Q_WS_WIN
>> -- Looking for Q_WS_WIN - not found.
>> -- Looking for Q_WS_QWS
>> -- Looking for Q_WS_QWS - not found.
>> -- Looking for Q_WS_MAC
>> -- Looking for Q_WS_MAC - not found.
>> -- Found Qt4: /usr/bin/qmake (found version "4.8.1")
>> -- Found ZLIB: /usr/lib/x86_64-linux-gnu/libz.so (found version
>> "1.2.3.4")
>> -- checking for module 'minizip'
>> --   package 'minizip' not found
>> -- Looking for qh_new_qhull in qhull
>> -- Looking for qh_new_qhull in qhull - found
>> -- Looking for qhull/qhull_a.h
>> -- Looking for qhull/qhull_a.h - found
>> -- Looking for C++ include ANN/ANN.h
>> -- Looking for C++ include ANN/ANN.h - not found
>> -- compiling local ann library
>> CMake Warning at CMakeLists.txt:673 (find_package):
>>   Could not find module FindFPARSER.cmake or a configuration file for
>> package
>>   FPARSER.
>>
>>   Adjust CMAKE_MODULE_PATH to find FindFPARSER.cmake or set FPARSER_DIR
>> to
>>   the directory containing a CMake configuration file for FPARSER.  The
>> file
>>   will have one of the following names:
>>
>>     FPARSERConfig.cmake
>>     fparser-config.cmake
>>
>>
>>
>> -- compiling local fparser library
>> -- Check size of float
>> -- Check size of float - done
>> -- Check size of long int
>> -- Check size of long int - done
>> -- Looking for alloca.h
>> -- Looking for alloca.h - found
>> -- Looking for strtof
>> -- Looking for strtof - found
>> -- Looking for strtold
>> -- Looking for strtold - found
>> -- Check size of long double
>> -- Check size of long double - done
>> -- compiling local convexdecomposition library
>> -- Looking for C++ include ext/hash_map
>> -- Looking for C++ include ext/hash_map - found
>> -- Looking for asinh
>> -- Looking for asinh - not found
>> -- Looking for acosh
>> -- Looking for acosh - not found
>> -- Looking for atanh
>> -- Looking for atanh - not found
>> -- Looking for exp2
>> -- Looking for exp2 - not found
>> -- Looking for log2
>> -- Looking for log2 - not found
>> -- Looking for mkstemp
>> -- Looking for mkstemp - found
>> -- Geometry Parsing: Using Open Asset Import Library (assimp)
>> -- Geometry Parsing: Using ivcon
>> -- extracting models to /home/len/workspace/openrave/src
>> -- Looking for _init in lapack
>> -- Looking for _init in lapack - not found
>> -- Matlab detected, compiling matlab mex files
>> -- Octave installation not found, is 'mkoctfile' in the system path?
>> -- Performing Test HAVE_ALL_PYTHON_HEADERS
>> -- Performing Test HAVE_ALL_PYTHON_HEADERS - Success
>> -- python and boost-python found
>> -- checking for module 'bullet'
>> --   found bullet, version 2.77
>> -- checking for modules 'libavformat;libavcodec'
>> --   found libavformat, version 53.21.0
>> --   found libavcodec, version 53.35.0
>> -- enabling FFMPEG support
>> -- checking for module 'libswscale'
>> --   found libswscale, version 2.1.0
>> -- Looking for libswscale/swscale.h
>> -- Looking for libswscale/swscale.h - found
>> -- Looking for libavformat/avformat.h
>> -- Looking for libavformat/avformat.h - found
>> -- Looking for libavcodec/avcodec.h
>> -- Looking for libavcodec/avcodec.h - found
>> -- Looking for ffmpeg/avformat.h
>> -- Looking for ffmpeg/avformat.h - not found
>> -- Looking for ffmpeg/avcodec.h
>> -- Looking for ffmpeg/avcodec.h - not found
>> -- Performing Test HAS_AVMEDIA_TYPE_VIDEO
>> -- Performing Test HAS_AVMEDIA_TYPE_VIDEO - Success
>> -- Looking for dAllocateODEDataForThread
>> -- Looking for dAllocateODEDataForThread - found
>> -- Detected ODE multi-threading extensions, but not sure if should enable
>> them... define ODE_USE_MULTITHREAD variable to use them
>> -- Performing Test NEED_TRIINDEX
>> -- Performing Test NEED_TRIINDEX - Failed
>> -- ODE found, building oderave plugin, precision=DOUBLE
>> -- Looking for XOpenDisplay in
>> /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so
>> -- Looking for XOpenDisplay in
>> /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so
>> -
>> found
>> -- Looking for gethostbyname
>> -- Looking for gethostbyname - found
>> -- Looking for connect
>> -- Looking for connect - found
>> -- Looking for remove
>> -- Looking for remove - found
>> -- Looking for shmat
>> -- Looking for shmat - found
>> -- Looking for IceConnectionNumber in ICE
>> -- Looking for IceConnectionNumber in ICE - found
>> -- Found X11: /usr/lib/x86_64-linux-gnu/libX11.so
>> -- Found OpenGL: /usr/lib/x86_64-linux-gnu/libGL.so
>> -- Detected SoQt/Coin3D GUI, making plugin
>> -- Looking for X11/Xlib.h
>> -- Looking for X11/Xlib.h - found
>> -- boost regex found
>> -- Configuring done
>> -- Generating done
>> -- Build files have been written to: /home/len/workspace/openrave/build
>> cd build && make
>> make[1]: Entering directory `/home/len/workspace/openrave/build'
>> make[2]: Entering directory `/home/len/workspace/openrave/build'
>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>
>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>> [  1%] Built target openrave-md5
>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>
>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>> [  3%] Built target cpp-gen-md5
>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>> Scanning dependencies of target interfacehashes_target
>>
>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>> [  3%] Built target interfacehashes_target
>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>
>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>> [ 19%] Built target crlibm
>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>
>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>> [ 21%] Built target minizip
>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>
>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>> [ 22%] Built target ivcon
>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>
>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>> [ 30%] Built target ANN
>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>
>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>> [ 31%] Built target fparser
>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>
>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>> [ 37%] Built target convexdecomposition
>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>
>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>> [ 38%] Built target check_libm_accuracy
>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>
>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>> [ 46%] Built target libopenrave
>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>
>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>
>> Linking CXX shared library libopenrave-core0.7.so
>> /usr/bin/ld: cannot find -lassimp
>> /usr/bin/ld: cannot find -lassimp
>> collect2: ld returned 1 exit status
>> make[3]: *** [src/libopenrave-core/libopenrave-core0.7.so.0.7.0] Error 1
>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>> make[2]: *** [src/libopenrave-core/CMakeFiles/libopenrave-core.dir/all]
>> Error 2
>> make[2]: Leaving directory `/home/len/workspace/openrave/build'
>> make[1]: *** [all] Error 2
>> make[1]: Leaving directory `/home/len/workspace/openrave/build'
>> make: *** [all] Error 2
>>
>> On 16/05/12 18:06, Rosen Diankov wrote:
>>
>> hi beatriz,
>>
>> we would need the entire log of the cmake output, not just the small
>> part that crashed.
>>
>> that's weird, the error says the assimp library does not exist. But
>> openrave only compiles with assimp if
>>
>> pkg-config --libs assimp
>>
>> returns -lassimp
>>
>> can you check if you have a assimp.pc file in your system?
>>
>> rosen,
>>
>> 2012/5/17 Beatriz <[hidden email]>:
>>
>> Hi Rosen,
>>
>> I am trying to install openrave from sources on Ubuntu 12.04 and it is
>> giving me the following error:
>>
>> [ 49%] Building CXX object
>> src/libopenrave-core/CMakeFiles/libopenrave-core.dir/generictrajectory.cpp.o
>> [ 50%] Building CXX object
>> src/libopenrave-core/CMakeFiles/libopenrave-core.dir/colladaparser/colladareader.cpp.o
>> [ 50%] Building CXX object
>> src/libopenrave-core/CMakeFiles/libopenrave-core.dir/colladaparser/colladawriter.cpp.o
>> [ 51%] Building CXX object
>> src/libopenrave-core/CMakeFiles/libopenrave-core.dir/xfileparser/XFileParser.cpp.o
>> [ 52%] Building CXX object
>> src/libopenrave-core/CMakeFiles/libopenrave-core.dir/xfileparser/XFileBindings.cpp.o
>> Linking CXX shared library libopenrave-core0.7.so
>> /usr/bin/ld: cannot find -lassimp
>> /usr/bin/ld: cannot find -lassimp
>> collect2: ld returned 1 exit status
>> make[3]: *** [src/libopenrave-core/libopenrave-core0.7.so.0.7.0] Error 1
>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>> make[2]: *** [src/libopenrave-core/CMakeFiles/libopenrave-core.dir/all]
>> Error 2
>> make[2]: Leaving directory `/home/len/workspace/openrave/build'
>> make[1]: *** [all] Error 2
>> make[1]: Leaving directory `/home/len/workspace/openrave/build'
>> make: *** [all] Error 2
>>
>> Any idea how can I solve it?
>>
>> Thanks,
>> Beatriz
>>
>>
>> On 09/05/12 06:27, Rosen Diankov wrote:
>>
>> Hi Nash, Billy,
>>
>> the "sudo apt-get build-dep openrave" is used for source installs to
>> bring in the dependencies. They are:
>>
>> libode
>> boost
>> coin3d
>> soqt
>> python-dev
>> python-numpy
>>
>> if you install these manually, you could ignore the build-dep step
>>
>> rosen,
>>
>> 2012/5/9 Billy Okal<[hidden email]>:
>>
>> Hey Nash,
>>
>>
>> As you can seen in the previous mail, there wont be deb packages for
>> 12.04
>> just yet (for about a month).
>> You can however build openrave from sources using the instructions here
>>
>> http://openrave.org/en/coreapihtml/installation_linux.html
>>
>>
>> Best,
>>
>> billy
>>
>>
>> On Tuesday, May 8, 2012 at 9:23 PM, nash911 wrote:
>>
>> Hi Rosen,
>>
>> Following the instruction on
>> [http://openrave.org/en/coreapihtml/installation_linux.html] for
>> installing
>> OpenRave by compiling the source on Ubuntu 12.04, I got the following
>> error,
>>
>>
>> W: Failed to fetch
>> http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/source/Sources
>> 404 Not Found
>>
>> W: Failed to fetch
>> http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/binary-amd64/Packages
>> 404 Not Found
>>
>> W: Failed to fetch
>> http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/binary-i386/Packages
>> 404 Not Found
>>
>> E: Some index files failed to download. They have been ignored, or old
>> ones
>> used instead.
>> nash@nashLab:~$ sudo apt-get build-dep openrave
>> Reading package lists... Done
>> Building dependency tree
>> Reading state information... Done
>> E: Unable to find a source package for openrave
>>
>>
>>
>> Please advice. Thank You.
>>
>> --
>> View this message in context:
>> http://openrave-users-list.185357.n3.nabble.com/Installing-OpenRAVE-on-Ubuntu-12-04-LTS-tp3954269p3972306.html
>> Sent from the OpenRAVE Users List mailing list archive at Nabble.com.
>>
>> ------------------------------------------------------------------------------
>> Live Security Virtual Conference
>> Exclusive live event will cover all the ways today's security and
>> threat landscape has changed and how IT managers can respond. Discussions
>> will include endpoint security, mobile security and the latest in malware
>> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
>> _______________________________________________
>> Openrave-users mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/openrave-users
>>
>>
>>
>> ------------------------------------------------------------------------------
>> Live Security Virtual Conference
>> Exclusive live event will cover all the ways today's security and
>> threat landscape has changed and how IT managers can respond. Discussions
>> will include endpoint security, mobile security and the latest in malware
>> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
>> _______________________________________________
>> Openrave-users mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/openrave-users
>>
>> ------------------------------------------------------------------------------
>> Live Security Virtual Conference
>> Exclusive live event will cover all the ways today's security and
>> threat landscape has changed and how IT managers can respond. Discussions
>> will include endpoint security, mobile security and the latest in malware
>> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
>> _______________________________________________
>> Openrave-users mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/openrave-users
>>
>> ------------------------------------------------------------------------------
>> Live Security Virtual Conference
>> Exclusive live event will cover all the ways today's security and
>> threat landscape has changed and how IT managers can respond. Discussions
>> will include endpoint security, mobile security and the latest in malware
>> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
>> _______________________________________________
>> Openrave-users mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/openrave-users
>>
>>
>
> ------------------------------------------------------------------------------
> Live Security Virtual Conference
> Exclusive live event will cover all the ways today's security and
> threat landscape has changed and how IT managers can respond. Discussions
> will include endpoint security, mobile security and the latest in malware
> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
> _______________________________________________
> Openrave-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/openrave-users
>


--
Christopher Dellin
[hidden email]

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Installing OpenRAVE on Ubuntu 12.04 LTS

Rosen Diankov
Administrator
hi chris,

excellent patch! next time, please put 'rdiankov' in the cc list, or
else i won't get the notification

rosen,

2012/5/17 Chris Dellin <[hidden email]>:

> Rosen, just an fyi, I submitted a patch for this as part of ticket 271.
> http://sourceforge.net/apps/trac/openrave/ticket/271
> - Chris
>
> On 5/16/12, Rosen Diankov <[hidden email]> wrote:
>> Beatriz, Prof Okada
>>
>> the assimp package is not available for 12.04 yet... sorry about that.
>>
>> The Debugging vs DEBUGGING change is very interesting indeened. it looks
>> like openrave has been relying on old assimp headers..! we'll change
>> this with the next update to
>>
>> Beatriz, please remove assimp.pc from your system and try again
>> rosen,
>>
>> 2012/5/17 Beatriz <[hidden email]>:
>>> Hi Rosen,
>>>
>>> Yes, I have it in /usr/lib/pkgconfig
>>>
>>> @k-okada, thanks for the suggestion, but when I try to install it this is
>>> the error that I get:
>>>
>>> The following NEW packages will be installed:
>>>   libassimp-dev
>>> 0 upgraded, 1 newly installed, 0 to remove and 2 not upgraded.
>>> Need to get 0 B/94.4 kB of archives.
>>> After this operation, 470 kB of additional disk space will be used.
>>> (Reading database ... 385425 files and directories currently installed.)
>>> Unpacking libassimp-dev (from .../libassimp-dev_2.0.863+dfsg-2_amd64.deb)
>>> ...
>>> dpkg: error processing
>>> /var/cache/apt/archives/libassimp-dev_2.0.863+dfsg-2_amd64.deb
>>> (--unpack):
>>>  trying to overwrite '/usr/include/assimp/aiQuaternion.h', which is also
>>> in
>>> package assimp-dev 2.0.0.6-ubuntu1~natty1
>>> Errors were encountered while processing:
>>>  /var/cache/apt/archives/libassimp-dev_2.0.863+dfsg-2_amd64.deb
>>> E: Sub-process /usr/bin/dpkg returned an error code (1)
>>>
>>> I don't know if it is related with this issue:
>>> http://ubuntuforums.org/showthread.php?p=11936769
>>>
>>>
>>> This is the complete output when doing make of openrave
>>>
>>> len@acad8088:~/workspace/openrave$ make
>>> -- The C compiler identification is GNU
>>> -- The CXX compiler identification is GNU
>>> -- Check for working C compiler: /usr/bin/gcc
>>> -- Check for working C compiler: /usr/bin/gcc -- works
>>> -- Detecting C compiler ABI info
>>> -- Detecting C compiler ABI info - done
>>> -- Check for working CXX compiler: /usr/bin/c++
>>> -- Check for working CXX compiler: /usr/bin/c++ -- works
>>> -- Detecting CXX compiler ABI info
>>> -- Detecting CXX compiler ABI info - done
>>> -- Compiling OpenRAVE Version 0.7.0, soversion=0.7
>>> -- Using cmake version 2.8.7
>>> -- Using double precision
>>> -- detected system processor: x86_64
>>> -- Found PythonInterp: /usr/bin/python (found version "2.7.3")
>>> -- Found PythonLibs: /usr/lib/libpython2.7.so
>>> -- installing to /usr/local, python subdir is
>>> lib/python2.7/dist-packages,
>>> program suffix is '0.7'
>>> -- Performing Test LINKER_HAS_RDYNAMIC
>>> -- Performing Test LINKER_HAS_RDYNAMIC - Success
>>> -- Performing Test LINKER_HAS_BSYMBOLIC
>>> -- Performing Test LINKER_HAS_BSYMBOLIC - Success
>>> -- Performing Test LINKER_HAS_BSYMBOLIC_FUNCTIONS
>>> -- Performing Test LINKER_HAS_BSYMBOLIC_FUNCTIONS - Success
>>> -- Performing Test LINKER_HAS_VISIBILITY
>>> -- Performing Test LINKER_HAS_VISIBILITY - Success
>>> -- Performing Test LINKER_HAS_VISIBILITY_INLINES_HIDDEN
>>> -- Performing Test LINKER_HAS_VISIBILITY_INLINES_HIDDEN - Success
>>> -- Boost version: 1.46.1
>>> -- Found the following Boost libraries:
>>> --   regex
>>> --   filesystem
>>> --   system
>>> --   python
>>> --   thread
>>> --   iostreams
>>> --   date_time
>>> -- found boost version: 104601
>>> -- Targetting Unix Makefiles
>>> -- Using /usr/bin/c++ compiler.
>>> -- Found GMP: /usr/lib/x86_64-linux-gnu/libgmp.so
>>> -- Found GMPXX: /usr/lib/x86_64-linux-gnu/libgmpxx.so
>>> -- Found MPFR: /usr/lib/x86_64-linux-gnu/libmpfr.so
>>> -- Looking for mpfr_div_d in /usr/lib/x86_64-linux-gnu/libmpfr.so
>>> -- Looking for mpfr_div_d in /usr/lib/x86_64-linux-gnu/libmpfr.so - found
>>> -- Found MPFI: /usr/lib/libmpfi.so
>>> -- Looking for crlibm_init in crlibm
>>> -- Looking for crlibm_init in crlibm - not found
>>> -- Looking for crlibm.h
>>> -- Looking for crlibm.h - not found
>>> -- Using local crlibm
>>> -- Looking for fpu_control.h
>>> -- Looking for fpu_control.h - found
>>> -- Looking for fenv.h
>>> -- Looking for fenv.h - found
>>> -- Looking for inttypes.h
>>> -- Looking for inttypes.h - found
>>> -- Check size of long double
>>> -- Check size of long double - done
>>> -- compiling with double extended (long double) floating point
>>> -- checking for module 'assimp'
>>> --   found assimp, version 2.0
>>> -- Performing Test IS_X86_64
>>> -- Performing Test IS_X86_64 - Success
>>> -- Looking for clock_gettime in rt
>>> -- Looking for clock_gettime in rt - found
>>> -- WARNING: you are using the obsolete 'PKGCONFIG' macro, use
>>> FindPkgConfig
>>> -- Found LibXml2: /usr/lib/x86_64-linux-gnu/libxml2.so
>>> -- libxml2 found
>>> -- Looking for Q_WS_X11
>>> -- Looking for Q_WS_X11 - found
>>> -- Looking for Q_WS_WIN
>>> -- Looking for Q_WS_WIN - not found.
>>> -- Looking for Q_WS_QWS
>>> -- Looking for Q_WS_QWS - not found.
>>> -- Looking for Q_WS_MAC
>>> -- Looking for Q_WS_MAC - not found.
>>> -- Found Qt4: /usr/bin/qmake (found version "4.8.1")
>>> -- Found ZLIB: /usr/lib/x86_64-linux-gnu/libz.so (found version
>>> "1.2.3.4")
>>> -- checking for module 'minizip'
>>> --   package 'minizip' not found
>>> -- Looking for qh_new_qhull in qhull
>>> -- Looking for qh_new_qhull in qhull - found
>>> -- Looking for qhull/qhull_a.h
>>> -- Looking for qhull/qhull_a.h - found
>>> -- Looking for C++ include ANN/ANN.h
>>> -- Looking for C++ include ANN/ANN.h - not found
>>> -- compiling local ann library
>>> CMake Warning at CMakeLists.txt:673 (find_package):
>>>   Could not find module FindFPARSER.cmake or a configuration file for
>>> package
>>>   FPARSER.
>>>
>>>   Adjust CMAKE_MODULE_PATH to find FindFPARSER.cmake or set FPARSER_DIR
>>> to
>>>   the directory containing a CMake configuration file for FPARSER.  The
>>> file
>>>   will have one of the following names:
>>>
>>>     FPARSERConfig.cmake
>>>     fparser-config.cmake
>>>
>>>
>>>
>>> -- compiling local fparser library
>>> -- Check size of float
>>> -- Check size of float - done
>>> -- Check size of long int
>>> -- Check size of long int - done
>>> -- Looking for alloca.h
>>> -- Looking for alloca.h - found
>>> -- Looking for strtof
>>> -- Looking for strtof - found
>>> -- Looking for strtold
>>> -- Looking for strtold - found
>>> -- Check size of long double
>>> -- Check size of long double - done
>>> -- compiling local convexdecomposition library
>>> -- Looking for C++ include ext/hash_map
>>> -- Looking for C++ include ext/hash_map - found
>>> -- Looking for asinh
>>> -- Looking for asinh - not found
>>> -- Looking for acosh
>>> -- Looking for acosh - not found
>>> -- Looking for atanh
>>> -- Looking for atanh - not found
>>> -- Looking for exp2
>>> -- Looking for exp2 - not found
>>> -- Looking for log2
>>> -- Looking for log2 - not found
>>> -- Looking for mkstemp
>>> -- Looking for mkstemp - found
>>> -- Geometry Parsing: Using Open Asset Import Library (assimp)
>>> -- Geometry Parsing: Using ivcon
>>> -- extracting models to /home/len/workspace/openrave/src
>>> -- Looking for _init in lapack
>>> -- Looking for _init in lapack - not found
>>> -- Matlab detected, compiling matlab mex files
>>> -- Octave installation not found, is 'mkoctfile' in the system path?
>>> -- Performing Test HAVE_ALL_PYTHON_HEADERS
>>> -- Performing Test HAVE_ALL_PYTHON_HEADERS - Success
>>> -- python and boost-python found
>>> -- checking for module 'bullet'
>>> --   found bullet, version 2.77
>>> -- checking for modules 'libavformat;libavcodec'
>>> --   found libavformat, version 53.21.0
>>> --   found libavcodec, version 53.35.0
>>> -- enabling FFMPEG support
>>> -- checking for module 'libswscale'
>>> --   found libswscale, version 2.1.0
>>> -- Looking for libswscale/swscale.h
>>> -- Looking for libswscale/swscale.h - found
>>> -- Looking for libavformat/avformat.h
>>> -- Looking for libavformat/avformat.h - found
>>> -- Looking for libavcodec/avcodec.h
>>> -- Looking for libavcodec/avcodec.h - found
>>> -- Looking for ffmpeg/avformat.h
>>> -- Looking for ffmpeg/avformat.h - not found
>>> -- Looking for ffmpeg/avcodec.h
>>> -- Looking for ffmpeg/avcodec.h - not found
>>> -- Performing Test HAS_AVMEDIA_TYPE_VIDEO
>>> -- Performing Test HAS_AVMEDIA_TYPE_VIDEO - Success
>>> -- Looking for dAllocateODEDataForThread
>>> -- Looking for dAllocateODEDataForThread - found
>>> -- Detected ODE multi-threading extensions, but not sure if should enable
>>> them... define ODE_USE_MULTITHREAD variable to use them
>>> -- Performing Test NEED_TRIINDEX
>>> -- Performing Test NEED_TRIINDEX - Failed
>>> -- ODE found, building oderave plugin, precision=DOUBLE
>>> -- Looking for XOpenDisplay in
>>> /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so
>>> -- Looking for XOpenDisplay in
>>> /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so
>>> -
>>> found
>>> -- Looking for gethostbyname
>>> -- Looking for gethostbyname - found
>>> -- Looking for connect
>>> -- Looking for connect - found
>>> -- Looking for remove
>>> -- Looking for remove - found
>>> -- Looking for shmat
>>> -- Looking for shmat - found
>>> -- Looking for IceConnectionNumber in ICE
>>> -- Looking for IceConnectionNumber in ICE - found
>>> -- Found X11: /usr/lib/x86_64-linux-gnu/libX11.so
>>> -- Found OpenGL: /usr/lib/x86_64-linux-gnu/libGL.so
>>> -- Detected SoQt/Coin3D GUI, making plugin
>>> -- Looking for X11/Xlib.h
>>> -- Looking for X11/Xlib.h - found
>>> -- boost regex found
>>> -- Configuring done
>>> -- Generating done
>>> -- Build files have been written to: /home/len/workspace/openrave/build
>>> cd build && make
>>> make[1]: Entering directory `/home/len/workspace/openrave/build'
>>> make[2]: Entering directory `/home/len/workspace/openrave/build'
>>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>>
>>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>>> [  1%] Built target openrave-md5
>>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>>
>>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>>> [  3%] Built target cpp-gen-md5
>>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>> Scanning dependencies of target interfacehashes_target
>>>
>>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>>> [  3%] Built target interfacehashes_target
>>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>>
>>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>>> [ 19%] Built target crlibm
>>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>>
>>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>>> [ 21%] Built target minizip
>>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>>
>>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>>> [ 22%] Built target ivcon
>>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>>
>>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>>> [ 30%] Built target ANN
>>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>>
>>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>>> [ 31%] Built target fparser
>>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>>
>>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>>> [ 37%] Built target convexdecomposition
>>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>>
>>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>>> [ 38%] Built target check_libm_accuracy
>>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>>
>>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>>> [ 46%] Built target libopenrave
>>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>>
>>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>>> make[3]: Entering directory `/home/len/workspace/openrave/build'
>>>
>>> Linking CXX shared library libopenrave-core0.7.so
>>> /usr/bin/ld: cannot find -lassimp
>>> /usr/bin/ld: cannot find -lassimp
>>> collect2: ld returned 1 exit status
>>> make[3]: *** [src/libopenrave-core/libopenrave-core0.7.so.0.7.0] Error 1
>>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>>> make[2]: *** [src/libopenrave-core/CMakeFiles/libopenrave-core.dir/all]
>>> Error 2
>>> make[2]: Leaving directory `/home/len/workspace/openrave/build'
>>> make[1]: *** [all] Error 2
>>> make[1]: Leaving directory `/home/len/workspace/openrave/build'
>>> make: *** [all] Error 2
>>>
>>> On 16/05/12 18:06, Rosen Diankov wrote:
>>>
>>> hi beatriz,
>>>
>>> we would need the entire log of the cmake output, not just the small
>>> part that crashed.
>>>
>>> that's weird, the error says the assimp library does not exist. But
>>> openrave only compiles with assimp if
>>>
>>> pkg-config --libs assimp
>>>
>>> returns -lassimp
>>>
>>> can you check if you have a assimp.pc file in your system?
>>>
>>> rosen,
>>>
>>> 2012/5/17 Beatriz <[hidden email]>:
>>>
>>> Hi Rosen,
>>>
>>> I am trying to install openrave from sources on Ubuntu 12.04 and it is
>>> giving me the following error:
>>>
>>> [ 49%] Building CXX object
>>> src/libopenrave-core/CMakeFiles/libopenrave-core.dir/generictrajectory.cpp.o
>>> [ 50%] Building CXX object
>>> src/libopenrave-core/CMakeFiles/libopenrave-core.dir/colladaparser/colladareader.cpp.o
>>> [ 50%] Building CXX object
>>> src/libopenrave-core/CMakeFiles/libopenrave-core.dir/colladaparser/colladawriter.cpp.o
>>> [ 51%] Building CXX object
>>> src/libopenrave-core/CMakeFiles/libopenrave-core.dir/xfileparser/XFileParser.cpp.o
>>> [ 52%] Building CXX object
>>> src/libopenrave-core/CMakeFiles/libopenrave-core.dir/xfileparser/XFileBindings.cpp.o
>>> Linking CXX shared library libopenrave-core0.7.so
>>> /usr/bin/ld: cannot find -lassimp
>>> /usr/bin/ld: cannot find -lassimp
>>> collect2: ld returned 1 exit status
>>> make[3]: *** [src/libopenrave-core/libopenrave-core0.7.so.0.7.0] Error 1
>>> make[3]: Leaving directory `/home/len/workspace/openrave/build'
>>> make[2]: *** [src/libopenrave-core/CMakeFiles/libopenrave-core.dir/all]
>>> Error 2
>>> make[2]: Leaving directory `/home/len/workspace/openrave/build'
>>> make[1]: *** [all] Error 2
>>> make[1]: Leaving directory `/home/len/workspace/openrave/build'
>>> make: *** [all] Error 2
>>>
>>> Any idea how can I solve it?
>>>
>>> Thanks,
>>> Beatriz
>>>
>>>
>>> On 09/05/12 06:27, Rosen Diankov wrote:
>>>
>>> Hi Nash, Billy,
>>>
>>> the "sudo apt-get build-dep openrave" is used for source installs to
>>> bring in the dependencies. They are:
>>>
>>> libode
>>> boost
>>> coin3d
>>> soqt
>>> python-dev
>>> python-numpy
>>>
>>> if you install these manually, you could ignore the build-dep step
>>>
>>> rosen,
>>>
>>> 2012/5/9 Billy Okal<[hidden email]>:
>>>
>>> Hey Nash,
>>>
>>>
>>> As you can seen in the previous mail, there wont be deb packages for
>>> 12.04
>>> just yet (for about a month).
>>> You can however build openrave from sources using the instructions here
>>>
>>> http://openrave.org/en/coreapihtml/installation_linux.html
>>>
>>>
>>> Best,
>>>
>>> billy
>>>
>>>
>>> On Tuesday, May 8, 2012 at 9:23 PM, nash911 wrote:
>>>
>>> Hi Rosen,
>>>
>>> Following the instruction on
>>> [http://openrave.org/en/coreapihtml/installation_linux.html] for
>>> installing
>>> OpenRave by compiling the source on Ubuntu 12.04, I got the following
>>> error,
>>>
>>>
>>> W: Failed to fetch
>>> http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/source/Sources
>>> 404 Not Found
>>>
>>> W: Failed to fetch
>>> http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/binary-amd64/Packages
>>> 404 Not Found
>>>
>>> W: Failed to fetch
>>> http://ppa.launchpad.net/openrave/release/ubuntu/dists/precise/main/binary-i386/Packages
>>> 404 Not Found
>>>
>>> E: Some index files failed to download. They have been ignored, or old
>>> ones
>>> used instead.
>>> nash@nashLab:~$ sudo apt-get build-dep openrave
>>> Reading package lists... Done
>>> Building dependency tree
>>> Reading state information... Done
>>> E: Unable to find a source package for openrave
>>>
>>>
>>>
>>> Please advice. Thank You.
>>>
>>> --
>>> View this message in context:
>>> http://openrave-users-list.185357.n3.nabble.com/Installing-OpenRAVE-on-Ubuntu-12-04-LTS-tp3954269p3972306.html
>>> Sent from the OpenRAVE Users List mailing list archive at Nabble.com.
>>>
>>> ------------------------------------------------------------------------------
>>> Live Security Virtual Conference
>>> Exclusive live event will cover all the ways today's security and
>>> threat landscape has changed and how IT managers can respond. Discussions
>>> will include endpoint security, mobile security and the latest in malware
>>> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
>>> _______________________________________________
>>> Openrave-users mailing list
>>> [hidden email]
>>> https://lists.sourceforge.net/lists/listinfo/openrave-users
>>>
>>>
>>>
>>> ------------------------------------------------------------------------------
>>> Live Security Virtual Conference
>>> Exclusive live event will cover all the ways today's security and
>>> threat landscape has changed and how IT managers can respond. Discussions
>>> will include endpoint security, mobile security and the latest in malware
>>> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
>>> _______________________________________________
>>> Openrave-users mailing list
>>> [hidden email]
>>> https://lists.sourceforge.net/lists/listinfo/openrave-users
>>>
>>> ------------------------------------------------------------------------------
>>> Live Security Virtual Conference
>>> Exclusive live event will cover all the ways today's security and
>>> threat landscape has changed and how IT managers can respond. Discussions
>>> will include endpoint security, mobile security and the latest in malware
>>> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
>>> _______________________________________________
>>> Openrave-users mailing list
>>> [hidden email]
>>> https://lists.sourceforge.net/lists/listinfo/openrave-users
>>>
>>> ------------------------------------------------------------------------------
>>> Live Security Virtual Conference
>>> Exclusive live event will cover all the ways today's security and
>>> threat landscape has changed and how IT managers can respond. Discussions
>>> will include endpoint security, mobile security and the latest in malware
>>> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
>>> _______________________________________________
>>> Openrave-users mailing list
>>> [hidden email]
>>> https://lists.sourceforge.net/lists/listinfo/openrave-users
>>>
>>>
>>
>> ------------------------------------------------------------------------------
>> Live Security Virtual Conference
>> Exclusive live event will cover all the ways today's security and
>> threat landscape has changed and how IT managers can respond. Discussions
>> will include endpoint security, mobile security and the latest in malware
>> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
>> _______________________________________________
>> Openrave-users mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/openrave-users
>>
>
>
> --
> Christopher Dellin
> [hidden email]

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Installing OpenRAVE on Ubuntu 12.04 LTS

abiravi
In reply to this post by k-okada@jsk.t.u-tokyo.ac.jp
Hi,

There was a problem in making the OpenRAVE sources in 10.04 for me.
However by interchanging the the assimp Logger in xmlreaders-core.cpp to the following :

#ifdef OPENRAVE_ASSIMP_PRE_R896
    const unsigned int severity = Logger::Debugging|Logger::Info|Logger::Warn|Logger::Err;
#else
    const unsigned int severity = Logger::DEBUGGING|Logger::INFO|Logger::WARN|Logger::ERR;
#endif

the make was fine.

Is this the right way to solve the issue ?

Best Regards
Ravi
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Installing OpenRAVE on Ubuntu 12.04 LTS

Rosen Diankov
Administrator
Dear Ravi,

The latest versions of assimp have ErrorSeverity defined as:

    enum ErrorSeverity
    {
        Debugging    = 1,    //!< Debug log message
        Info        = 2,     //!< Info log message
        Warn        = 4,    //!< Warn log message
        Err            = 8        //!< Error log message
    };

which means the check is correct, and for some reason
OPENRAVE_ASSIMP_PRE_R896 is getting defined for you. did you switch
assimp libraries in your system?

rosen,


2013/2/21 abiravi <[hidden email]>:

> Hi,
>
> There was a problem in making the OpenRAVE sources in 10.04 for me.
> However by interchanging the the assimp Logger in xmlreaders-core.cpp to the
> following :
>
> #ifdef OPENRAVE_ASSIMP_PRE_R896
>     const unsigned int severity =
> Logger::Debugging|Logger::Info|Logger::Warn|Logger::Err;
> #else
>     const unsigned int severity =
> Logger::DEBUGGING|Logger::INFO|Logger::WARN|Logger::ERR;
> #endif
>
> the make was fine.
>
> Is this the right way to solve the issue ?
>
> Best Regards
> Ravi
>
>
>
> --
> View this message in context: http://openrave-users-list.185357.n3.nabble.com/Installing-OpenRAVE-on-Ubuntu-12-04-LTS-tp3954269p4026061.html
> Sent from the OpenRAVE Users List mailing list archive at Nabble.com.
>
> ------------------------------------------------------------------------------
> Everyone hates slow websites. So do we.
> Make your web apps faster with AppDynamics
> Download AppDynamics Lite for free today:
> http://p.sf.net/sfu/appdyn_d2d_feb
> _______________________________________________
> Openrave-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/openrave-users

------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_feb
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Installing OpenRAVE on Ubuntu 12.04 LTS

waldezjr
Hi every one

I ve been trying to install open rave on my ubuntu 12.04 but i keep getting these error messages:

waldezjr@waldezjr-K52JT:~/catkin_ws/src/beginner_tutorials$ sudo apt-get install openrave
Reading package lists... Done
Building dependency tree      
Reading state information... Done
openrave is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 openrave0.8-dp-plugin-bulletrave : Depends: libbullet2.80 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).



The problems looks to be in the libbullet2.80 not being installed but whenever  I try to install it i get these errors:

waldezjr@waldezjr-K52JT:~/catkin_ws/src/beginner_tutorials$ sudo apt-get install libbullet2.80
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following packages were automatically installed and are no longer required:
  gir1.2-ubuntuoneui-3.0 libubuntuoneui-3.0-1 thunderbird-globalmenu
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
  libbullet2.80
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
1 not fully installed or removed.
Need to get 0 B/1,008 kB of archives.
After this operation, 2,599 kB of additional disk space will be used.
(Reading database ... 284072 files and directories currently installed.)
Unpacking libbullet2.80 (from .../libbullet2.80_2.80.2-ubuntu1~precise1_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libbullet2.80_2.80.2-ubuntu1~precise1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/libHACD.so.2.80', which is also in package libbullet 2.80-0
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libbullet2.80_2.80.2-ubuntu1~precise1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)



Furthermore ubuntu tries to update the system to solve the issue but keeps getting the same errors over and over again.And it also doesnt seem to be a very common problem to most users since my google search about similar problems wasnt very useful, anyway, you guys have any idea on how i could possibly sort this out?

any insight will be very much appreciated
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Installing OpenRAVE on Ubuntu 12.04 LTS

waldezjr
Nevermind, I got it working by simply downloading and unpacking the libbullet and libbullet-dev packages from the source, sorry if caused any sort of trouble.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Installing OpenRAVE on Ubuntu 12.04 LTS

ktiwari9
In reply to this post by Felix
CONTENTS DELETED
The author has deleted this message.
Loading...