Issues installing OpenRave

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Issues installing OpenRave

Connor Schenck
If this is the wrong list to send this to, please point me in the right direction and I can send it there.

I'm running Ubuntu 14.04 and I'm having issues trying to get OpenRave set up. I've been following the instructions on the openrave website for installing from git hub (installing from repo didn't work), but when I get to the cmake step, cmake complains of not being able to find a bunch of OpenSceneGraph libraries (I attached the cmake output). I couldn't find OpenSceneGraph in any repo or deb form, so I installed it from source. The attached output is what I get after running cmake on openrave after installing openscenegraph from source.

I'm not really sure how OpenRave depends on OpenSceneGraph, so I'm not sure how to go about debugging this issue. If anyone has any insights and can point me in the right direction, I would greatly appreciate it.

Thank you,
Connor

------------------------------------------------------------------------------

_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users

openrave_output.txt (16K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Issues installing OpenRave

caron
Hi Connor,

On 2015年07月23日 09:10, Connor Schenck [via OpenRAVE Users List] wrote:
> I couldn't find OpenSceneGraph in any repo or deb form, so I installed it from source.

There is a package called openscenegraph in the Ubuntu official repository. Libraries and dev files are in separate packages called libopenscenegraph-dev. You can install it via:

sudo apt-get install openscenegraph libopenscenegraph-dev

I could compile openrave from source using these ones.

Hope this helps,

Stephane
Stéphane Caron
https://scaron.info
Reply | Threaded
Open this post in threaded view
|

Re: Issues installing OpenRave

Franks
im sorry but is this OpenRAVE/IKFast only good for ubuntu ?im on win 8.1 x64 and i have had Zero luck with Visual Studio 2013