No grasps found - 6DOF value is not in limits

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

No grasps found - 6DOF value is not in limits

softy
Hello,
i have a problem with a grasping an object. I work on a problem called "bin-picking". We have a Kuka KR16-2 robot (6 axes) and Schunk 160 (2 finger parallel) gripper and metal forgings. I made a kinematic model for all of them (i attached a zip). But when I run a command (openrave.py --database grasping --robot=K16.xml --manipname=Schunk160 --target=forging/forging.kinbody.xml --graspingnoise=0.003) i see "dof 6 value is not in limits"
I check fingers closing via python script. Its move correctly, but after every close or release command this warning message is shown.
When i run an example script fastgraspingthreaded (with my scene - only robot and forging) i see messeage "found 0 grasps".
I try different settings of graping steps sizes. Sometimes is some grasps found, but this founded grasps isn't grasp, it seem like touches between one finger (edge of finger) and object.
Example graspplanning crash with error:
File "mtrand.pyx", line 874, in mtrand.RandomState.randint (numpy/random/mtrand/mtrand.c:5970)
ValueError: low >= high
after message "starting to pick and place random objects".

I use Ubuntu 12.04 and openrave 0.8

Thanks for help and sorry for my english.

K16.zip