OpenRave dependencies install

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

OpenRave dependencies install

pmonso
I'm trying to install OpenRave through the ros package. http://www.ros.org/wiki/openrave

since it was complaining about missing soqt, I installed it http://www.ros.org/wiki/soqt

When compiling soqt, I get the following message:

checking if we can compile and link with the Coin library... false
  configure: WARNING:
  Compilation and/or linking with the Coin main library SDK failed, for
  unknown reason. If you are familiar with configure-based configuration
  and building, investigate the 'config.log' file for clues.
 
  If you can not figure out what went wrong, please forward the 'config.log'
  file to the email address <coin-support@coin3d.org> and ask for help by
  describing the situation where this failed.
 
  configure: error: couldn't compile and link against Coin

I did install libcoin40-dev and libcoin40c2 and got the same message, as well as with installing libcoin60 and libsoqt

Since I doubt I have to download coin from their website, what's wrong? What packages is soqt expecting?


Reply | Threaded
Open this post in threaded view
|

Re: OpenRave dependencies install

pmonso

I forgot to mention I'm on ubuntu 10.04, with ros ros-cturtle-pr2all installed and working

2010/11/10 pmonso <[hidden email]>

I'm trying to install OpenRave through the ros package.
http://www.ros.org/wiki/openrave

since it was complaining about missing soqt, I installed it
http://www.ros.org/wiki/soqt

When compiling soqt, I get the following message:

checking if we can compile and link with the Coin library... false
 configure: WARNING:
 Compilation and/or linking with the Coin main library SDK failed, for
 unknown reason. If you are familiar with configure-based configuration
 and building, investigate the 'config.log' file for clues.

 If you can not figure out what went wrong, please forward the 'config.log'
 file to the email address <[hidden email]> and ask for help by
 describing the situation where this failed.

 configure: error: couldn't compile and link against Coin

I did install libcoin40-dev and libcoin40c2 and got the same message, as
well as with installing libcoin60 and libsoqt

Since I doubt I have to download coin from their website, what's wrong? What
packages is soqt expecting?



--
View this message in context: http://openrave-users-list.185357.n3.nabble.com/OpenRave-dependencies-install-tp1876069p1876069.html
Sent from the OpenRAVE Users List mailing list archive at Nabble.com.

------------------------------------------------------------------------------
The Next 800 Companies to Lead America's Growth: New Video Whitepaper
David G. Thomson, author of the best-selling book "Blueprint to a
Billion" shares his insights and actions to help propel your
business during the next growth cycle. Listen Now!
http://p.sf.net/sfu/SAP-dev2dev
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users


------------------------------------------------------------------------------
The Next 800 Companies to Lead America's Growth: New Video Whitepaper
David G. Thomson, author of the best-selling book "Blueprint to a
Billion" shares his insights and actions to help propel your
business during the next growth cycle. Listen Now!
http://p.sf.net/sfu/SAP-dev2dev
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Reply | Threaded
Open this post in threaded view
|

Re: OpenRave dependencies install

Rosen Diankov
Administrator
hi pol,

You shouldn't have any problems if you are on ubuntu....after
re-installing coin-dev, have you tried to make wipe the soqt ros
package before re-making?

If so, and it still doesn't work. Send the config.log (or better yet,
ask the soqt developers)

rosen,

2010/11/10 Pol Monsó <[hidden email]>:

>
> I forgot to mention I'm on ubuntu 10.04, with ros ros-cturtle-pr2all
> installed and working
>
> 2010/11/10 pmonso <[hidden email]>
>>
>> I'm trying to install OpenRave through the ros package.
>> http://www.ros.org/wiki/openrave
>>
>> since it was complaining about missing soqt, I installed it
>> http://www.ros.org/wiki/soqt
>>
>> When compiling soqt, I get the following message:
>>
>> checking if we can compile and link with the Coin library... false
>>  configure: WARNING:
>>  Compilation and/or linking with the Coin main library SDK failed, for
>>  unknown reason. If you are familiar with configure-based configuration
>>  and building, investigate the 'config.log' file for clues.
>>
>>  If you can not figure out what went wrong, please forward the
>> 'config.log'
>>  file to the email address <[hidden email]> and ask for help by
>>  describing the situation where this failed.
>>
>>  configure: error: couldn't compile and link against Coin
>>
>> I did install libcoin40-dev and libcoin40c2 and got the same message, as
>> well as with installing libcoin60 and libsoqt
>>
>> Since I doubt I have to download coin from their website, what's wrong?
>> What
>> packages is soqt expecting?
>>
>>
>>
>> --
>> View this message in context:
>> http://openrave-users-list.185357.n3.nabble.com/OpenRave-dependencies-install-tp1876069p1876069.html
>> Sent from the OpenRAVE Users List mailing list archive at Nabble.com.
>>
>>
>> ------------------------------------------------------------------------------
>> The Next 800 Companies to Lead America's Growth: New Video Whitepaper
>> David G. Thomson, author of the best-selling book "Blueprint to a
>> Billion" shares his insights and actions to help propel your
>> business during the next growth cycle. Listen Now!
>> http://p.sf.net/sfu/SAP-dev2dev
>> _______________________________________________
>> Openrave-users mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/openrave-users
>
>
> ------------------------------------------------------------------------------
> The Next 800 Companies to Lead America's Growth: New Video Whitepaper
> David G. Thomson, author of the best-selling book "Blueprint to a
> Billion" shares his insights and actions to help propel your
> business during the next growth cycle. Listen Now!
> http://p.sf.net/sfu/SAP-dev2dev
> _______________________________________________
> Openrave-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/openrave-users
>
>

------------------------------------------------------------------------------
The Next 800 Companies to Lead America's Growth: New Video Whitepaper
David G. Thomson, author of the best-selling book "Blueprint to a
Billion" shares his insights and actions to help propel your
business during the next growth cycle. Listen Now!
http://p.sf.net/sfu/SAP-dev2dev
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Reply | Threaded
Open this post in threaded view
|

Re: OpenRave dependencies install

pmonso
Hello Rosen, thanks for replying.

I tried cleaning and re-building with the same result. What package(s)
of coin do you have installed?

I'll ask soqt developers as well..

Thanks!

Pol Monsó

config.log:
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by SoQt configure 1.4.1, which was
generated by GNU Autoconf 2.65.  Invocation command line was

  $ ./configure --prefix=/home/pmonso/code/ros/stacks/soqt

## --------- ##
## Platform. ##
## --------- ##

hostname = leno3
uname -m = i686
uname -r = 2.6.32-25-generic
uname -s = Linux
uname -v = #45-Ubuntu SMP Sat Oct 16 19:48:22 UTC 2010

/usr/bin/uname -p = unknown
/bin/uname -X     = unknown

/bin/arch              = unknown
/usr/bin/arch -k       = unknown
/usr/convex/getsysinfo = unknown
/usr/bin/hostinfo      = unknown
/bin/machine           = unknown
/usr/bin/oslevel       = unknown
/bin/universe          = unknown

PATH: /opt/ros/cturtle/ros/bin
PATH: /usr/local/sbin
PATH: /usr/local/bin
PATH: /usr/sbin
PATH: /usr/bin
PATH: /sbin
PATH: /bin
PATH: /usr/games


## ----------- ##
## Core tests. ##
## ----------- ##

configure:2953: checking build system type
configure:2967: result: i686-pc-linux-gnu
configure:2987: checking host system type
configure:3000: result: i686-pc-linux-gnu
configure:3020: checking target system type
configure:3033: result: i686-pc-linux-gnu
configure:3127:
sim_ac_wrapmsvc=/home/pmonso/code/ros/stacks/soqt/build/SoQt-1.4.1/cfg/wrapmsvc.exe
configure:3128: checking setup for wrapmsvc.exe
run-detectors: unable to find an interpreter for
/home/pmonso/code/ros/stacks/soqt/build/SoQt-1.4.1/cfg/wrapmsvc.exe
configure:3212: result: not working (as expected)
configure:3427: checking for a BSD-compatible install
configure:3495: result: /usr/bin/install -c
configure:3506: checking whether build environment is sane
configure:3543: result: yes
configure:3573: checking for gawk
configure:3589: found /usr/bin/gawk
configure:3600: result: gawk
configure:3611: checking whether make sets $(MAKE)
configure:3633: result: yes
configure:3843: checking whether to enable maintainer-specific
portions of Makefiles
configure:3852: result: no
configure:3917: checking for gcc
configure:3933: found /usr/bin/gcc
configure:3944: result: gcc
configure:4173: checking for C compiler version
configure:4182: gcc --version >&5
gcc (Ubuntu 4.4.3-4ubuntu5) 4.4.3
Copyright (C) 2009 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:4193: $? = 0
configure:4182: gcc -v >&5
Using built-in specs.
Target: i486-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu
4.4.3-4ubuntu5'
--with-bugurl=file:///usr/share/doc/gcc-4.4/README.Bugs
--enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr
--enable-shared --enable-multiarch --enable-linker-build-id
--with-system-zlib --libexecdir=/usr/lib --without-included-gettext
--enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.4
--program-suffix=-4.4 --enable-nls --enable-clocale=gnu
--enable-libstdcxx-debug --enable-plugin --enable-objc-gc
--enable-targets=all --disable-werror --with-arch-32=i486
--with-tune=generic --enable-checking=release --build=i486-linux-gnu
--host=i486-linux-gnu --target=i486-linux-gnu
Thread model: posix
gcc version 4.4.3 (Ubuntu 4.4.3-4ubuntu5)
configure:4193: $? = 0
configure:4182: gcc -V >&5
gcc: '-V' option must have argument
configure:4193: $? = 1
configure:4182: gcc -qversion >&5
gcc: unrecognized option '-qversion'
gcc: no input files
configure:4193: $? = 1
configure:4213: checking whether the C compiler works
configure:4235: gcc    conftest.c  >&5
configure:4239: $? = 0
configure:4288: result: yes
configure:4291: checking for C compiler default output file name
configure:4293: result: a.out
configure:4299: checking for suffix of executables
configure:4306: gcc -o conftest    conftest.c  >&5
configure:4310: $? = 0
configure:4332: result:
configure:4354: checking whether we are cross compiling
configure:4362: gcc -o conftest    conftest.c  >&5
configure:4366: $? = 0
configure:4373: ./conftest
configure:4377: $? = 0
configure:4392: result: no
configure:4397: checking for suffix of object files
configure:4419: gcc -c   conftest.c >&5
configure:4423: $? = 0
configure:4444: result: o
configure:4448: checking whether we are using the GNU C compiler
configure:4467: gcc -c   conftest.c >&5
configure:4467: $? = 0
configure:4476: result: yes
configure:4485: checking whether gcc accepts -g
configure:4505: gcc -c -g  conftest.c >&5
configure:4505: $? = 0
configure:4546: result: yes
configure:4563: checking for gcc option to accept ISO C89
configure:4627: gcc  -c -g -O2  conftest.c >&5
configure:4627: $? = 0
configure:4640: result: none needed
configure:4671: checking for style of include used by make
configure:4699: result: GNU
configure:4727: checking dependency style of gcc
configure:4795: result: gcc3
configure:4817: checking how to run the C preprocessor
configure:4848: gcc -E  conftest.c
configure:4848: $? = 0
configure:4862: gcc -E  conftest.c
conftest.c:15:28: error: ac_nonexistent.h: No such file or directory
configure:4862: $? = 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "SoQt"
| #define PACKAGE_TARNAME "soqt"
| #define PACKAGE_VERSION "1.4.1"
| #define PACKAGE_STRING "SoQt 1.4.1"
| #define PACKAGE_BUGREPORT "[hidden email]"
| #define PACKAGE_URL ""
| #define SOQT_MAJOR_VERSION 1
| #define SOQT_MINOR_VERSION 4
| #define SOQT_MICRO_VERSION 1
| #define SOQT_VERSION "1.4.1"
| #define PACKAGE "SoQt"
| #define VERSION "1.4.1"
| /* end confdefs.h.  */
| #include <ac_nonexistent.h>
configure:4887: result: gcc -E
configure:4907: gcc -E  conftest.c
configure:4907: $? = 0
configure:4921: gcc -E  conftest.c
conftest.c:15:28: error: ac_nonexistent.h: No such file or directory
configure:4921: $? = 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "SoQt"
| #define PACKAGE_TARNAME "soqt"
| #define PACKAGE_VERSION "1.4.1"
| #define PACKAGE_STRING "SoQt 1.4.1"
| #define PACKAGE_BUGREPORT "[hidden email]"
| #define PACKAGE_URL ""
| #define SOQT_MAJOR_VERSION 1
| #define SOQT_MINOR_VERSION 4
| #define SOQT_MICRO_VERSION 1
| #define SOQT_VERSION "1.4.1"
| #define PACKAGE "SoQt"
| #define VERSION "1.4.1"
| /* end confdefs.h.  */
| #include <ac_nonexistent.h>
configure:5007: checking for g++
configure:5023: found /usr/bin/g++
configure:5034: result: g++
configure:5061: checking for C++ compiler version
configure:5070: g++ --version >&5
g++ (Ubuntu 4.4.3-4ubuntu5) 4.4.3
Copyright (C) 2009 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:5081: $? = 0
configure:5070: g++ -v >&5
Using built-in specs.
Target: i486-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu
4.4.3-4ubuntu5'
--with-bugurl=file:///usr/share/doc/gcc-4.4/README.Bugs
--enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr
--enable-shared --enable-multiarch --enable-linker-build-id
--with-system-zlib --libexecdir=/usr/lib --without-included-gettext
--enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.4
--program-suffix=-4.4 --enable-nls --enable-clocale=gnu
--enable-libstdcxx-debug --enable-plugin --enable-objc-gc
--enable-targets=all --disable-werror --with-arch-32=i486
--with-tune=generic --enable-checking=release --build=i486-linux-gnu
--host=i486-linux-gnu --target=i486-linux-gnu
Thread model: posix
gcc version 4.4.3 (Ubuntu 4.4.3-4ubuntu5)
configure:5081: $? = 0
configure:5070: g++ -V >&5
g++: '-V' option must have argument
configure:5081: $? = 1
configure:5070: g++ -qversion >&5
g++: unrecognized option '-qversion'
g++: no input files
configure:5081: $? = 1
configure:5085: checking whether we are using the GNU C++ compiler
configure:5104: g++ -c   conftest.cpp >&5
configure:5104: $? = 0
configure:5113: result: yes
configure:5122: checking whether g++ accepts -g
configure:5142: g++ -c -g  conftest.cpp >&5
configure:5142: $? = 0
configure:5183: result: yes
configure:5208: checking dependency style of g++
configure:5276: result: gcc3
configure:5298: checking how to run the C++ preprocessor
configure:5325: g++ -E  conftest.cpp
configure:5325: $? = 0
configure:5339: g++ -E  conftest.cpp
conftest.cpp:15:28: error: ac_nonexistent.h: No such file or directory
configure:5339: $? = 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "SoQt"
| #define PACKAGE_TARNAME "soqt"
| #define PACKAGE_VERSION "1.4.1"
| #define PACKAGE_STRING "SoQt 1.4.1"
| #define PACKAGE_BUGREPORT "[hidden email]"
| #define PACKAGE_URL ""
| #define SOQT_MAJOR_VERSION 1
| #define SOQT_MINOR_VERSION 4
| #define SOQT_MICRO_VERSION 1
| #define SOQT_VERSION "1.4.1"
| #define PACKAGE "SoQt"
| #define VERSION "1.4.1"
| /* end confdefs.h.  */
| #include <ac_nonexistent.h>
configure:5364: result: g++ -E
configure:5384: g++ -E  conftest.cpp
configure:5384: $? = 0
configure:5398: g++ -E  conftest.cpp
conftest.cpp:15:28: error: ac_nonexistent.h: No such file or directory
configure:5398: $? = 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "SoQt"
| #define PACKAGE_TARNAME "soqt"
| #define PACKAGE_VERSION "1.4.1"
| #define PACKAGE_STRING "SoQt 1.4.1"
| #define PACKAGE_BUGREPORT "[hidden email]"
| #define PACKAGE_URL ""
| #define SOQT_MAJOR_VERSION 1
| #define SOQT_MINOR_VERSION 4
| #define SOQT_MICRO_VERSION 1
| #define SOQT_VERSION "1.4.1"
| #define PACKAGE "SoQt"
| #define VERSION "1.4.1"
| /* end confdefs.h.  */
| #include <ac_nonexistent.h>
configure:5669: checking for a sed that does not truncate output
configure:5723: result: /bin/sed
configure:5726: checking for grep that handles long lines and -e
configure:5784: result: /bin/grep
configure:5789: checking for egrep
configure:5851: result: /bin/grep -E
configure:5867: checking for ld used by gcc
configure:5934: result: /usr/bin/ld
configure:5941: checking if the linker (/usr/bin/ld) is GNU ld
configure:5956: result: yes
configure:5961: checking for /usr/bin/ld option to reload object files
configure:5968: result: -r
configure:5986: checking for BSD-compatible nm
configure:6035: result: /usr/bin/nm -B
configure:6039: checking whether ln -s works
configure:6043: result: yes
configure:6050: checking how to recognise dependent libraries
configure:6226: result: pass_all
configure:6428: checking for ANSI C header files
configure:6448: g++ -c -g -O2  conftest.cpp >&5
configure:6448: $? = 0
configure:6521: g++ -o conftest -g -O2   conftest.cpp  >&5
configure:6521: $? = 0
configure:6521: ./conftest
configure:6521: $? = 0
configure:6532: result: yes
configure:6545: checking for sys/types.h
configure:6545: g++ -c -g -O2  conftest.cpp >&5
configure:6545: $? = 0
configure:6545: result: yes
configure:6545: checking for sys/stat.h
configure:6545: g++ -c -g -O2  conftest.cpp >&5
configure:6545: $? = 0
configure:6545: result: yes
configure:6545: checking for stdlib.h
configure:6545: g++ -c -g -O2  conftest.cpp >&5
configure:6545: $? = 0
configure:6545: result: yes
configure:6545: checking for string.h
configure:6545: g++ -c -g -O2  conftest.cpp >&5
configure:6545: $? = 0
configure:6545: result: yes
configure:6545: checking for memory.h
configure:6545: g++ -c -g -O2  conftest.cpp >&5
configure:6545: $? = 0
configure:6545: result: yes
configure:6545: checking for strings.h
configure:6545: g++ -c -g -O2  conftest.cpp >&5
configure:6545: $? = 0
configure:6545: result: yes
configure:6545: checking for inttypes.h
configure:6545: g++ -c -g -O2  conftest.cpp >&5
configure:6545: $? = 0
configure:6545: result: yes
configure:6545: checking for stdint.h
configure:6545: g++ -c -g -O2  conftest.cpp >&5
configure:6545: $? = 0
configure:6545: result: yes
configure:6545: checking for unistd.h
configure:6545: g++ -c -g -O2  conftest.cpp >&5
configure:6545: $? = 0
configure:6545: result: yes
configure:6560: checking dlfcn.h usability
configure:6560: g++ -c -g -O2  conftest.cpp >&5
configure:6560: $? = 0
configure:6560: result: yes
configure:6560: checking dlfcn.h presence
configure:6560: g++ -E  conftest.cpp
configure:6560: $? = 0
configure:6560: result: yes
configure:6560: checking for dlfcn.h
configure:6560: result: yes
configure:6580: checking how to run the C++ preprocessor
configure:6646: result: g++ -E
configure:6666: g++ -E  conftest.cpp
configure:6666: $? = 0
configure:6680: g++ -E  conftest.cpp
conftest.cpp:26:28: error: ac_nonexistent.h: No such file or directory
configure:6680: $? = 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "SoQt"
| #define PACKAGE_TARNAME "soqt"
| #define PACKAGE_VERSION "1.4.1"
| #define PACKAGE_STRING "SoQt 1.4.1"
| #define PACKAGE_BUGREPORT "[hidden email]"
| #define PACKAGE_URL ""
| #define SOQT_MAJOR_VERSION 1
| #define SOQT_MINOR_VERSION 4
| #define SOQT_MICRO_VERSION 1
| #define SOQT_VERSION "1.4.1"
| #define PACKAGE "SoQt"
| #define VERSION "1.4.1"
| #define STDC_HEADERS 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_STAT_H 1
| #define HAVE_STDLIB_H 1
| #define HAVE_STRING_H 1
| #define HAVE_MEMORY_H 1
| #define HAVE_STRINGS_H 1
| #define HAVE_INTTYPES_H 1
| #define HAVE_STDINT_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_DLFCN_H 1
| /* end confdefs.h.  */
| #include <ac_nonexistent.h>
configure:6764: checking for g77
configure:6794: result: no
configure:6764: checking for xlf
configure:6794: result: no
configure:6764: checking for f77
configure:6794: result: no
configure:6764: checking for frt
configure:6794: result: no
configure:6764: checking for pgf77
configure:6794: result: no
configure:6764: checking for cf77
configure:6794: result: no
configure:6764: checking for fort77
configure:6794: result: no
configure:6764: checking for fl32
configure:6794: result: no
configure:6764: checking for af77
configure:6794: result: no
configure:6764: checking for xlf90
configure:6794: result: no
configure:6764: checking for f90
configure:6794: result: no
configure:6764: checking for pgf90
configure:6794: result: no
configure:6764: checking for pghpf
configure:6794: result: no
configure:6764: checking for epcf90
configure:6794: result: no
configure:6764: checking for gfortran
configure:6780: found /usr/bin/gfortran
configure:6791: result: gfortran
configure:6817: checking for Fortran 77 compiler version
configure:6826: gfortran --version >&5
GNU Fortran (Ubuntu 4.4.3-4ubuntu5) 4.4.3
Copyright (C) 2010 Free Software Foundation, Inc.

GNU Fortran comes with NO WARRANTY, to the extent permitted by law.
You may redistribute copies of GNU Fortran
under the terms of the GNU General Public License.
For more information about these matters, see the file named COPYING

configure:6837: $? = 0
configure:6826: gfortran -v >&5
Using built-in specs.
Target: i486-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu
4.4.3-4ubuntu5'
--with-bugurl=file:///usr/share/doc/gcc-4.4/README.Bugs
--enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr
--enable-shared --enable-multiarch --enable-linker-build-id
--with-system-zlib --libexecdir=/usr/lib --without-included-gettext
--enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.4
--program-suffix=-4.4 --enable-nls --enable-clocale=gnu
--enable-libstdcxx-debug --enable-plugin --enable-objc-gc
--enable-targets=all --disable-werror --with-arch-32=i486
--with-tune=generic --enable-checking=release --build=i486-linux-gnu
--host=i486-linux-gnu --target=i486-linux-gnu
Thread model: posix
gcc version 4.4.3 (Ubuntu 4.4.3-4ubuntu5)
configure:6837: $? = 0
configure:6826: gfortran -V >&5
gfortran: '-V' option must have argument
configure:6837: $? = 1
configure:6826: gfortran -qversion >&5
gfortran: unrecognized option '-qversion'
gfortran: no input files
configure:6837: $? = 1
configure:6846: checking whether we are using the GNU Fortran 77 compiler
configure:6859: gfortran -c  conftest.F >&5
configure:6859: $? = 0
configure:6868: result: yes
configure:6874: checking whether gfortran accepts -g
configure:6885: gfortran -c -g conftest.f >&5
configure:6885: $? = 0
configure:6893: result: yes
configure:6927: checking the maximum length of command line arguments
configure:7036: result: 32768
configure:7047: checking command to parse /usr/bin/nm -B output from gcc object
configure:7152: g++ -c -g -O2  conftest.cpp >&5
configure:7155: $? = 0
configure:7159: /usr/bin/nm -B conftest.o \| sed -n -e 's/^.*[
        ]\([ABCDGIRSTW][ABCDGIRSTW]*\)[ ][ ]*\([_A-Za-z][_A-Za-z0-9]*\)$/\1
\2 \2/p' \> conftest.nm
configure:7162: $? = 0
configure:7214: g++ -o conftest -g -O2   conftest.cpp conftstm.o >&5
configure:7217: $? = 0
configure:7255: result: ok
configure:7259: checking for objdir
configure:7274: result: .libs
configure:7366: checking for ar
configure:7382: found /usr/bin/ar
configure:7393: result: ar
configure:7458: checking for ranlib
configure:7474: found /usr/bin/ranlib
configure:7485: result: ranlib
configure:7550: checking for strip
configure:7566: found /usr/bin/strip
configure:7577: result: strip
configure:7859: checking if gcc supports -fno-rtti -fno-exceptions
configure:7877: gcc -c -g -O2  -fno-rtti -fno-exceptions conftest.c >&5
cc1: warning: command line option "-fno-rtti" is valid for C++/ObjC++
but not for C
configure:7881: $? = 0
configure:7894: result: no
configure:7909: checking for gcc option to produce PIC
configure:8119: result: -fPIC
configure:8127: checking if gcc PIC flag -fPIC works
configure:8145: gcc -c -g -O2  -fPIC -DPIC conftest.c >&5
configure:8149: $? = 0
configure:8162: result: yes
configure:8190: checking if gcc static flag -static works
configure:8218: result: yes
configure:8228: checking if gcc supports -c -o file.o
configure:8249: gcc -c -g -O2  -o out/conftest2.o conftest.c >&5
configure:8253: $? = 0
configure:8275: result: yes
configure:8301: checking whether the gcc linker (/usr/bin/ld) supports
shared libraries
configure:9201: result: yes
configure:9222: checking whether -lc should be explicitly linked in
configure:9227: gcc -c -g -O2  conftest.c >&5
configure:9230: $? = 0
configure:9245: gcc -shared conftest.o  -v -Wl,-soname -Wl,conftest -o
conftest 2\>\&1 \| grep  -lc  \>/dev/null 2\>\&1
configure:9248: $? = 0
configure:9260: result: no
configure:9268: checking dynamic linker characteristics
configure:9856: result: GNU/Linux ld.so
configure:9865: checking how to hardcode library paths into programs
configure:9890: result: immediate
configure:9904: checking whether stripping libraries is possible
configure:9909: result: yes
configure:10425: checking if libtool supports shared libraries
configure:10427: result: yes
configure:10430: checking whether to build shared libraries
configure:10451: result: yes
configure:10454: checking whether to build static libraries
configure:10458: result: no
configure:10550: creating libtool
configure:11134: checking for ld used by g++
configure:11201: result: /usr/bin/ld
configure:11208: checking if the linker (/usr/bin/ld) is GNU ld
configure:11223: result: yes
configure:11274: checking whether the g++ linker (/usr/bin/ld)
supports shared libraries
configure:12154: result: yes
configure:12172: g++ -c -g -O2  conftest.cpp >&5
configure:12175: $? = 0
configure:12294: checking for g++ option to produce PIC
configure:12568: result: -fPIC
configure:12576: checking if g++ PIC flag -fPIC works
configure:12594: g++ -c -g -O2  -fPIC -DPIC conftest.cpp >&5
configure:12598: $? = 0
configure:12611: result: yes
configure:12639: checking if g++ static flag -static works
configure:12667: result: yes
configure:12677: checking if g++ supports -c -o file.o
configure:12698: g++ -c -g -O2  -o out/conftest2.o conftest.cpp >&5
configure:12702: $? = 0
configure:12724: result: yes
configure:12750: checking whether the g++ linker (/usr/bin/ld)
supports shared libraries
configure:12775: result: yes
configure:12842: checking dynamic linker characteristics
configure:13430: result: GNU/Linux ld.so
configure:13439: checking how to hardcode library paths into programs
configure:13464: result: immediate
configure:13990: checking if libtool supports shared libraries
configure:13992: result: yes
configure:13995: checking whether to build shared libraries
configure:14015: result: yes
configure:14018: checking whether to build static libraries
configure:14022: result: no
configure:14032: checking for gfortran option to produce PIC
configure:14242: result: -fPIC
configure:14250: checking if gfortran PIC flag -fPIC works
configure:14268: gfortran -c -g -O2 -fPIC conftest.f >&5
configure:14272: $? = 0
configure:14285: result: yes
configure:14313: checking if gfortran static flag -static works
configure:14341: result: yes
configure:14351: checking if gfortran supports -c -o file.o
configure:14372: gfortran -c -g -O2 -o out/conftest2.o conftest.f >&5
configure:14376: $? = 0
configure:14398: result: yes
configure:14424: checking whether the gfortran linker (/usr/bin/ld)
supports shared libraries
configure:15312: result: yes
configure:15379: checking dynamic linker characteristics
configure:15967: result: GNU/Linux ld.so
configure:15976: checking how to hardcode library paths into programs
configure:16001: result: immediate
configure:20767: checking windows.h usability
configure:20767: g++ -c -g -O2  conftest.cpp >&5
conftest.cpp:59:21: error: windows.h: No such file or directory
configure:20767: $? = 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "SoQt"
| #define PACKAGE_TARNAME "soqt"
| #define PACKAGE_VERSION "1.4.1"
| #define PACKAGE_STRING "SoQt 1.4.1"
| #define PACKAGE_BUGREPORT "[hidden email]"
| #define PACKAGE_URL ""
| #define SOQT_MAJOR_VERSION 1
| #define SOQT_MINOR_VERSION 4
| #define SOQT_MICRO_VERSION 1
| #define SOQT_VERSION "1.4.1"
| #define PACKAGE "SoQt"
| #define VERSION "1.4.1"
| #define STDC_HEADERS 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_STAT_H 1
| #define HAVE_STDLIB_H 1
| #define HAVE_STRING_H 1
| #define HAVE_MEMORY_H 1
| #define HAVE_STRINGS_H 1
| #define HAVE_INTTYPES_H 1
| #define HAVE_STDINT_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_DLFCN_H 1
| /* end confdefs.h.  */
| #include <stdio.h>
| #ifdef HAVE_SYS_TYPES_H
| # include <sys/types.h>
| #endif
| #ifdef HAVE_SYS_STAT_H
| # include <sys/stat.h>
| #endif
| #ifdef STDC_HEADERS
| # include <stdlib.h>
| # include <stddef.h>
| #else
| # ifdef HAVE_STDLIB_H
| #  include <stdlib.h>
| # endif
| #endif
| #ifdef HAVE_STRING_H
| # if !defined STDC_HEADERS && defined HAVE_MEMORY_H
| #  include <memory.h>
| # endif
| # include <string.h>
| #endif
| #ifdef HAVE_STRINGS_H
| # include <strings.h>
| #endif
| #ifdef HAVE_INTTYPES_H
| # include <inttypes.h>
| #endif
| #ifdef HAVE_STDINT_H
| # include <stdint.h>
| #endif
| #ifdef HAVE_UNISTD_H
| # include <unistd.h>
| #endif
| #include <windows.h>
configure:20767: result: no
configure:20767: checking windows.h presence
configure:20767: g++ -E  conftest.cpp
conftest.cpp:26:21: error: windows.h: No such file or directory
configure:20767: $? = 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "SoQt"
| #define PACKAGE_TARNAME "soqt"
| #define PACKAGE_VERSION "1.4.1"
| #define PACKAGE_STRING "SoQt 1.4.1"
| #define PACKAGE_BUGREPORT "[hidden email]"
| #define PACKAGE_URL ""
| #define SOQT_MAJOR_VERSION 1
| #define SOQT_MINOR_VERSION 4
| #define SOQT_MICRO_VERSION 1
| #define SOQT_VERSION "1.4.1"
| #define PACKAGE "SoQt"
| #define VERSION "1.4.1"
| #define STDC_HEADERS 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_STAT_H 1
| #define HAVE_STDLIB_H 1
| #define HAVE_STRING_H 1
| #define HAVE_MEMORY_H 1
| #define HAVE_STRINGS_H 1
| #define HAVE_INTTYPES_H 1
| #define HAVE_STDINT_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_DLFCN_H 1
| /* end confdefs.h.  */
| #include <windows.h>
configure:20767: result: no
configure:20767: checking for windows.h
configure:20767: result: no
configure:20767: checking for unistd.h
configure:20767: result: yes
configure:20767: checking for sys/types.h
configure:20767: result: yes
configure:20767: checking sys/time.h usability
configure:20767: g++ -c -g -O2  conftest.cpp >&5
configure:20767: $? = 0
configure:20767: result: yes
configure:20767: checking sys/time.h presence
configure:20767: g++ -E  conftest.cpp
configure:20767: $? = 0
configure:20767: result: yes
configure:20767: checking for sys/time.h
configure:20767: result: yes
configure:20767: checking netinet/in.h usability
configure:20767: g++ -c -g -O2  conftest.cpp >&5
configure:20767: $? = 0
configure:20767: result: yes
configure:20767: checking netinet/in.h presence
configure:20767: g++ -E  conftest.cpp
configure:20767: $? = 0
configure:20767: result: yes
configure:20767: checking for netinet/in.h
configure:20767: result: yes
configure:20783: checking for tlhelp32.h
configure:20783: g++ -c -g -O2  conftest.cpp >&5
conftest.cpp:36:22: error: tlhelp32.h: No such file or directory
configure:20783: $? = 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "SoQt"
| #define PACKAGE_TARNAME "soqt"
| #define PACKAGE_VERSION "1.4.1"
| #define PACKAGE_STRING "SoQt 1.4.1"
| #define PACKAGE_BUGREPORT "[hidden email]"
| #define PACKAGE_URL ""
| #define SOQT_MAJOR_VERSION 1
| #define SOQT_MINOR_VERSION 4
| #define SOQT_MICRO_VERSION 1
| #define SOQT_VERSION "1.4.1"
| #define PACKAGE "SoQt"
| #define VERSION "1.4.1"
| #define STDC_HEADERS 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_STAT_H 1
| #define HAVE_STDLIB_H 1
| #define HAVE_STRING_H 1
| #define HAVE_MEMORY_H 1
| #define HAVE_STRINGS_H 1
| #define HAVE_INTTYPES_H 1
| #define HAVE_STDINT_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_DLFCN_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_TIME_H 1
| #define HAVE_NETINET_IN_H 1
| /* end confdefs.h.  */
|
| #ifdef HAVE_WINDOWS_H
| #include <windows.h>
| #endif
|
|
| #include <tlhelp32.h>
configure:20783: result: no
configure:20804: checking X11/extensions/SGIMisc.h usability
configure:20804: g++ -c -g -O2  conftest.cpp >&5
conftest.cpp:63:36: error: X11/extensions/SGIMisc.h: No such file or directory
configure:20804: $? = 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "SoQt"
| #define PACKAGE_TARNAME "soqt"
| #define PACKAGE_VERSION "1.4.1"
| #define PACKAGE_STRING "SoQt 1.4.1"
| #define PACKAGE_BUGREPORT "[hidden email]"
| #define PACKAGE_URL ""
| #define SOQT_MAJOR_VERSION 1
| #define SOQT_MINOR_VERSION 4
| #define SOQT_MICRO_VERSION 1
| #define SOQT_VERSION "1.4.1"
| #define PACKAGE "SoQt"
| #define VERSION "1.4.1"
| #define STDC_HEADERS 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_STAT_H 1
| #define HAVE_STDLIB_H 1
| #define HAVE_STRING_H 1
| #define HAVE_MEMORY_H 1
| #define HAVE_STRINGS_H 1
| #define HAVE_INTTYPES_H 1
| #define HAVE_STDINT_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_DLFCN_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_TIME_H 1
| #define HAVE_NETINET_IN_H 1
| /* end confdefs.h.  */
| #include <stdio.h>
| #ifdef HAVE_SYS_TYPES_H
| # include <sys/types.h>
| #endif
| #ifdef HAVE_SYS_STAT_H
| # include <sys/stat.h>
| #endif
| #ifdef STDC_HEADERS
| # include <stdlib.h>
| # include <stddef.h>
| #else
| # ifdef HAVE_STDLIB_H
| #  include <stdlib.h>
| # endif
| #endif
| #ifdef HAVE_STRING_H
| # if !defined STDC_HEADERS && defined HAVE_MEMORY_H
| #  include <memory.h>
| # endif
| # include <string.h>
| #endif
| #ifdef HAVE_STRINGS_H
| # include <strings.h>
| #endif
| #ifdef HAVE_INTTYPES_H
| # include <inttypes.h>
| #endif
| #ifdef HAVE_STDINT_H
| # include <stdint.h>
| #endif
| #ifdef HAVE_UNISTD_H
| # include <unistd.h>
| #endif
| #include <X11/extensions/SGIMisc.h>
configure:20804: result: no
configure:20804: checking X11/extensions/SGIMisc.h presence
configure:20804: g++ -E  conftest.cpp
conftest.cpp:30:36: error: X11/extensions/SGIMisc.h: No such file or directory
configure:20804: $? = 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "SoQt"
| #define PACKAGE_TARNAME "soqt"
| #define PACKAGE_VERSION "1.4.1"
| #define PACKAGE_STRING "SoQt 1.4.1"
| #define PACKAGE_BUGREPORT "[hidden email]"
| #define PACKAGE_URL ""
| #define SOQT_MAJOR_VERSION 1
| #define SOQT_MINOR_VERSION 4
| #define SOQT_MICRO_VERSION 1
| #define SOQT_VERSION "1.4.1"
| #define PACKAGE "SoQt"
| #define VERSION "1.4.1"
| #define STDC_HEADERS 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_STAT_H 1
| #define HAVE_STDLIB_H 1
| #define HAVE_STRING_H 1
| #define HAVE_MEMORY_H 1
| #define HAVE_STRINGS_H 1
| #define HAVE_INTTYPES_H 1
| #define HAVE_STDINT_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_DLFCN_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_TIME_H 1
| #define HAVE_NETINET_IN_H 1
| /* end confdefs.h.  */
| #include <X11/extensions/SGIMisc.h>
configure:20804: result: no
configure:20804: checking for X11/extensions/SGIMisc.h
configure:20804: result: no
configure:20804: checking X11/Xproto.h usability
configure:20804: g++ -c -g -O2  conftest.cpp >&5
configure:20804: $? = 0
configure:20804: result: yes
configure:20804: checking X11/Xproto.h presence
configure:20804: g++ -E  conftest.cpp
configure:20804: $? = 0
configure:20804: result: yes
configure:20804: checking for X11/Xproto.h
configure:20804: result: yes
configure:20804: checking X11/extensions/XInput.h usability
configure:20804: g++ -c -g -O2  conftest.cpp >&5
configure:20804: $? = 0
configure:20804: result: yes
configure:20804: checking X11/extensions/XInput.h presence
configure:20804: g++ -E  conftest.cpp
configure:20804: $? = 0
configure:20804: result: yes
configure:20804: checking for X11/extensions/XInput.h
configure:20804: result: yes
configure:20821: checking if the Win32 API is available
configure:20851: g++ -c -g -O2  conftest.cpp >&5
conftest.cpp:33:21: error: windows.h: No such file or directory
conftest.cpp: In function 'int main()':
conftest.cpp:46: error: 'NULL' was not declared in this scope
conftest.cpp:46: error: 'CreateDirectory' was not declared in this scope
conftest.cpp:47: error: 'RemoveDirectory' was not declared in this scope
conftest.cpp:48: error: 'SetLastError' was not declared in this scope
conftest.cpp:49: error: 'GetLastError' was not declared in this scope
conftest.cpp:50: error: 'LocalAlloc' was not declared in this scope
conftest.cpp:51: error: 'LocalFree' was not declared in this scope
configure:20851: $? = 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "SoQt"
| #define PACKAGE_TARNAME "soqt"
| #define PACKAGE_VERSION "1.4.1"
| #define PACKAGE_STRING "SoQt 1.4.1"
| #define PACKAGE_BUGREPORT "[hidden email]"
| #define PACKAGE_URL ""
| #define SOQT_MAJOR_VERSION 1
| #define SOQT_MINOR_VERSION 4
| #define SOQT_MICRO_VERSION 1
| #define SOQT_VERSION "1.4.1"
| #define PACKAGE "SoQt"
| #define VERSION "1.4.1"
| #define STDC_HEADERS 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_STAT_H 1
| #define HAVE_STDLIB_H 1
| #define HAVE_STRING_H 1
| #define HAVE_MEMORY_H 1
| #define HAVE_STRINGS_H 1
| #define HAVE_INTTYPES_H 1
| #define HAVE_STDINT_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_DLFCN_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_TIME_H 1
| #define HAVE_NETINET_IN_H 1
| #define HAVE_X11_XPROTO_H 1
| #define HAVE_X11_EXTENSIONS_XINPUT_H 1
| /* end confdefs.h.  */
|
| #include <windows.h>
|
| int
| main ()
| {
|
|   /* These need to be as basic as possible. I.e. they should be
|      available on all Windows versions. That means NT 3.1 and later,
|      Win95 and later, WinCE 1.0 and later), their definitions should
|      be available from windows.h, and should be linked in from kernel32.
|
|      The ones below are otherwise rather random picks.
|   */
|   (void)CreateDirectory(NULL, NULL);
|   (void)RemoveDirectory(NULL);
|   SetLastError(0);
|   (void)GetLastError();
|   (void)LocalAlloc(0, 1);
|   (void)LocalFree(NULL);
|   return 0;
|
|   ;
|   return 0;
| }
configure:20863: result: no
configure:20871: checking for GetEnvironmentVariable() function
configure:20884: g++ -o conftest -g -O2   conftest.cpp  >&5
conftest.cpp:32:21: error: windows.h: No such file or directory
conftest.cpp: In function 'int main()':
conftest.cpp:36: error: 'NULL' was not declared in this scope
conftest.cpp:36: error: 'GetEnvironmentVariable' was not declared in this scope
configure:20884: $? = 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "SoQt"
| #define PACKAGE_TARNAME "soqt"
| #define PACKAGE_VERSION "1.4.1"
| #define PACKAGE_STRING "SoQt 1.4.1"
| #define PACKAGE_BUGREPORT "[hidden email]"
| #define PACKAGE_URL ""
| #define SOQT_MAJOR_VERSION 1
| #define SOQT_MINOR_VERSION 4
| #define SOQT_MICRO_VERSION 1
| #define SOQT_VERSION "1.4.1"
| #define PACKAGE "SoQt"
| #define VERSION "1.4.1"
| #define STDC_HEADERS 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_STAT_H 1
| #define HAVE_STDLIB_H 1
| #define HAVE_STRING_H 1
| #define HAVE_MEMORY_H 1
| #define HAVE_STRINGS_H 1
| #define HAVE_INTTYPES_H 1
| #define HAVE_STDINT_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_DLFCN_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_TIME_H 1
| #define HAVE_NETINET_IN_H 1
| #define HAVE_X11_XPROTO_H 1
| #define HAVE_X11_EXTENSIONS_XINPUT_H 1
| /* end confdefs.h.  */
| #include <windows.h>
| int
| main ()
| {
| (void)GetEnvironmentVariable("FOOBAR", NULL, 0);
|   ;
|   return 0;
| }
configure:20891: result: no
configure:20918: checking for windows.h
configure:20918: result: no
configure:20929: checking whether the Win32 LoadLibrary() method is available
configure:20949: g++ -o conftest -g -O2   conftest.cpp  >&5
conftest.cpp: In function 'int main()':
conftest.cpp:40: error: 'LoadLibrary' was not declared in this scope
conftest.cpp:40: error: 'GetProcAddress' was not declared in this scope
conftest.cpp:40: error: 'FreeLibrary' was not declared in this scope
configure:20949: $? = 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "SoQt"
| #define PACKAGE_TARNAME "soqt"
| #define PACKAGE_VERSION "1.4.1"
| #define PACKAGE_STRING "SoQt 1.4.1"
| #define PACKAGE_BUGREPORT "[hidden email]"
| #define PACKAGE_URL ""
| #define SOQT_MAJOR_VERSION 1
| #define SOQT_MINOR_VERSION 4
| #define SOQT_MICRO_VERSION 1
| #define SOQT_VERSION "1.4.1"
| #define PACKAGE "SoQt"
| #define VERSION "1.4.1"
| #define STDC_HEADERS 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_STAT_H 1
| #define HAVE_STDLIB_H 1
| #define HAVE_STRING_H 1
| #define HAVE_MEMORY_H 1
| #define HAVE_STRINGS_H 1
| #define HAVE_INTTYPES_H 1
| #define HAVE_STDINT_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_DLFCN_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_TIME_H 1
| #define HAVE_NETINET_IN_H 1
| #define HAVE_X11_XPROTO_H 1
| #define HAVE_X11_EXTENSIONS_XINPUT_H 1
| /* end confdefs.h.  */
|
| #ifdef HAVE_WINDOWS_H
| #include <windows.h>
| #endif /* HAVE_WINDOWS_H */
|
| int
| main ()
| {
| (void)LoadLibrary(0L); (void)GetProcAddress(0L, 0L); (void)FreeLibrary(0L);
|   ;
|   return 0;
| }
configure:20957: result: no
configure:20977: checking for GetClassName() function
configure:20996: g++ -o conftest -g -O2   conftest.cpp  -luser32 >&5
conftest.cpp: In function 'int main()':
conftest.cpp:41: error: 'NULL' was not declared in this scope
conftest.cpp:41: error: 'GetClassName' was not declared in this scope
configure:20996: $? = 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "SoQt"
| #define PACKAGE_TARNAME "soqt"
| #define PACKAGE_VERSION "1.4.1"
| #define PACKAGE_STRING "SoQt 1.4.1"
| #define PACKAGE_BUGREPORT "[hidden email]"
| #define PACKAGE_URL ""
| #define SOQT_MAJOR_VERSION 1
| #define SOQT_MINOR_VERSION 4
| #define SOQT_MICRO_VERSION 1
| #define SOQT_VERSION "1.4.1"
| #define PACKAGE "SoQt"
| #define VERSION "1.4.1"
| #define STDC_HEADERS 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_STAT_H 1
| #define HAVE_STDLIB_H 1
| #define HAVE_STRING_H 1
| #define HAVE_MEMORY_H 1
| #define HAVE_STRINGS_H 1
| #define HAVE_INTTYPES_H 1
| #define HAVE_STDINT_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_DLFCN_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_TIME_H 1
| #define HAVE_NETINET_IN_H 1
| #define HAVE_X11_XPROTO_H 1
| #define HAVE_X11_EXTENSIONS_XINPUT_H 1
| /* end confdefs.h.  */
|
| #ifdef HAVE_WINDOWS_H
| #include <windows.h>
| #endif
|
| int
| main ()
| {
|
|   (void)GetClassName(NULL, NULL, 0);
|
|   ;
|   return 0;
| }
configure:21004: result: no
configure:21021: checking if fink is available
configure:21032: result: no
configure:21076: checking whether -R must be followed by a space
configure:21092: g++ -o conftest -g -O2   conftest.cpp  -RNONE >&5
g++: unrecognized option '-RNONE'
configure:21092: $? = 0
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "SoQt"
| #define PACKAGE_TARNAME "soqt"
| #define PACKAGE_VERSION "1.4.1"
| #define PACKAGE_STRING "SoQt 1.4.1"
| #define PACKAGE_BUGREPORT "[hidden email]"
| #define PACKAGE_URL ""
| #define SOQT_MAJOR_VERSION 1
| #define SOQT_MINOR_VERSION 4
| #define SOQT_MICRO_VERSION 1
| #define SOQT_VERSION "1.4.1"
| #define PACKAGE "SoQt"
| #define VERSION "1.4.1"
| #define STDC_HEADERS 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_STAT_H 1
| #define HAVE_STDLIB_H 1
| #define HAVE_STRING_H 1
| #define HAVE_MEMORY_H 1
| #define HAVE_STRINGS_H 1
| #define HAVE_INTTYPES_H 1
| #define HAVE_STDINT_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_DLFCN_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_TIME_H 1
| #define HAVE_NETINET_IN_H 1
| #define HAVE_X11_XPROTO_H 1
| #define HAVE_X11_EXTENSIONS_XINPUT_H 1
| /* end confdefs.h.  */
|
| int
| main ()
| {
|
|   ;
|   return 0;
| }
configure:21109: g++ -o conftest -g -O2   conftest.cpp  -R NONE >&5
g++: NONE: No such file or directory
g++: unrecognized option '-R'
configure:21109: $? = 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "SoQt"
| #define PACKAGE_TARNAME "soqt"
| #define PACKAGE_VERSION "1.4.1"
| #define PACKAGE_STRING "SoQt 1.4.1"
| #define PACKAGE_BUGREPORT "[hidden email]"
| #define PACKAGE_URL ""
| #define SOQT_MAJOR_VERSION 1
| #define SOQT_MINOR_VERSION 4
| #define SOQT_MICRO_VERSION 1
| #define SOQT_VERSION "1.4.1"
| #define PACKAGE "SoQt"
| #define VERSION "1.4.1"
| #define STDC_HEADERS 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_STAT_H 1
| #define HAVE_STDLIB_H 1
| #define HAVE_STRING_H 1
| #define HAVE_MEMORY_H 1
| #define HAVE_STRINGS_H 1
| #define HAVE_INTTYPES_H 1
| #define HAVE_STDINT_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_DLFCN_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_TIME_H 1
| #define HAVE_NETINET_IN_H 1
| #define HAVE_X11_XPROTO_H 1
| #define HAVE_X11_EXTENSIONS_XINPUT_H 1
| /* end confdefs.h.  */
|
| int
| main ()
| {
|
|   ;
|   return 0;
| }
configure:21114: result: neither works
configure:21155: g++ -o conftest -g -O2   conftest.cpp   -LNONE -lX11 >&5
configure:21155: $? = 0
configure:21253: checking for gethostbyname
configure:21253: g++ -o conftest -g -O2   conftest.cpp  >&5
configure:21253: $? = 0
configure:21253: result: yes
configure:21350: checking for connect
configure:21350: g++ -o conftest -g -O2   conftest.cpp  >&5
configure:21350: $? = 0
configure:21350: result: yes
configure:21399: checking for remove
configure:21399: g++ -o conftest -g -O2   conftest.cpp  >&5
configure:21399: $? = 0
configure:21399: result: yes
configure:21448: checking for shmat
configure:21448: g++ -o conftest -g -O2   conftest.cpp  >&5
configure:21448: $? = 0
configure:21448: result: yes
configure:21506: checking for IceConnectionNumber in -lICE
configure:21531: g++ -o conftest -g -O2   -LNONE conftest.cpp -lICE   >&5
configure:21531: $? = 0
configure:21540: result: yes
configure:22908: checking how to include gl.h
configure:22974: g++ -E   conftest.cpp
configure:22974: $? = 0
configure:22996: result: #include <GL/gl.h>
configure:23062: checking for coin-config
configure:23080: found /usr/bin/coin-config
configure:23093: result: /usr/bin/coin-config
configure:23121: checking if we can compile and link with the Coin library
configure:23152: g++ -o conftest -g -O2 -g -O2 -g -Wall -O2
-I/usr/include/Inventor/annex -D_REENTRANT  -L/usr/lib
-Wl,-Bsymbolic-functions conftest.cpp -lCoin -lGL -lXext -lSM -lICE
-lX11 -ldl -lpthread  >&5
/usr/bin/ld: cannot find -lGL
collect2: ld returned 1 exit status
configure:23152: $? = 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "SoQt"
| #define PACKAGE_TARNAME "soqt"
| #define PACKAGE_VERSION "1.4.1"
| #define PACKAGE_STRING "SoQt 1.4.1"
| #define PACKAGE_BUGREPORT "[hidden email]"
| #define PACKAGE_URL ""
| #define SOQT_MAJOR_VERSION 1
| #define SOQT_MINOR_VERSION 4
| #define SOQT_MICRO_VERSION 1
| #define SOQT_VERSION "1.4.1"
| #define PACKAGE "SoQt"
| #define VERSION "1.4.1"
| #define STDC_HEADERS 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_STAT_H 1
| #define HAVE_STDLIB_H 1
| #define HAVE_STRING_H 1
| #define HAVE_MEMORY_H 1
| #define HAVE_STRINGS_H 1
| #define HAVE_INTTYPES_H 1
| #define HAVE_STDINT_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_DLFCN_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_TIME_H 1
| #define HAVE_NETINET_IN_H 1
| #define HAVE_X11_XPROTO_H 1
| #define HAVE_X11_EXTENSIONS_XINPUT_H 1
| #define HAVE_GL_GL_H 1
| /* end confdefs.h.  */
| #include <Inventor/SoDB.h>
| int
| main ()
| {
| SoDB::init();
|   ;
|   return 0;
| }
configure:23172: result: false
configure:23185: WARNING:
Compilation and/or linking with the Coin main library SDK failed, for
unknown reason. If you are familiar with configure-based configuration
and building, investigate the 'config.log' file for clues.

If you can not figure out what went wrong, please forward the 'config.log'
file to the email address <[hidden email]> and ask for help by
describing the situation where this failed.

configure:23305: error: couldn't compile and link against Coin

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_build=i686-pc-linux-gnu
ac_cv_c_compiler_gnu=yes
ac_cv_cxx_compiler_gnu=yes
ac_cv_env_CCC_set=
ac_cv_env_CCC_value=
ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=
ac_cv_env_CFLAGS_value=
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_CXXCPP_set=
ac_cv_env_CXXCPP_value=
ac_cv_env_CXXFLAGS_set=
ac_cv_env_CXXFLAGS_value=
ac_cv_env_CXX_set=
ac_cv_env_CXX_value=
ac_cv_env_F77_set=
ac_cv_env_F77_value=
ac_cv_env_FFLAGS_set=
ac_cv_env_FFLAGS_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_LIBS_set=
ac_cv_env_LIBS_value=
ac_cv_env_XMKMF_set=
ac_cv_env_XMKMF_value=
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_htmldir_set=set
ac_cv_env_htmldir_value='${docdir}'
ac_cv_env_htmlhelpdir_set=
ac_cv_env_htmlhelpdir_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_f77_compiler_gnu=yes
ac_cv_func_connect=yes
ac_cv_func_gethostbyname=yes
ac_cv_func_remove=yes
ac_cv_func_shmat=yes
ac_cv_header_GL_gl_h=yes
ac_cv_header_X11_Xproto_h=yes
ac_cv_header_X11_extensions_SGIMisc_h=no
ac_cv_header_X11_extensions_XInput_h=yes
ac_cv_header_dlfcn_h=yes
ac_cv_header_inttypes_h=yes
ac_cv_header_memory_h=yes
ac_cv_header_netinet_in_h=yes
ac_cv_header_stdc=yes
ac_cv_header_stdint_h=yes
ac_cv_header_stdlib_h=yes
ac_cv_header_string_h=yes
ac_cv_header_strings_h=yes
ac_cv_header_sys_stat_h=yes
ac_cv_header_sys_time_h=yes
ac_cv_header_sys_types_h=yes
ac_cv_header_tlhelp32_h=no
ac_cv_header_unistd_h=yes
ac_cv_header_windows_h=no
ac_cv_host=i686-pc-linux-gnu
ac_cv_lib_ICE_IceConnectionNumber=yes
ac_cv_objext=o
ac_cv_path_EGREP='/bin/grep -E'
ac_cv_path_GREP=/bin/grep
ac_cv_path_install='/usr/bin/install -c'
ac_cv_path_sim_ac_coin_configcmd=/usr/bin/coin-config
ac_cv_prog_AWK=gawk
ac_cv_prog_CPP='gcc -E'
ac_cv_prog_CXXCPP='g++ -E'
ac_cv_prog_ac_ct_AR=ar
ac_cv_prog_ac_ct_CC=gcc
ac_cv_prog_ac_ct_CXX=g++
ac_cv_prog_ac_ct_F77=gfortran
ac_cv_prog_ac_ct_RANLIB=ranlib
ac_cv_prog_ac_ct_STRIP=strip
ac_cv_prog_cc_c89=
ac_cv_prog_cc_g=yes
ac_cv_prog_cxx_g=yes
ac_cv_prog_f77_g=yes
ac_cv_prog_make_make_set=yes
ac_cv_target=i686-pc-linux-gnu
am_cv_CC_dependencies_compiler_type=gcc3
am_cv_CXX_dependencies_compiler_type=gcc3
lt_cv_deplibs_check_method=pass_all
lt_cv_file_magic_cmd='$MAGIC_CMD'
lt_cv_file_magic_test_file=
lt_cv_ld_reload_flag=-r
lt_cv_objdir=.libs
lt_cv_path_LD=/usr/bin/ld
lt_cv_path_LDCXX=/usr/bin/ld
lt_cv_path_NM='/usr/bin/nm -B'
lt_cv_path_SED=/bin/sed
lt_cv_prog_compiler_c_o=yes
lt_cv_prog_compiler_c_o_CXX=yes
lt_cv_prog_compiler_c_o_F77=yes
lt_cv_prog_compiler_rtti_exceptions=no
lt_cv_prog_gnu_ld=yes
lt_cv_prog_gnu_ldcxx=yes
lt_cv_sys_global_symbol_pipe='sed -n -e '\''s/^.*[
        ]\([ABCDGIRSTW][ABCDGIRSTW]*\)[ ][ ]*\([_A-Za-z][_A-Za-z0-9]*\)$/\1
\2 \2/p'\'''
lt_cv_sys_global_symbol_to_c_name_address='sed -n -e '\''s/^: \([^
]*\) $/  {\"\1\", (lt_ptr) 0},/p'\'' -e '\''s/^[BCDEGRST] \([^ ]*\)
\([^ ]*\)$/  {"\2", (lt_ptr) \&\2},/p'\'''
lt_cv_sys_global_symbol_to_cdecl='sed -n -e '\''s/^. .* \(.*\)$/extern
int \1;/p'\'''
lt_cv_sys_max_cmd_len=32768
lt_lt_cv_prog_compiler_c_o='"yes"'
lt_lt_cv_prog_compiler_c_o_CXX='"yes"'
lt_lt_cv_prog_compiler_c_o_F77='"yes"'
lt_lt_cv_sys_global_symbol_pipe='"sed -n -e '\''s/^.*[
        ]\\([ABCDGIRSTW][ABCDGIRSTW]*\\)[ ][
        ]*\\([_A-Za-z][_A-Za-z0-9]*\\)\$/\\1 \\2 \\2/p'\''"'
lt_lt_cv_sys_global_symbol_to_c_name_address='"sed -n -e '\''s/^:
\\([^ ]*\\) \$/  {\\\"\\1\\\", (lt_ptr) 0},/p'\'' -e '\''s/^[BCDEGRST]
\\([^ ]*\\) \\([^ ]*\\)\$/  {\"\\2\", (lt_ptr) \\&\\2},/p'\''"'
lt_lt_cv_sys_global_symbol_to_cdecl='"sed -n -e '\''s/^. .*
\\(.*\\)\$/extern int \\1;/p'\''"'
sim_cv_coin_avail=false
sim_cv_lib_loadlibrary_avail=no

## ----------------- ##
## Output variables. ##
## ----------------- ##

ACLOCAL='${SHELL}
/home/pmonso/code/ros/stacks/soqt/build/SoQt-1.4.1/cfg/missing --run
aclocal-1.7'
AMDEPBACKSLASH='\'
AMDEP_FALSE='#'
AMDEP_TRUE=''
AMTAR='${SHELL}
/home/pmonso/code/ros/stacks/soqt/build/SoQt-1.4.1/cfg/missing --run
tar'
AR='ar'
AUTOCONF='${SHELL}
/home/pmonso/code/ros/stacks/soqt/build/SoQt-1.4.1/cfg/missing --run
autoconf'
AUTOHEADER='${SHELL}
/home/pmonso/code/ros/stacks/soqt/build/SoQt-1.4.1/cfg/missing --run
autoheader'
AUTOMAKE='${SHELL}
/home/pmonso/code/ros/stacks/soqt/build/SoQt-1.4.1/cfg/missing --run
automake-1.7'
AWK='gawk'
BUILD_HTMLHELP_FALSE=''
BUILD_HTMLHELP_TRUE='#'
BUILD_HTMLPAGES_FALSE=''
BUILD_HTMLPAGES_TRUE='#'
BUILD_LIBRARY_FALSE='#'
BUILD_LIBRARY_TRUE=''
BUILD_MANPAGES_FALSE=''
BUILD_MANPAGES_TRUE='#'
BUILD_METAFILES_FALSE='#'
BUILD_METAFILES_TRUE=''
BUILD_WITH_MSVC='false'
BUILD_WITH_MSVC_FALSE=''
BUILD_WITH_MSVC_TRUE=''
CC='gcc'
CCDEPMODE='depmode=gcc3'
CFLAGS='-g -O2'
COIN_COMPILER=''
COMPONENTHEADER=''
CONFIG='default'
CPP='gcc -E'
CPPFLAGS=' '
CXX='g++'
CXXCPP='g++ -E'
CXXDEPMODE='depmode=gcc3'
CXXFLAGS='-g -O2'
CYGPATH_W='echo'
DEFS=''
DEPDIR='.deps'
DSUFFIX=''
ECHO='echo'
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EGREP='/bin/grep -E'
EVENT=''
EXEEXT=''
F77='gfortran'
FFLAGS='-g -O2'
GREP='/bin/grep'
GUI=''
Gui=''
HACKING_COMPACT_BUILD_FALSE=''
HACKING_COMPACT_BUILD_TRUE='#'
HAVE_JOYSTICK_LINUX_FALSE=''
HAVE_JOYSTICK_LINUX_TRUE=''
INSTALL_DATA='${INSTALL} -m 644'
INSTALL_PROGRAM='${INSTALL}'
INSTALL_SCRIPT='${INSTALL}'
INSTALL_STRIP_PROGRAM='${SHELL} $(install_sh) -c -s'
LDFLAGS=''
LIBFLAGS=''
LIBOBJS=''
LIBS=''
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
LN_S='ln -s'
LTLIBOBJS=''
LT_AGE='4'
LT_CURRENT='24'
LT_REVISION='1'
MACOSX_10_2FF_FALSE=''
MACOSX_10_2FF_TRUE=''
MACOSX_FALSE=''
MACOSX_PACKAGEABLE_FALSE=''
MACOSX_PACKAGEABLE_TRUE=''
MACOSX_TRUE=''
MAC_FRAMEWORK=''
MAC_FRAMEWORK_FALSE=''
MAC_FRAMEWORK_NAME=''
MAC_FRAMEWORK_PREFIX=''
MAC_FRAMEWORK_TRUE=''
MAC_FRAMEWORK_VERSION=''
MAINT='#'
MAINTAINER_MODE_FALSE=''
MAINTAINER_MODE_TRUE='#'
MAKEINFO='${SHELL}
/home/pmonso/code/ros/stacks/soqt/build/SoQt-1.4.1/cfg/missing --run
makeinfo'
MOC2=''
MOC=''
OBJEXT='o'
PACKAGE='SoQt'
PACKAGE_BUGREPORT='[hidden email]'
PACKAGE_NAME='SoQt'
PACKAGE_STRING='SoQt 1.4.1'
PACKAGE_TARNAME='soqt'
PACKAGE_URL=''
PACKAGE_VERSION='1.4.1'
PATH_SEPARATOR=':'
RANLIB='ranlib'
SET_MAKE=''
SHELL='/bin/bash'
SOGUI_DOC_HTML='NO'
SOGUI_DOC_HTML_HELP='NO'
SOGUI_DOC_MAN='NO'
SOGUI_EXTRA_CFLAGS='-g -O2'
SOGUI_EXTRA_CPPFLAGS=' '
SOGUI_EXTRA_CXXFLAGS='-g -O2'
SOGUI_EXTRA_LDFLAGS=''
SOGUI_EXTRA_LIBS=''
SOGUI_MAJOR_VERSION='1'
SOGUI_MINOR_VERSION='4'
SOGUI_MSVC_LIBC=''
SOQT_BETA_VERSION=''
SOQT_DSP_DEFS=''
SOQT_DSP_INCS=''
SOQT_DSP_LIBS=''
SOQT_LIB_DSP_DEFS=''
SOQT_MAJOR_VERSION='1'
SOQT_MICRO_VERSION='1'
SOQT_MINOR_VERSION='4'
SOQT_SO_VERSION='20'
SOQT_VERSION='1.4.1'
STRIP='strip'
SUFFIX=''
UNIX2WINPATH=''
VERSION='1.4.1'
WIDGET=''
XMKMF=''
X_CFLAGS=' -INONE'
X_EXTRA_LIBS=''
X_LIBS=' -LNONE'
X_PRE_LIBS=' -lSM -lICE'
ac_compiler_gnu='yes'
ac_ct_CC='gcc'
ac_ct_CXX='g++'
ac_ct_F77='gfortran'
ac_unique_file='src/Inventor/Qt/SoQt.cpp'
am__fastdepCC_FALSE='#'
am__fastdepCC_TRUE=''
am__fastdepCXX_FALSE='#'
am__fastdepCXX_TRUE=''
am__include='include'
am__leading_dot='.'
am__quote=''
bindir='${exec_prefix}/bin'
build='i686-pc-linux-gnu'
build_alias=''
build_cpu='i686'
build_os='linux-gnu'
build_vendor='pc'
datadir='${datarootdir}'
datarootdir='${prefix}/share'
docdir='${datarootdir}/doc/${PACKAGE_TARNAME}'
dvidir='${docdir}'
exec_prefix='NONE'
frameworkdir=''
gui=''
host='i686-pc-linux-gnu'
host_alias=''
host_cpu='i686'
host_os='linux-gnu'
host_vendor='pc'
htmldir='${prefix}/${docdir}'
htmlhelpdir='${datarootdir}/SoQt/htmlhelp'
includedir='${prefix}/include'
infodir='${datarootdir}/info'
install_sh='/home/pmonso/code/ros/stacks/soqt/build/SoQt-1.4.1/cfg/install-sh'
ivframeworkdir=''
ivincludedir=''
libdir='${exec_prefix}/lib'
libexecdir='${exec_prefix}/libexec'
localedir='${datarootdir}/locale'
localstatedir='${prefix}/var'
mandir='${datarootdir}/man'
meta_prefix='moc_'
nop=''
oldincludedir='/usr/include'
path_tag=''
pdfdir='${docdir}'
prefix='/home/pmonso/code/ros/stacks/soqt'
program_transform_name='s,x,x,'
psdir='${docdir}'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
sim_ac_coin_configcmd='/usr/bin/coin-config --alternate=default'
sim_ac_doxygen_exe=''
sim_ac_hhc_exe=''
sim_ac_packagemaker_app=''
sim_ac_perl_exe=''
sim_ac_qt_cygpath=''
sim_ac_relative_src_dir='.'
sim_ac_relative_src_dir_p='true'
sogui_build_dir='/home/pmonso/code/ros/stacks/soqt/build/SoQt-1.4.1'
sogui_html_dir='/home/pmonso/code/ros/stacks/soqt/build/SoQt-1.4.1/html'
sogui_html_help_dir='/home/pmonso/code/ros/stacks/soqt/build/SoQt-1.4.1/htmlhelp'
sogui_man_dir='/home/pmonso/code/ros/stacks/soqt/build/SoQt-1.4.1/man'
sogui_src_dir='/home/pmonso/code/ros/stacks/soqt/build/SoQt-1.4.1'
soguiincludedir=''
soqt_build_dir='/home/pmonso/code/ros/stacks/soqt/build/SoQt-1.4.1'
soqt_src_dir='/home/pmonso/code/ros/stacks/soqt/build/SoQt-1.4.1'
soqt_w32_build_dir='/home/pmonso/code/ros/stacks/soqt/build/SoQt-1.4.1'
soqt_w32_src_dir='/home/pmonso/code/ros/stacks/soqt/build/SoQt-1.4.1'
sysconfdir='${prefix}/etc'
target='i686-pc-linux-gnu'
target_alias=''
target_cpu='i686'
target_os='linux-gnu'
target_vendor='pc'

## ----------- ##
## confdefs.h. ##
## ----------- ##

/* confdefs.h */
#define PACKAGE_NAME "SoQt"
#define PACKAGE_TARNAME "soqt"
#define PACKAGE_VERSION "1.4.1"
#define PACKAGE_STRING "SoQt 1.4.1"
#define PACKAGE_BUGREPORT "[hidden email]"
#define PACKAGE_URL ""
#define SOQT_MAJOR_VERSION 1
#define SOQT_MINOR_VERSION 4
#define SOQT_MICRO_VERSION 1
#define SOQT_VERSION "1.4.1"
#define PACKAGE "SoQt"
#define VERSION "1.4.1"
#define STDC_HEADERS 1
#define HAVE_SYS_TYPES_H 1
#define HAVE_SYS_STAT_H 1
#define HAVE_STDLIB_H 1
#define HAVE_STRING_H 1
#define HAVE_MEMORY_H 1
#define HAVE_STRINGS_H 1
#define HAVE_INTTYPES_H 1
#define HAVE_STDINT_H 1
#define HAVE_UNISTD_H 1
#define HAVE_DLFCN_H 1
#define HAVE_UNISTD_H 1
#define HAVE_SYS_TYPES_H 1
#define HAVE_SYS_TIME_H 1
#define HAVE_NETINET_IN_H 1
#define HAVE_X11_XPROTO_H 1
#define HAVE_X11_EXTENSIONS_XINPUT_H 1
#define HAVE_GL_GL_H 1

configure: exit 1

2010/11/10 Rosen Diankov <[hidden email]>

>
> hi pol,
>
> You shouldn't have any problems if you are on ubuntu....after
> re-installing coin-dev, have you tried to make wipe the soqt ros
> package before re-making?
>
> If so, and it still doesn't work. Send the config.log (or better yet,
> ask the soqt developers)
>
> rosen,
>
> 2010/11/10 Pol Monsó <[hidden email]>:
> >
> > I forgot to mention I'm on ubuntu 10.04, with ros ros-cturtle-pr2all
> > installed and working
> >
> > 2010/11/10 pmonso <[hidden email]>
> >>
> >> I'm trying to install OpenRave through the ros package.
> >> http://www.ros.org/wiki/openrave
> >>
> >> since it was complaining about missing soqt, I installed it
> >> http://www.ros.org/wiki/soqt
> >>
> >> When compiling soqt, I get the following message:
> >>
> >> checking if we can compile and link with the Coin library... false
> >>  configure: WARNING:
> >>  Compilation and/or linking with the Coin main library SDK failed, for
> >>  unknown reason. If you are familiar with configure-based configuration
> >>  and building, investigate the 'config.log' file for clues.
> >>
> >>  If you can not figure out what went wrong, please forward the
> >> 'config.log'
> >>  file to the email address <[hidden email]> and ask for help by
> >>  describing the situation where this failed.
> >>
> >>  configure: error: couldn't compile and link against Coin
> >>
> >> I did install libcoin40-dev and libcoin40c2 and got the same message, as
> >> well as with installing libcoin60 and libsoqt
> >>
> >> Since I doubt I have to download coin from their website, what's wrong?
> >> What
> >> packages is soqt expecting?
> >>
> >>
> >>
> >> --
> >> View this message in context:
> >> http://openrave-users-list.185357.n3.nabble.com/OpenRave-dependencies-install-tp1876069p1876069.html
> >> Sent from the OpenRAVE Users List mailing list archive at Nabble.com.
> >>
> >>
> >> ------------------------------------------------------------------------------
> >> The Next 800 Companies to Lead America's Growth: New Video Whitepaper
> >> David G. Thomson, author of the best-selling book "Blueprint to a
> >> Billion" shares his insights and actions to help propel your
> >> business during the next growth cycle. Listen Now!
> >> http://p.sf.net/sfu/SAP-dev2dev
> >> _______________________________________________
> >> Openrave-users mailing list
> >> [hidden email]
> >> https://lists.sourceforge.net/lists/listinfo/openrave-users
> >
> >
> > ------------------------------------------------------------------------------
> > The Next 800 Companies to Lead America's Growth: New Video Whitepaper
> > David G. Thomson, author of the best-selling book "Blueprint to a
> > Billion" shares his insights and actions to help propel your
> > business during the next growth cycle. Listen Now!
> > http://p.sf.net/sfu/SAP-dev2dev
> > _______________________________________________
> > Openrave-users mailing list
> > [hidden email]
> > https://lists.sourceforge.net/lists/listinfo/openrave-users
> >
> >

------------------------------------------------------------------------------
Centralized Desktop Delivery: Dell and VMware Reference Architecture
Simplifying enterprise desktop deployment and management using
Dell EqualLogic storage and VMware View: A highly scalable, end-to-end
client virtualization framework. Read more!
http://p.sf.net/sfu/dell-eql-dev2dev
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Reply | Threaded
Open this post in threaded view
|

Re: OpenRave dependencies install

Rosen Diankov
Administrator
hi pol,

sorry for the late response. it seems that things are failing in this command:

g++ -o conftest -g -O2 -g -O2 -g -Wall -O2
-I/usr/include/Inventor/annex -D_REENTRANT  -L/usr/lib
-Wl,-Bsymbolic-functions conftest.cpp -lCoin -lGL -lXext -lSM -lICE
-lX11 -ldl -lpthread  >&5
/usr/bin/ld: cannot find -lGL


In other words, you do not have opengl libraries installed correctly
and coin3d is failing to link libGL

rosen,

------------------------------------------------------------------------------
Centralized Desktop Delivery: Dell and VMware Reference Architecture
Simplifying enterprise desktop deployment and management using
Dell EqualLogic storage and VMware View: A highly scalable, end-to-end
client virtualization framework. Read more!
http://p.sf.net/sfu/dell-eql-dev2dev
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Reply | Threaded
Open this post in threaded view
|

Re: OpenRave dependencies install

pmonso
And yet it is installed at a standard location from the package manager:

/usr/lib/libGL.so
/include/GL/gl.h

Anyway, I'll go blame the SoQt or Coin first and since I did only want
to try out WAM on OpenRave+ros before porting the WAM arm to ros's
urdf modelling -as we're discussing in another thread- I may just keep
going. I though the installation would be straightforward.

Just to be sure, what version of coin should I have installed
libcoin40 or libcoin60 ?

Thanks,

Pol Monsó


2010/11/12 Rosen Diankov <[hidden email]>:

> hi pol,
>
> sorry for the late response. it seems that things are failing in this command:
>
> g++ -o conftest -g -O2 -g -O2 -g -Wall -O2
> -I/usr/include/Inventor/annex -D_REENTRANT  -L/usr/lib
> -Wl,-Bsymbolic-functions conftest.cpp -lCoin -lGL -lXext -lSM -lICE
> -lX11 -ldl -lpthread  >&5
> /usr/bin/ld: cannot find -lGL
>
>
> In other words, you do not have opengl libraries installed correctly
> and coin3d is failing to link libGL
>
> rosen,
>

------------------------------------------------------------------------------
Centralized Desktop Delivery: Dell and VMware Reference Architecture
Simplifying enterprise desktop deployment and management using
Dell EqualLogic storage and VMware View: A highly scalable, end-to-end
client virtualization framework. Read more!
http://p.sf.net/sfu/dell-eql-dev2dev
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Reply | Threaded
Open this post in threaded view
|

Re: OpenRave dependencies install

Rosen Diankov
Administrator
hi pol,

try

sudo openrave

usually that disables any graphics stuff

both coin versions should work, although libcoin40 has been easier to
get installed.

rosen,

2010/11/12 Pol Monsó <[hidden email]>:

> And yet it is installed at a standard location from the package manager:
>
> /usr/lib/libGL.so
> /include/GL/gl.h
>
> Anyway, I'll go blame the SoQt or Coin first and since I did only want
> to try out WAM on OpenRave+ros before porting the WAM arm to ros's
> urdf modelling -as we're discussing in another thread- I may just keep
> going. I though the installation would be straightforward.
>
> Just to be sure, what version of coin should I have installed
> libcoin40 or libcoin60 ?
>
> Thanks,
>
> Pol Monsó
>
>
> 2010/11/12 Rosen Diankov <[hidden email]>:
>> hi pol,
>>
>> sorry for the late response. it seems that things are failing in this command:
>>
>> g++ -o conftest -g -O2 -g -O2 -g -Wall -O2
>> -I/usr/include/Inventor/annex -D_REENTRANT  -L/usr/lib
>> -Wl,-Bsymbolic-functions conftest.cpp -lCoin -lGL -lXext -lSM -lICE
>> -lX11 -ldl -lpthread  >&5
>> /usr/bin/ld: cannot find -lGL
>>
>>
>> In other words, you do not have opengl libraries installed correctly
>> and coin3d is failing to link libGL
>>
>> rosen,
>>
>

------------------------------------------------------------------------------
Centralized Desktop Delivery: Dell and VMware Reference Architecture
Simplifying enterprise desktop deployment and management using
Dell EqualLogic storage and VMware View: A highly scalable, end-to-end
client virtualization framework. Read more!
http://p.sf.net/sfu/dell-eql-dev2dev
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Reply | Threaded
Open this post in threaded view
|

Re: OpenRave dependencies install

pmonso
I'm a bit confused, I didn't install openrave yet since it fails to
link to SoQt, so the command openrave is undefined.


2010/11/12 Rosen Diankov <[hidden email]>:

> hi pol,
>
> try
>
> sudo openrave
>
> usually that disables any graphics stuff
>
> both coin versions should work, although libcoin40 has been easier to
> get installed.
>
> rosen,
>
> 2010/11/12 Pol Monsó <[hidden email]>:
>> And yet it is installed at a standard location from the package manager:
>>
>> /usr/lib/libGL.so
>> /include/GL/gl.h
>>
>> Anyway, I'll go blame the SoQt or Coin first and since I did only want
>> to try out WAM on OpenRave+ros before porting the WAM arm to ros's
>> urdf modelling -as we're discussing in another thread- I may just keep
>> going. I though the installation would be straightforward.
>>
>> Just to be sure, what version of coin should I have installed
>> libcoin40 or libcoin60 ?
>>
>> Thanks,
>>
>> Pol Monsó
>>
>>
>> 2010/11/12 Rosen Diankov <[hidden email]>:
>>> hi pol,
>>>
>>> sorry for the late response. it seems that things are failing in this command:
>>>
>>> g++ -o conftest -g -O2 -g -O2 -g -Wall -O2
>>> -I/usr/include/Inventor/annex -D_REENTRANT  -L/usr/lib
>>> -Wl,-Bsymbolic-functions conftest.cpp -lCoin -lGL -lXext -lSM -lICE
>>> -lX11 -ldl -lpthread  >&5
>>> /usr/bin/ld: cannot find -lGL
>>>
>>>
>>> In other words, you do not have opengl libraries installed correctly
>>> and coin3d is failing to link libGL
>>>
>>> rosen,
>>>
>>
>

------------------------------------------------------------------------------
Centralized Desktop Delivery: Dell and VMware Reference Architecture
Simplifying enterprise desktop deployment and management using
Dell EqualLogic storage and VMware View: A highly scalable, end-to-end
client virtualization framework. Read more!
http://p.sf.net/sfu/dell-eql-dev2dev
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Reply | Threaded
Open this post in threaded view
|

Re: OpenRave dependencies install

Rosen Diankov
Administrator
try compiling a simple coin3d example and see if that finishes correctly.

on ubuntu 10.04 /usr/lib/libGL.so is a symlink to the mesa graphics
library. can you try reinstalling it?

rosen,

2010/11/12 Pol Monsó <[hidden email]>:

> I'm a bit confused, I didn't install openrave yet since it fails to
> link to SoQt, so the command openrave is undefined.
>
>
> 2010/11/12 Rosen Diankov <[hidden email]>:
>> hi pol,
>>
>> try
>>
>> sudo openrave
>>
>> usually that disables any graphics stuff
>>
>> both coin versions should work, although libcoin40 has been easier to
>> get installed.
>>
>> rosen,
>>
>> 2010/11/12 Pol Monsó <[hidden email]>:
>>> And yet it is installed at a standard location from the package manager:
>>>
>>> /usr/lib/libGL.so
>>> /include/GL/gl.h
>>>
>>> Anyway, I'll go blame the SoQt or Coin first and since I did only want
>>> to try out WAM on OpenRave+ros before porting the WAM arm to ros's
>>> urdf modelling -as we're discussing in another thread- I may just keep
>>> going. I though the installation would be straightforward.
>>>
>>> Just to be sure, what version of coin should I have installed
>>> libcoin40 or libcoin60 ?
>>>
>>> Thanks,
>>>
>>> Pol Monsó
>>>
>>>
>>> 2010/11/12 Rosen Diankov <[hidden email]>:
>>>> hi pol,
>>>>
>>>> sorry for the late response. it seems that things are failing in this command:
>>>>
>>>> g++ -o conftest -g -O2 -g -O2 -g -Wall -O2
>>>> -I/usr/include/Inventor/annex -D_REENTRANT  -L/usr/lib
>>>> -Wl,-Bsymbolic-functions conftest.cpp -lCoin -lGL -lXext -lSM -lICE
>>>> -lX11 -ldl -lpthread  >&5
>>>> /usr/bin/ld: cannot find -lGL
>>>>
>>>>
>>>> In other words, you do not have opengl libraries installed correctly
>>>> and coin3d is failing to link libGL
>>>>
>>>> rosen,
>>>>
>>>
>>
>

------------------------------------------------------------------------------
Centralized Desktop Delivery: Dell and VMware Reference Architecture
Simplifying enterprise desktop deployment and management using
Dell EqualLogic storage and VMware View: A highly scalable, end-to-end
client virtualization framework. Read more!
http://p.sf.net/sfu/dell-eql-dev2dev
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Reply | Threaded
Open this post in threaded view
|

Re: OpenRave dependencies install

pmonso
Indeed you're right!

Reinstalling mesa didn't work, but I've folowed the broken symlinks.
It seems that mesa moved everything to a folder without updating the
symlinks, henceforth leading to a broken symlink. I've restored the
symlink of mesa/libGL.so to libGL.so.1 and everything is working now.

I guess I should report the Mesa package maintainers?

Thanks!

Pol Monsó

2010/11/12 Rosen Diankov <[hidden email]>:

> try compiling a simple coin3d example and see if that finishes correctly.
>
> on ubuntu 10.04 /usr/lib/libGL.so is a symlink to the mesa graphics
> library. can you try reinstalling it?
>
> rosen,
>
> 2010/11/12 Pol Monsó <[hidden email]>:
>> I'm a bit confused, I didn't install openrave yet since it fails to
>> link to SoQt, so the command openrave is undefined.
>>
>>
>> 2010/11/12 Rosen Diankov <[hidden email]>:
>>> hi pol,
>>>
>>> try
>>>
>>> sudo openrave
>>>
>>> usually that disables any graphics stuff
>>>
>>> both coin versions should work, although libcoin40 has been easier to
>>> get installed.
>>>
>>> rosen,
>>>
>>> 2010/11/12 Pol Monsó <[hidden email]>:
>>>> And yet it is installed at a standard location from the package manager:
>>>>
>>>> /usr/lib/libGL.so
>>>> /include/GL/gl.h
>>>>
>>>> Anyway, I'll go blame the SoQt or Coin first and since I did only want
>>>> to try out WAM on OpenRave+ros before porting the WAM arm to ros's
>>>> urdf modelling -as we're discussing in another thread- I may just keep
>>>> going. I though the installation would be straightforward.
>>>>
>>>> Just to be sure, what version of coin should I have installed
>>>> libcoin40 or libcoin60 ?
>>>>
>>>> Thanks,
>>>>
>>>> Pol Monsó
>>>>
>>>>
>>>> 2010/11/12 Rosen Diankov <[hidden email]>:
>>>>> hi pol,
>>>>>
>>>>> sorry for the late response. it seems that things are failing in this command:
>>>>>
>>>>> g++ -o conftest -g -O2 -g -O2 -g -Wall -O2
>>>>> -I/usr/include/Inventor/annex -D_REENTRANT  -L/usr/lib
>>>>> -Wl,-Bsymbolic-functions conftest.cpp -lCoin -lGL -lXext -lSM -lICE
>>>>> -lX11 -ldl -lpthread  >&5
>>>>> /usr/bin/ld: cannot find -lGL
>>>>>
>>>>>
>>>>> In other words, you do not have opengl libraries installed correctly
>>>>> and coin3d is failing to link libGL
>>>>>
>>>>> rosen,
>>>>>
>>>>
>>>
>>
>

------------------------------------------------------------------------------
Centralized Desktop Delivery: Dell and VMware Reference Architecture
Simplifying enterprise desktop deployment and management using
Dell EqualLogic storage and VMware View: A highly scalable, end-to-end
client virtualization framework. Read more!
http://p.sf.net/sfu/dell-eql-dev2dev
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users