Problems with OpenRave install/finding plugins

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Problems with OpenRave install/finding plugins

Daniel Seidel
Hi Rosen,

I am encountering some trouble with my local OpenRave installation. Since I am working on a ubuntu precise netboot system, I do not have any sudo rights and therefore have to make a local install. My way of doing this was using a fresh ubuntu precise installation and on it running apt-get build-dep openrave and apt-get install openrave with print uris option. From this I downloaded all deb packages needed and transfered them to my system. Here I extrated them to my local installation path. Now my problem: compilation and everything works fine, however, when trying to run my programm I get the following

<ds@calcit|14:52:47> build $ make && build/openRaveTest 
[100%] Built target openRaveTest
[plugindatabase.h:392] /usr/share/openrave-0.8/plugins doesn't exist
[libopenrave.cpp:737] /usr/share/openrave-0.8 doesn't exist
[plugindatabase.h:573] Failed to create name ode, interface collisionchecker
[plugindatabase.h:573] Failed to create name bullet, interface collisionchecker                                                          
[plugindatabase.h:573] Failed to create name pqp, interface collisionchecker                                                             
[plugindatabase.h:573] Failed to create name pqp, interface collisionchecker                                                             
[environment-core.h:782] disabling collisions
[plugindatabase.h:573] Failed to create name qtcoin, interface viewer
[plugindatabase.h:573] Failed to create name ivmodelloader, interface module 

The following I have added to my .bashrc:
export PATH=$PATH:/homes/dseidel/raveinstall/:/homes/dseidel/raveinstall/bin
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH=:/homes/dseidel/raveinstall/lib

$ openrave --version
does list me correctly "0.8.2"

what do I have to do to make openrave find the plugins? I have checked the folders and all files are in the correct place.

I have found this earlier question, which, however, was no help.

kind regards
daniel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problems with OpenRave install/finding plugins

Rosen Diankov
Administrator
hi daniel,

we actually have a script that will setup the entire environment for
you. just do:

source /homes/dseidel/raveinstall/:/homes/dseidel/raveinstall/share/openrave-0.8/openrave.bash

hope this helps,

2013/3/21 Daniel Seidel <[hidden email]>:

> Hi Rosen,
>
> I am encountering some trouble with my local OpenRave installation. Since I
> am working on a ubuntu precise netboot system, I do not have any sudo rights
> and therefore have to make a local install. My way of doing this was using a
> fresh ubuntu precise installation and on it running apt-get build-dep
> openrave and apt-get install openrave with print uris option. From this I
> downloaded all deb packages needed and transfered them to my system. Here I
> extrated them to my local installation path. Now my problem: compilation and
> everything works fine, however, when trying to run my programm I get the
> following
>
>
>
> The following I have added to my .bashrc:
> export PATH=$PATH:/homes/dseidel/raveinstall/:/homes/dseidel/raveinstall/bin
> export LD_LIBRARY_PATH=$LD_LIBRARY_PATH=:/homes/dseidel/raveinstall/lib
>
> $ openrave --version
> does list me correctly "0.8.2"
>
> what do I have to do to make openrave find the plugins? I have checked the
> folders and all files are in the correct place.
>
> I have found  this
> <http://openrave-users-list.185357.n3.nabble.com/Grabbing-of-Object-td3061764.html>
> earlier question, which, however, was no help.
>
> kind regards
> daniel
>
>
>
>
> --
> View this message in context: http://openrave-users-list.185357.n3.nabble.com/Problems-with-OpenRave-install-finding-plugins-tp4026211.html
> Sent from the OpenRAVE Users List mailing list archive at Nabble.com.
>
> ------------------------------------------------------------------------------
> Everyone hates slow websites. So do we.
> Make your web apps faster with AppDynamics
> Download AppDynamics Lite for free today:
> http://p.sf.net/sfu/appdyn_d2d_mar
> _______________________________________________
> Openrave-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/openrave-users

------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_mar
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problems with OpenRave install/finding plugins

Daniel Seidel
hi,

I still have the problem, even when using the script. I think the problem is with this:
$ openrave-config --share-dir
/usr/share/openrave-0.8

this is somehow configured to be pointing to usr directory and since there are no openrave files
[plugindatabase.h:392] /usr/share/openrave-0.8/plugins doesn't exist
[libopenrave.cpp:737] /usr/share/openrave-0.8 doesn't exist
is the logic consequence.

<ds@calcit|11:20:33> build $ echo $LD_LIBRARY_PATH
/homes/dseidel/raveinstall/lib:
<ds@calcit|11:20:41> build $ echo $PATH
/homes/dseidel/raveinstall/bin:/usr/bin:/usr/bin:[..]
<ds@calcit|11:20:49> build $ openrave --version
0.8.2
<ds@calcit|11:21:25> build $ which openrave
/homes/dseidel/raveinstall/bin/openrave
<ds@calcit|11:21:29> build $ which openrave-config
/homes/dseidel/raveinstall/bin/openrave-config
<ds@calcit|11:22:18> build $ openrave-config --share-dir
/usr/share/openrave-0.8

So, the environment variables set by the script all seem to be okay. How can this share dir be configured or where might it come from?

Daniel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problems with OpenRave install/finding plugins

Franks
im sorry but is this OpenRAVE/IKFast only good for ubuntu ?im on win 8.1 x64 and i have had Zero luck with Visual Studio 2013

"so did you get the problem solved ? im having issues as well "
Loading...