Unable to install openRAVE. Package catalog broken.

classic Classic list List threaded Threaded
33 messages Options
12
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Unable to install openRAVE. Package catalog broken.

ratneshmadaan
This post was updated on .
Got an error of unmet dependencies on the first install attempt. Now when I redo apt-get install:

ratneshmadaan@ratneshmadaan-Inspiron-N5010:~$ sudo apt-get install openraveReading package lists... Done
Building dependency tree      
Reading state information... Done
openrave is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 openrave0.8-dp-plugin-bulletrave : Depends: libbullet2.80 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

So , I try:

atneshmadaan@ratneshmadaan-Inspiron-N5010:~$ sudo apt-get install libbullet2.80Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following NEW packages will be installed:
  libbullet2.80
0 upgraded, 1 newly installed, 0 to remove and 111 not upgraded.
1 not fully installed or removed.
Need to get 0 B/981 kB of archives.
After this operation, 2,369 kB of additional disk space will be used.
(Reading database ... 285795 files and directories currently installed.)
Unpacking libbullet2.80 (from .../libbullet2.80_2.80.2-ubuntu1~precise1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libbullet2.80_2.80.2-ubuntu1~precise1_i386.deb (--unpack):
 trying to overwrite '/usr/lib/libBulletWorldImporter.so.2.80', which is also in package libbullet 2.80-0
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libbullet2.80_2.80.2-ubuntu1~precise1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Also, package catalog is broken. This is the output apt-get-f install:

ratneshmadaan@ratneshmadaan-Inspiron-N5010:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libbullet2.80
The following NEW packages will be installed:
  libbullet2.80
0 upgraded, 1 newly installed, 0 to remove and 111 not upgraded.
1 not fully installed or removed.
Need to get 0 B/981 kB of archives.
After this operation, 2,369 kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
(Reading database ... 285795 files and directories currently installed.)
Unpacking libbullet2.80 (from .../libbullet2.80_2.80.2-ubuntu1~precise1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libbullet2.80_2.80.2-ubuntu1~precise1_i386.deb (--unpack):
 trying to overwrite '/usr/lib/libBulletWorldImporter.so.2.80', which is also in package libbullet 2.80-0
No apport report written because MaxReports is reached already
                                                              dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libbullet2.80_2.80.2-ubuntu1~precise1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


I have tried clean and autoclean.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to install openRAVE. Package catalog broken.

Praveen
Hi Ratnesh,

Suggested method is to completely remove the installed bullet from your system.
Install Bullet and OpenRAVE. It should work.
You need to resolve the package dependencies.

What is the output of :

sudo apt-get autoremove libullet*  

Best Regards
Praveen

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to install openRAVE. Package catalog broken.

ratneshmadaan
ratneshmadaan@ratneshmadaan-Inspiron-N5010:~/catkin_ws$ sudo apt-get autoremove libbullet
Reading package lists... Done
Building dependency tree      
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libbullet-dev : Depends: libbullet (= 2.80-0) but it is not going to be installed
 openrave0.8-dp-plugin-bulletrave : Depends: libbullet2.80 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to install openRAVE. Package catalog broken.

ratneshmadaan
with the regex

ratneshmadaan@ratneshmadaan-Inspiron-N5010:~$ sudo apt-get autoremove libbullet*
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Note, selecting 'libbullet2.80' for regex 'libbullet*'
Note, selecting 'libbulletml-dev' for regex 'libbullet*'
Note, selecting 'libbulletml0d2' for regex 'libbullet*'
Note, selecting 'libbullet-dev' for regex 'libbullet*'
Note, selecting 'libbullet2.80-dev' for regex 'libbullet*'
Note, selecting 'libbullet' for regex 'libbullet*'
Package libbulletml-dev is not installed, so not removed
Package libbulletml0d2 is not installed, so not removed
Package libbullet2.80-dev is not installed, so not removed
Package libbullet2.80 is not installed, so not removed
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 openrave0.8-dp-plugin-bulletrave : Depends: libbullet2.80 but it is not going to be installed
 ros-hydro-tf2-bullet : Depends: libbullet-dev but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to install openRAVE. Package catalog broken.

ratneshmadaan
In reply to this post by ratneshmadaan
with the regex

ratneshmadaan@ratneshmadaan-Inspiron-N5010:~$ sudo apt-get autoremove libbullet*
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Note, selecting 'libbullet2.80' for regex 'libbullet*'
Note, selecting 'libbulletml-dev' for regex 'libbullet*'
Note, selecting 'libbulletml0d2' for regex 'libbullet*'
Note, selecting 'libbullet-dev' for regex 'libbullet*'
Note, selecting 'libbullet2.80-dev' for regex 'libbullet*'
Note, selecting 'libbullet' for regex 'libbullet*'
Package libbulletml-dev is not installed, so not removed
Package libbulletml0d2 is not installed, so not removed
Package libbullet2.80-dev is not installed, so not removed
Package libbullet2.80 is not installed, so not removed
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 openrave0.8-dp-plugin-bulletrave : Depends: libbullet2.80 but it is not going to be installed
 ros-hydro-tf2-bullet : Depends: libbullet-dev but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to install openRAVE. Package catalog broken.

Praveen
good :-)
Could you please try :
sudo apt-get remove openrave0.8-dp-plugin-bulletrave  ros-hydro-tf2-bullet

Do not worry if it removes lots of stuff, it can be retrieved.
Also, run :
sudo apt-get update

Please post the output.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to install openRAVE. Package catalog broken.

ratneshmadaan
Oh shit! I didn't see your reply and reinstalled ubuntu yesterday. Funny thing is I decided to ros fuerte with the youbot this time. And openrave installed just fine! However, I have no idea why the base is green.
30.png

I'll let you know of the hydro distro issue soon.

Thanks
Ratnesh
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to install openRAVE. Package catalog broken.

ratneshmadaan
This post was updated on .
errors2.sh

How can I do anything if the package catalog is broken?
Aargh, this is frustrating me.

This is a different machine.
i should have used --ignore.

How can I remove them now? Would doing it manually help?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to install openRAVE. Package catalog broken.

Rosen Diankov
Administrator
can you try the openrave debian packages in the testing repo?

https://launchpad.net/~openrave/+archive/testing


2014-05-26 17:37 GMT+09:00 ratneshmadaan <[hidden email]>:
errors2.sh
<http://openrave-users-list.185357.n3.nabble.com/file/n4026990/errors2.sh>

How can I do anything if the package catalog is broken?
Aargh, this is frustrating me.



--
View this message in context: http://openrave-users-list.185357.n3.nabble.com/Unable-to-install-openRAVE-Package-catalog-broken-tp4026982p4026990.html
Sent from the OpenRAVE Users List mailing list archive at Nabble.com.

------------------------------------------------------------------------------
The best possible search technologies are now affordable for all companies.
Download your FREE open source Enterprise Search Engine today!
Our experts will assist you in its installation for $59/mo, no commitment.
Test it for FREE on our Cloud platform anytime!
http://pubads.g.doubleclick.net/gampad/clk?id=145328191&iu=/4140/ostg.clktrk
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users


------------------------------------------------------------------------------
The best possible search technologies are now affordable for all companies.
Download your FREE open source Enterprise Search Engine today!
Our experts will assist you in its installation for $59/mo, no commitment.
Test it for FREE on our Cloud platform anytime!
http://pubads.g.doubleclick.net/gampad/clk?id=145328191&iu=/4140/ostg.clktrk
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to install openRAVE. Package catalog broken.

ratneshmadaan
But nothing can be installed as my package catalog is broken. How can I fix it?

I downloaded the ppa and apt-get updated. And I can't go further. Have a look:

`youbot@youbot-desktop:~/scripts_youBot$ sudo apt-get install openrave0.9
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Note, selecting 'openrave0.9-dp-plugin-dualmanipulation' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-octave' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-plugin-bulletrave' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-python' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-plugin-qtcoinrave' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-plugins-base' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-base' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-plugin-oderave' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-plugin-ikfastsolvers' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-data' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-plugin-logging' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-matlab' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-dev' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-ikfast' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-plugin-grasper' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-plugins-all' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-plugin-textserver' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-plugin-qtosgrave' for regex 'openrave0.9'
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 openrave0.8-dp-plugin-bulletrave : Depends: libbullet2.80 but it is not going to be installed
 openrave0.9-dp-base : Depends: collada-dom2.4-dp-base (>= 2.4.2.0-ubuntu1~precise1) but 2.4.0.16-ubuntu1~precise1 is to be installed
 openrave0.9-dp-plugin-bulletrave : Depends: libbullet2.80 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
`
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to install openRAVE. Package catalog broken.

Rosen Diankov
Administrator
you don't have to install the bullet plugin. try openrave0.9 packages without the bullet dependency, ie:

sudo apt-get install openrave0.9-dp-plugin-ikfastsolvers openrave0.9-dp-base     openrave0.9-dp-octave       openrave0.9-dp-plugin-logging   openrave0.9-dp-plugins-base openrave0.9-dp-data     openrave0.9-dp-plugin-oderave   openrave0.9-dp-plugin-textserver openrave0.9-dp-dev      openrave0.9-dp-plugin-dualmanipulation  openrave0.9-dp-plugin-qtcoinrave    openrave0.9-dp-python openrave0.9-dp-ikfast       openrave0.9-dp-plugin-grasper   openrave0.9-dp-plugin-qtosgrave    



2014-05-26 19:00 GMT+09:00 ratneshmadaan <[hidden email]>:
But nothing can be installed as my package catalog is broken. How can I fix
it?

I downloaded the ppa and apt-get updated. And I can't go further. Have a
look:

`youbot@youbot-desktop:~/scripts_youBot$ sudo apt-get install openrave0.9
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'openrave0.9-dp-plugin-dualmanipulation' for regex
'openrave0.9'
Note, selecting 'openrave0.9-dp-octave' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-plugin-bulletrave' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-python' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-plugin-qtcoinrave' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-plugins-base' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-base' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-plugin-oderave' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-plugin-ikfastsolvers' for regex
'openrave0.9'
Note, selecting 'openrave0.9-dp-data' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-plugin-logging' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-matlab' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-dev' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-ikfast' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-plugin-grasper' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-plugins-all' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-plugin-textserver' for regex 'openrave0.9'
Note, selecting 'openrave0.9-dp-plugin-qtosgrave' for regex 'openrave0.9'
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 openrave0.8-dp-plugin-bulletrave : Depends: libbullet2.80 but it is not
going to be installed
 openrave0.9-dp-base : Depends: collada-dom2.4-dp-base (>=
2.4.2.0-ubuntu1~precise1) but 2.4.0.16-ubuntu1~precise1 is to be installed
 openrave0.9-dp-plugin-bulletrave : Depends: libbullet2.80 but it is not
going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify
a solution).
`



--
View this message in context: http://openrave-users-list.185357.n3.nabble.com/Unable-to-install-openRAVE-Package-catalog-broken-tp4026982p4026992.html
Sent from the OpenRAVE Users List mailing list archive at Nabble.com.

------------------------------------------------------------------------------
The best possible search technologies are now affordable for all companies.
Download your FREE open source Enterprise Search Engine today!
Our experts will assist you in its installation for $59/mo, no commitment.
Test it for FREE on our Cloud platform anytime!
http://pubads.g.doubleclick.net/gampad/clk?id=145328191&iu=/4140/ostg.clktrk
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users


------------------------------------------------------------------------------
The best possible search technologies are now affordable for all companies.
Download your FREE open source Enterprise Search Engine today!
Our experts will assist you in its installation for $59/mo, no commitment.
Test it for FREE on our Cloud platform anytime!
http://pubads.g.doubleclick.net/gampad/clk?id=145328191&iu=/4140/ostg.clktrk
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to install openRAVE. Package catalog broken.

ratneshmadaan
This post was updated on .
Yes you both are right. I did this and all dependencies are resolved! Thanks. Feeling like a noob.

 sudo apt-get remove openrave0.8-dp-plugin-bulletrave

Now, I can work in peace. :)

I'll try 0.9 as well.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to install openRAVE. Package catalog broken.

ratneshmadaan
This post was updated on .
The blunder I was making all this time was that I assumed if the package catalog is broken, I can neither remove nor install new packages. Only the second statement is true, though. (?).
(after an apt-get autoclean), I tried removing the libbullet plugin which worked. Hah.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to install openRAVE. Package catalog broken.

ratneshmadaan
The only issue that remains is the base of the youbot model is green! Maybe, Praveen can help me out or I ll raise an issue on github.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to install openRAVE. Package catalog broken.

Sbenaissa
This post has NOT been accepted by the mailing list yet.
In reply to this post by Praveen
Go to the archives's directory :''/var/cache/apt/archives$"
cd /var/cache/apt/archives/
rm libbullet2.80_2.80.2-ubuntu1~precise1_i386.deb
sudo apt-get -f install




Good luck
S.Benaissa
ENSEM-Casablanca
Morocco
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to install openRAVE. Package catalog broken.

Franks
This post was updated on .
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to install openRAVE. Package catalog broken.

Rosen Diankov
Administrator
Dear Franks,

you can get ikfast from here:

https://github.com/rdiankov/openrave/tree/master/python

it's actually two files: ikfast.py and ikfast_generator_cpp.py
you'll need sympy 0.7.1 to run it. it should output a c++ file for you.

hope this helps,
best,

2015-10-24 2:13 GMT+09:00 Franks <[hidden email]>:
is this in reply to my post?




--
View this message in context: http://openrave-users-list.185357.n3.nabble.com/Unable-to-install-openRAVE-Package-catalog-broken-tp4026982p4027650.html
Sent from the OpenRAVE Users List mailing list archive at Nabble.com.

------------------------------------------------------------------------------
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users


------------------------------------------------------------------------------

_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to install openRAVE. Package catalog broken.

Franks
Thanks now is this for use once i install the Linux or ubuntu inside the VM in my win 8.1 ? just want to be clear prior to installing things "the order of operations seems like"
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to install openRAVE. Package catalog broken.

Rosen Diankov
Administrator
although ikfast is a standalone program, it needs to get the kinematics information of the robot, which is uses openrave for. so you'll need openrave installed to use it, so yes you'll have to install everything on the VM first.

2015-11-18 1:29 GMT+09:00 Franks <[hidden email]>:
Thanks now is this for use once i install the Linux or ubuntu inside the VM
in my win 8.1 ? just want to be clear prior to installing things "the order
of operations seems like"



--
View this message in context: http://openrave-users-list.185357.n3.nabble.com/Unable-to-install-openRAVE-Package-catalog-broken-tp4026982p4027668.html
Sent from the OpenRAVE Users List mailing list archive at Nabble.com.

------------------------------------------------------------------------------
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users


------------------------------------------------------------------------------

_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to install openRAVE. Package catalog broken.

Franks
Hey there rosen i installed the VM with ubuntu inside and a copy of Python3.3.6 and sympy, i also have those 2 files .cpp.py from the open rave folder now im ready to install but do not know whats next or how to execute those files in ubuntu, can i get next steps ?
12
Loading...