Unable to install openRAVE. Package catalog broken.

classic Classic list List threaded Threaded
33 messages Options
12
Reply | Threaded
Open this post in threaded view
|

Re: Unable to install openRAVE. Package catalog broken.

Franks
this is all i was able to do with limited help and im stuck at installing openrave,.

set up apt-get repository

http://openrave.org/docs/latest_stable/install/#install

sudo add-apt-repository ppa:openrave/release
sudo apt-get update

# Next: install package

sudo apt-get install openrave0.8-sp


deb http://ppa.launchpad.net/openrave/release/ubuntu trusty main
deb-src http://ppa.launchpad.net/openrave/release/ubuntu trusty main

sudo sh -c 'echo "deb-src http://ppa.launchpad.net/openrave/release/ubuntu `lsb_release -cs` main" >> /etc/apt/sources.list.d/openrave-release-`lsb_release -cs`.list'

sudo apt-get install g++ libqt4-dev qt4-dev-tools ffmpeg libavcodec-dev libavformat-dev libxvidcore-dev libx264-dev libfaac-dev libogg-dev libvorbis-dev libdc1394-dev liblame-dev libgsm1-dev libboost-dev libboost-regex-dev libxml2-dev libglew-dev  libboost-graph-dev libboost-wave-dev libboost-serialization-dev libboost-filesystem-dev libpcre3-dev libboost-thread-dev libmpfr-dev libboost-date-time-dev libqhull-dev libswscale-dev lapack3-dev

1. I need help figuring out a package dependancy problem
2. I need help compiling and installing OpenRave

The default directions to install did not work for me, we think it is a problem with the repository, but we don't know.
Reply | Threaded
Open this post in threaded view
|

Re: Unable to install openRAVE. Package catalog broken.

andreas
What OS are you using? In case of Ubuntu 14.04, there's a tutorial within the openrave repo.

-- Andreas

----- Original Message -----
From: "Franks" <[hidden email]>
To: "openrave-users" <[hidden email]>
Sent: Tuesday, November 24, 2015 3:32:23 PM
Subject: Re: [OpenRAVE-users] Unable to install openRAVE. Package catalog broken.

this is all i was able to do with limited help and im stuck at installing
openrave,.

set up apt-get repository

http://openrave.org/docs/latest_stable/install/#install

sudo add-apt-repository ppa:openrave/release
sudo apt-get update

# Next: install package

sudo apt-get install openrave0.8-sp


deb http://ppa.launchpad.net/openrave/release/ubuntu trusty main
deb-src http://ppa.launchpad.net/openrave/release/ubuntu trusty main

sudo sh -c 'echo "deb-src http://ppa.launchpad.net/openrave/release/ubuntu
`lsb_release -cs` main" >>
/etc/apt/sources.list.d/openrave-release-`lsb_release -cs`.list'

sudo apt-get install g++ libqt4-dev qt4-dev-tools ffmpeg libavcodec-dev
libavformat-dev libxvidcore-dev libx264-dev libfaac-dev libogg-dev
libvorbis-dev libdc1394-dev liblame-dev libgsm1-dev libboost-dev
libboost-regex-dev libxml2-dev libglew-dev  libboost-graph-dev
libboost-wave-dev libboost-serialization-dev libboost-filesystem-dev
libpcre3-dev libboost-thread-dev libmpfr-dev libboost-date-time-dev
libqhull-dev libswscale-dev lapack3-dev

1. I need help figuring out a package dependancy problem
2. I need help compiling and installing OpenRave

The default directions to install did not work for me, we think it is a
problem with the repository, but we don't know.




--
View this message in context: http://openrave-users-list.185357.n3.nabble.com/Unable-to-install-openRAVE-Package-catalog-broken-tp4026982p4027681.html
Sent from the OpenRAVE Users List mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Go from Idea to Many App Stores Faster with Intel(R) XDK
Give your users amazing mobile app experiences with Intel(R) XDK.
Use one codebase in this all-in-one HTML5 development environment.
Design, debug & build mobile apps & 2D/3D high-impact games for multiple OSs.
http://pubads.g.doubleclick.net/gampad/clk?id=254741551&iu=/4140
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users

------------------------------------------------------------------------------
Go from Idea to Many App Stores Faster with Intel(R) XDK
Give your users amazing mobile app experiences with Intel(R) XDK.
Use one codebase in this all-in-one HTML5 development environment.
Design, debug & build mobile apps & 2D/3D high-impact games for multiple OSs.
http://pubads.g.doubleclick.net/gampad/clk?id=254741551&iu=/4140
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Reply | Threaded
Open this post in threaded view
|

Re: Unable to install openRAVE. Package catalog broken.

Franks
hello there Andreas, my OS is Windows 8.1 but im running a VM for Ubuntu 14.04 and python 3.3.6 do you have a link to this video ? this is alot harder then i thought but then again is only cuz im a Windows Native user
Reply | Threaded
Open this post in threaded view
|

Re: Unable to install openRAVE. Package catalog broken.

andreas
No video, just text instructions:

1. https://github.com/rdiankov/openrave/blob/master/docs/Tutorial%20for%20Installing%20Openrave%20in%20Ubuntu-Ubuntu%20Mate%2014.04.2%20x64.rst
2. http://www.aizac.info/installing-openrave0-9-on-ubuntu-trusty-14-04-64bit/

Hope this helps!

-- Andreas

----- Original Message -----
From: "Franks" <[hidden email]>
To: "openrave-users" <[hidden email]>
Sent: Wednesday, November 25, 2015 10:31:38 AM
Subject: Re: [OpenRAVE-users] Unable to install openRAVE. Package catalog broken.

hello there Andreas, my OS is Windows 8.1 but im running a VM for Ubuntu
14.04 and python 3.3.6 do you have a link to this video ? this is alot
harder then i thought but then again is only cuz im a Windows Native user



--
View this message in context: http://openrave-users-list.185357.n3.nabble.com/Unable-to-install-openRAVE-Package-catalog-broken-tp4026982p4027684.html
Sent from the OpenRAVE Users List mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Go from Idea to Many App Stores Faster with Intel(R) XDK
Give your users amazing mobile app experiences with Intel(R) XDK.
Use one codebase in this all-in-one HTML5 development environment.
Design, debug & build mobile apps & 2D/3D high-impact games for multiple OSs.
http://pubads.g.doubleclick.net/gampad/clk?id=254741551&iu=/4140
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users

------------------------------------------------------------------------------
Go from Idea to Many App Stores Faster with Intel(R) XDK
Give your users amazing mobile app experiences with Intel(R) XDK.
Use one codebase in this all-in-one HTML5 development environment.
Design, debug & build mobile apps & 2D/3D high-impact games for multiple OSs.
http://pubads.g.doubleclick.net/gampad/clk?id=254741551&iu=/4140
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Reply | Threaded
Open this post in threaded view
|

Re: Unable to install openRAVE. Package catalog broken.

Franks
thanks i will look at those link men! but my biggest issue is that i dont know how to navigate or even use python or ubuntu, when i was trying to do all this in windows i was GOLDEN till i got hit with a issue about Boot libraries and something about the repository being closed for downloads and that was the end of my trip MAYYYYBE i should just have someone like you who can help me simulate the asnwers im looking for by me supplying what ever i have to for you to generate the c++ code i need for the IK ?

my robots are in my websites gallery maybe you wanna check it out.
www.excorp.weebly.com
but here is the one im looking to use IKfast on
 
Reply | Threaded
Open this post in threaded view
|

Re: Unable to install openRAVE. Package catalog broken.

Franks
In reply to this post by Rosen Diankov
can i get a hand here im really trying by what seems obvious to do as a noob in python and ubuntu this are both not my forte im a windows user and a c/c++ guy so im really lost here and im just about youtube and here for help and so far i got no where .

what am i doing wrong i thought all i needed was 2 files ikfast.py and the ikfast_generator.cpp.py ?

what am i doing wrong?
Reply | Threaded
Open this post in threaded view
|

Re: Unable to install openRAVE. Package catalog broken.

baxelrod
In reply to this post by ratneshmadaan

The openrave git hub is located at: https://github.com/rdiankov/openrave.  It might be a bit of work to compile on windows.  

To get your ikfast files:
1. cd ~/openrave-0.9.0-src
2. mkdir build
3. cd build
4. cmake ..
5. make -j8
6. sudo make install
7. make an xml for your robot according to: http://openrave.programmingvision.com/wiki/index.php/Format:XML 
7. cd wherever/your/robot/xml/files/are
8. openrave.py --database inversekinematics --robot=<robotname> --manipname=<manipname> --iktype=Transform6D
Note that you may want to use a different iktype as listed here: http://openrave.org/docs/latest_stable/openravepy/ikfast/#ikfast-compiler.  You may also need to specify a number of "free joints" depending on the DOF of your robot.  
9. If it succeeds, there will be a message on the console telling you where the files are located.  It will be located under a directory like: ~/.openrave/kinematics.00e8882ecafb8d259f52002e3dc9755d
10. use the .cpp and .h file in your own C++ code!  Take a look at the bottom of the .cpp file for example usage.

Hope that helps,
Ben


-----Original Message-----
From: Franks [mailto:[hidden email]]
Sent: Monday, November 30, 2015 7:01 PM
To: [hidden email]
Subject: Re: [OpenRAVE-users] Unable to install openRAVE. Package catalog broken.

can i get a hand here im really trying by what seems obvious to do as a noob in python and ubuntu this are both not my forte im a windows user and a c/c++ guy so im really lost here and im just about youtube and here for help and so far i got no where .

what am i doing wrong i thought all i needed was 2 files ikfast.py and the ikfast_generator.cpp.py ?

<https://urldefense.proofpoint.com/v2/url?u=http-3A__openrave-2Dusers-2Dlist.185357.n3.nabble.com_file_n4027691_why.jpg&d=CwICAg&c=jIGm9aumLIlctTGl0fKZ3w&r=1iJ6OX7D7L47l9bTpxrbK0TAPfNh_pNdp6N0eQk4AYg&m=-WvfmjLS5nmemcXb-yfHy8LNNV_EHU7CNe2rGhbNj64&s=QaWNcVZ_3g5rYU9nV8F7H7-579zjDHTrZNa4jzjnRWw&e= >



--
View this message in context: https://urldefense.proofpoint.com/v2/url?u=http-3A__openrave-2Dusers-2Dlist.185357.n3.nabble.com_Unable-2Dto-2Dinstall-2DopenRAVE-2DPackage-2Dcatalog-2Dbroken-2Dtp4026982p4027691.html&d=CwICAg&c=jIGm9aumLIlctTGl0fKZ3w&r=1iJ6OX7D7L47l9bTpxrbK0TAPfNh_pNdp6N0eQk4AYg&m=-WvfmjLS5nmemcXb-yfHy8LNNV_EHU7CNe2rGhbNj64&s=4hm_JhECGASVEn5xZfeC1n2rjZhNGpvrFC6oPNfeMyA&e=
Sent from the OpenRAVE Users List mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Go from Idea to Many App Stores Faster with Intel(R) XDK Give your users amazing mobile app experiences with Intel(R) XDK.
Use one codebase in this all-in-one HTML5 development environment.
Design, debug & build mobile apps & 2D/3D high-impact games for multiple OSs.
https://urldefense.proofpoint.com/v2/url?u=http-3A__pubads.g.doubleclick.net_gampad_clk-3Fid-3D254741911-26iu-3D_4140&d=CwICAg&c=jIGm9aumLIlctTGl0fKZ3w&r=1iJ6OX7D7L47l9bTpxrbK0TAPfNh_pNdp6N0eQk4AYg&m=-WvfmjLS5nmemcXb-yfHy8LNNV_EHU7CNe2rGhbNj64&s=9XEhJtiJpFrmIOs9C1YMVD4wmVepZYQzanOlL9rpWsI&e=
_______________________________________________
Openrave-users mailing list
[hidden email]
https://urldefense.proofpoint.com/v2/url?u=https-3A__lists.sourceforge.net_lists_listinfo_openrave-2Dusers&d=CwICAg&c=jIGm9aumLIlctTGl0fKZ3w&r=1iJ6OX7D7L47l9bTpxrbK0TAPfNh_pNdp6N0eQk4AYg&m=-WvfmjLS5nmemcXb-yfHy8LNNV_EHU7CNe2rGhbNj64&s=hTh0AltqvOpwtov-it-HKBs1FytoJiW4I8u0bOIkmn4&e= 

------------------------------------------------------------------------------
Go from Idea to Many App Stores Faster with Intel(R) XDK
Give your users amazing mobile app experiences with Intel(R) XDK.
Use one codebase in this all-in-one HTML5 development environment.
Design, debug & build mobile apps & 2D/3D high-impact games for multiple OSs.
http://pubads.g.doubleclick.net/gampad/clk?id=254741911&iu=/4140
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Reply | Threaded
Open this post in threaded view
|

Re: Unable to install openRAVE. Package catalog broken.

Franks
Thanks for that Baxelrod tho i think i was misled about what i really needed cuz i was told that i only really need 2 files to get up and running but im hearing you talking about other names which i dont think i downloaded or know where to download from specifically? and what is this xml ? how do i make that ?> i did look at the link http://openrave.programmingvision.com/wiki/index.php/Format:XML#OpenRAVE_Custom_XML_Format  but it does not tells me how to make that or what sorta thing to consider in order to make one,
Reply | Threaded
Open this post in threaded view
|

Re: Unable to install openRAVE. Package catalog broken.

baxelrod
Maybe I misunderstood your question / goal.  I thought you wanted to do some inverse kinematics with your robot.  And to do so (with OpenRave and/or ikfast) you need to first generate the ikfast files.  These are standalone C++ files that you can use in your own code without any OpenRave.  They might even work in Windows.

It might be possible to generate ikfast files without installing OpenRave.  The ikfast generator is written in Python after all...  But I have never done it this way.  And if it is all Python, then you can theoretically do it in Windows.

In order for OpenRave to understand the construction of your robot, you need to create this xml file.  This is similar to a ROS urdf file, but the syntax is different.  The link I sent has some simple examples and the entire xml schema.  There are also xml files for a number of standard robots such as the WAM, PR2, Puma, etc.  Look under src/robots for examples.

If you are just going to use the generated ikfast files outside of OpenRave, I don't believe you need much more than the links and joints in your xml.  Ikfast doesn't do collision checking or even joint limit checking (I think).  So you don't need to put mesh files or geometric solids to make your robot actually look like a robot.  But I do recommend it if you are making your robot xml file for the first time.  Viewing the robot and moving the joints around in OpenRave will help you verify everything is correct.

Good luck,
Ben


-----Original Message-----
From: Franks [mailto:[hidden email]]
Sent: Wednesday, December 02, 2015 12:17 PM
To: [hidden email]
Subject: Re: [OpenRAVE-users] Unable to install openRAVE. Package catalog broken.

Thanks for that Baxelrod tho i think i was misled about what i really needed cuz i was told that i only really need 2 files to get up and running but im hearing you talking about other names which i dont think i downloaded or know where to download from specifically? and what is this xml ? how do i make that ?> i did look at the link https://urldefense.proofpoint.com/v2/url?u=http-3A__openrave.programmingvision.com_wiki_index.php_Format-3AXML-23OpenRAVE-5FCustom-5FXML-5FFormat&d=CwICAg&c=jIGm9aumLIlctTGl0fKZ3w&r=1iJ6OX7D7L47l9bTpxrbK0TAPfNh_pNdp6N0eQk4AYg&m=sibWvlHHG47ieAtRqQhVtXfe1icTG-fWvZc4LWfZUjI&s=NBBng3Q8Y7VwaXU3v8y1PUzcYPcW0SNqqjy_4WZPGBk&e= 
<https://urldefense.proofpoint.com/v2/url?u=http-3A__openrave.programmingvision.com_wiki_index.php_Format-3AXML-23OpenRAVE-5FCustom-5FXML-5FFormat&d=CwICAg&c=jIGm9aumLIlctTGl0fKZ3w&r=1iJ6OX7D7L47l9bTpxrbK0TAPfNh_pNdp6N0eQk4AYg&m=sibWvlHHG47ieAtRqQhVtXfe1icTG-fWvZc4LWfZUjI&s=NBBng3Q8Y7VwaXU3v8y1PUzcYPcW0SNqqjy_4WZPGBk&e= >  
but it does not tells me how to make that or what sorta thing to consider in order to make one,



--
View this message in context: https://urldefense.proofpoint.com/v2/url?u=http-3A__openrave-2Dusers-2Dlist.185357.n3.nabble.com_Unable-2Dto-2Dinstall-2DopenRAVE-2DPackage-2Dcatalog-2Dbroken-2Dtp4026982p4027693.html&d=CwICAg&c=jIGm9aumLIlctTGl0fKZ3w&r=1iJ6OX7D7L47l9bTpxrbK0TAPfNh_pNdp6N0eQk4AYg&m=sibWvlHHG47ieAtRqQhVtXfe1icTG-fWvZc4LWfZUjI&s=-b6jc6KxHHIJQd0c97zSUn9oTloCxtZncUPChfyoGb8&e= 
Sent from the OpenRAVE Users List mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Go from Idea to Many App Stores Faster with Intel(R) XDK
Give your users amazing mobile app experiences with Intel(R) XDK.
Use one codebase in this all-in-one HTML5 development environment.
Design, debug & build mobile apps & 2D/3D high-impact games for multiple OSs.
https://urldefense.proofpoint.com/v2/url?u=http-3A__pubads.g.doubleclick.net_gampad_clk-3Fid-3D254741911-26iu-3D_4140&d=CwICAg&c=jIGm9aumLIlctTGl0fKZ3w&r=1iJ6OX7D7L47l9bTpxrbK0TAPfNh_pNdp6N0eQk4AYg&m=sibWvlHHG47ieAtRqQhVtXfe1icTG-fWvZc4LWfZUjI&s=-0XuytgGr86QNxMApbkB9q2OzAwyo_Hxbvzvt5-IktE&e= 
_______________________________________________
Openrave-users mailing list
[hidden email]
https://urldefense.proofpoint.com/v2/url?u=https-3A__lists.sourceforge.net_lists_listinfo_openrave-2Dusers&d=CwICAg&c=jIGm9aumLIlctTGl0fKZ3w&r=1iJ6OX7D7L47l9bTpxrbK0TAPfNh_pNdp6N0eQk4AYg&m=sibWvlHHG47ieAtRqQhVtXfe1icTG-fWvZc4LWfZUjI&s=BjwlT3lWuKHHpRCp_SQQCSY7-U6UeS1MgX9zzVqm614&e= 

------------------------------------------------------------------------------
Go from Idea to Many App Stores Faster with Intel(R) XDK
Give your users amazing mobile app experiences with Intel(R) XDK.
Use one codebase in this all-in-one HTML5 development environment.
Design, debug & build mobile apps & 2D/3D high-impact games for multiple OSs.
http://pubads.g.doubleclick.net/gampad/clk?id=254741911&iu=/4140
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users
Reply | Threaded
Open this post in threaded view
|

Re: Unable to install openRAVE. Package catalog broken.

Franks
This post was updated on .
yes perhaps i need to be clear about what i need, first of lets say i dont know NOTHING about what you and or your community are doing with this files, what i do know is that i write and read C++ and my robot uses SCC32 & Arduino MCU as its controllers and Motor Drivers, and i want to go about having my humanoid do movement that of Inverse Kinematics meaning if i tell or have my humanoid walk or grab something that ever motor will act as one in order to not have it move one motor at a time, so if it moves its hand wrist elbow shoulder will follow along to make the actual move and if the waist needs to give in a little to make that reach that it will do so without me having to tell it to do so manually as in fact if i point to the red cup its will move any motor involve in completing this task sorta like visual servoing, if you go to my website you can see my humanoid there's only one on there, now what i thought this programs here would do is calculate all of those crazy math for me so that i can take that c++ file into Arduino for arduino to tell the motor drivers which motor will be involved in this particular operation excorp.weebly.com
Reply | Threaded
Open this post in threaded view
|

Re: Unable to install openRAVE. Package catalog broken.

baxelrod
I believe what you are attempting to do is way beyond the capabilities of an Arduino.  Performing inverse kinematics involves a large amount of trigonometry, linear algebra, and floating point math that the 8 bit microcontroller won't be able to handle.  At least not in any reasonable amount of time, if it even fits on the device.  I attached some sample ikfast files so you get the idea of what I am talking about.

But it is still not exactly clear to me what you are trying to achieve.  If you have some stock walking gait (with more than one joint moving at a time), you can definitely follow that with the Arduino.  You would only need IK if you have some world coordinates (for example from a perception system) where you want to place your hand or foot.

What are the degrees of freedom of your robot?  If it is low, you might be able to calculate by hand.

-Ben


-----Original Message-----
From: Franks [mailto:[hidden email]]
Sent: Sunday, December 06, 2015 2:11 PM
To: [hidden email]
Subject: Re: [OpenRAVE-users] Unable to install openRAVE. Package catalog broken.

yes perhaps i need to be clear about what i need, first of lets say i dont know NOTHING about what you and or your community are doing with this files, what i do know is that i write and read C++ and my robot uses SCC32 & Arduino MCU as its controllers and Motor Drivers, and i want to go about having my humanoid do movement that of Inverse Kinematics meaning if i tell or have my humanoid walk or grab something that ever motor will act as one in order to not have it move one motor at a time, so if it moves its hand wrist elbow shoulder will follow along to make the actual move and if the waist needs to give in a little to make that reach that it will do so without me having to tell it to do so manually as in fact if i point to the red cup its will move any motor involve in completing this task sorta like visual servoing, if you go to my website you can see my humanoid there's only one on there, now what i thought this programs here would do is calculate all of those crazy math for me so that i can take that c++ file into Arduino for arduino to tell the motor drivers which motor will be involved in this particular operation



--
View this message in context: https://urldefense.proofpoint.com/v2/url?u=http-3A__openrave-2Dusers-2Dlist.185357.n3.nabble.com_Unable-2Dto-2Dinstall-2DopenRAVE-2DPackage-2Dcatalog-2Dbroken-2Dtp4026982p4027696.html&d=CwICAg&c=jIGm9aumLIlctTGl0fKZ3w&r=1iJ6OX7D7L47l9bTpxrbK0TAPfNh_pNdp6N0eQk4AYg&m=aLEk9_TB1A4c3CpoDEWChjzyCVaJdFlcF2oaKQh2lCY&s=67IKQLzg0lTGjSZvH6bhFdL5r1AEko8Nb8myhLcsCDM&e=
Sent from the OpenRAVE Users List mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Go from Idea to Many App Stores Faster with Intel(R) XDK Give your users amazing mobile app experiences with Intel(R) XDK.
Use one codebase in this all-in-one HTML5 development environment.
Design, debug & build mobile apps & 2D/3D high-impact games for multiple OSs.
https://urldefense.proofpoint.com/v2/url?u=http-3A__pubads.g.doubleclick.net_gampad_clk-3Fid-3D254741911-26iu-3D_4140&d=CwICAg&c=jIGm9aumLIlctTGl0fKZ3w&r=1iJ6OX7D7L47l9bTpxrbK0TAPfNh_pNdp6N0eQk4AYg&m=aLEk9_TB1A4c3CpoDEWChjzyCVaJdFlcF2oaKQh2lCY&s=HkJmzduZLrNu9VH4wsa6mBtZO57idHTpFFJAR1d9qi4&e=
_______________________________________________
Openrave-users mailing list
[hidden email]
https://urldefense.proofpoint.com/v2/url?u=https-3A__lists.sourceforge.net_lists_listinfo_openrave-2Dusers&d=CwICAg&c=jIGm9aumLIlctTGl0fKZ3w&r=1iJ6OX7D7L47l9bTpxrbK0TAPfNh_pNdp6N0eQk4AYg&m=aLEk9_TB1A4c3CpoDEWChjzyCVaJdFlcF2oaKQh2lCY&s=ndGLKhdeuF7UTtQg-79cCCiDGefDpDKVAFA7qoPrxWc&e= 

------------------------------------------------------------------------------
Go from Idea to Many App Stores Faster with Intel(R) XDK
Give your users amazing mobile app experiences with Intel(R) XDK.
Use one codebase in this all-in-one HTML5 development environment.
Design, debug & build mobile apps & 2D/3D high-impact games for multiple OSs.
http://pubads.g.doubleclick.net/gampad/clk?id=254741911&iu=/4140
_______________________________________________
Openrave-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openrave-users

ikfast.h (16K) Download Attachment
ikfast61.TranslationDirection5D.0_1_2_3_4.cpp (308K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Unable to install openRAVE. Package catalog broken.

Franks
This post was updated on .
thanks for the detailed explanation,

    "But it is still not exactly clear to me what you are trying to achieve?"

what im trying to achieve is Visual Servoing, and while most user tend to control their Robot im not, im simply trying to layout the set of rules just like humans are bound by rules/laws and moral codes and is why we are led to act as we do in our daily life, this is the same constrains that im looking to apply to this humanoid, the rest will be up to the onboard sensors and by this i mean touch, feelings and focus points of motivations, now i have been working on a AI source built in visual studios and this will be the engine if you will that will communicate with the end user and this AI will be responsible for computing questions, statement as well as responses to itself and the human element using sensors and machine vision/computer vision aka OpenCV/SimpleCV.  Now while most of the data will be done in a pc Windows 8.1 i5 Processor and a server wirelessly Tx this data to the Android the locomotion will be done inside the application via Arduino and other good motor drivers respectfully for the stepper motor, Servos, solenoids and DC motors,

   "What are the degrees of freedom of your robot?"

let me make clear that this is a humanoid and by definition it should have the limitation and constrains that of human beings, so when you ask me "What are the degrees of freedom of your robot?" this is your answer.  

   "I believe what you are attempting to do is way beyond the capabilities of an Arduino.  Performing inverse kinematics involves a large amount of trigonometry, linear algebra, and floating point math that the 8 bit microcontroller won't be able to handle."

Are you aware of Atlas the Boston Dynamics Humanoid? well i recall several video where i was paying attention to its inner parts and notices Arduino MCU such as Micro or even nano size boards in its back near its motor drivers, now i hear what your saying about an Arduino not being a fast contender for this specific application but the fact is that as long as memory does not become a issue i should be good and even so theres such things as shield with the expansion of memory that will table this issue, yes math is a big one BUT as long as i have the right C Math.h libraries in the include# in my main sketch that is all that will be needed to compute which is where the controller gets its given name "MCU" now i have those libraries that will let me perform MatrixMath/Matrices, MatrixInvert() sin() cos() atan2() functions, and a combination of polynomial and acos() functions (This custom math library runs 10+ times faster than the standard built-in library Cmath)functions are executed one by one right?  well the mcu will only execute one line of code at a time which is why sophisticated algorithms need to be implemented just like algebraic equations using variables

 "meaning you can write 15 lines of code that will be executed one by one IF they have met their conditional statements OR you can write 1 line of code that will do the same exact thing that the 15 line of code would do, so now when that one line is executed alot will happen upon the first execution of instructions" now once this code is executed the commands are sent to the proper motor drivers and therefor out of the mcu hands and now ready for the next set of calculation on the hierarchy tree of arguments. (functions/methods or void loop)

The driver will be in charge of executing multiple motor runs either cw/ccw translating into joint movements after reading analog/digital readings from sensors, this is all very possible with arduino and in the case one cant do it then theres is no reason why we cant use more then one mcu after all we humans use 2 sides of our brains to compute correct?!

I JUST NEED TO GET THIS PROGRAM RUNNING SO I CAN GET MY PROJECT CUT IN HALF BY NOT HAVING TO SCRATCH CODE EVERYTHING

i do hope this note makes clear my attempt and clear up all the confusion my friend.

by the way did you noticed me in my profile picture with Atlas? this was taken at the WPI University down the street from my home here in Worcester, Ma SO TRUST ME i had plenty of time to sit there and study everything about this machine non-invasively but its a open body frame so you can see alot at the distance i was so i know what makes this thing tick.
Reply | Threaded
Open this post in threaded view
|

Re: Unable to install openRAVE. Package catalog broken. (Ubuntu 15.10)

AgriPacTe
In reply to this post by andreas
Bonjour,

I am installing OpenRave on Ubuntu 15.10.
It seems the "sudo add-apt-repository ppa:openrave/release"
works fine, but ... look at the following ...
(do I specify a version instead of "openrave" in the "apt-get install"?

-----------------------------------------------------------------------
cs@cs-Aspire-5520:~$ sudo apt-get update
Atteint http://archive.canonical.com wily InRelease
Atteint http://fr.archive.ubuntu.com wily InRelease                                                        
Ign http://ppa.launchpad.net vivid InRelease                                                                
Ign http://www.openfoam.org wily InRelease                                                                  
Réception de : 1 http://fr.archive.ubuntu.com wily-updates InRelease [64.4 kB]                              
Ign http://ppa.launchpad.net wily InRelease                                                                
Ign http://www.openfoam.org wily Release.gpg                                                                
Ign http://www.openfoam.org wily Release                                                                    
Réception de : 2 http://ppa.launchpad.net vivid Release.gpg [316 B]                                        
Atteint http://security.ubuntu.com wily-security InRelease                                                  
Err http://www.openfoam.org wily/main Sources                                                              
 
Ign http://ppa.launchpad.net wily Release.gpg                                                              
Atteint http://fr.archive.ubuntu.com wily-backports InRelease                                              
Err http://www.openfoam.org wily/main Sources                                                              
 
Atteint http://archive.canonical.com wily/partner i386 Packages                                            
Atteint http://ppa.launchpad.net vivid Release                                                              
Err http://www.openfoam.org wily/main Sources                                                              
 
Atteint http://archive.canonical.com wily/partner Translation-en                                            
Ign http://ppa.launchpad.net wily Release                                                                  
Ign http://ppa.launchpad.net vivid Release                                                                  
Réception de : 3 http://security.ubuntu.com wily-security/main Sources [28.3 kB]                            
Err http://www.openfoam.org wily/main Sources                                                              
 
Err http://www.openfoam.org wily/main Sources  404  Not Found
Réception de : 4 http://security.ubuntu.com wily-security/restricted Sources [2,854 B]                      
Réception de : 5 http://security.ubuntu.com wily-security/multiverse Sources [1,923 B]                      
Réception de : 6 http://security.ubuntu.com wily-security/universe Sources [7,420 B]                        
Ign http://ppa.launchpad.net vivid/main i386 Packages/DiffIndex                                            
Réception de : 7 http://security.ubuntu.com wily-security/main i386 Packages [88.4 kB]                      
Réception de : 8 http://security.ubuntu.com wily-security/main i386 Packages [88.4 kB]                    
Réception de : 9 http://security.ubuntu.com wily-security/restricted i386 Packages [10.8 kB]                
Réception de : 10 http://security.ubuntu.com wily-security/universe i386 Packages [37.1 kB]                
Réception de : 11 http://security.ubuntu.com wily-security/multiverse i386 Packages [6,076 B]              
Atteint http://ppa.launchpad.net vivid/main Translation-en                                                  
Réception de : 12 http://fr.archive.ubuntu.com wily-updates/main Sources [47.1 kB]                          
Réception de : 13 http://fr.archive.ubuntu.com wily-updates/restricted Sources [3,741 B]                    
Atteint http://security.ubuntu.com wily-security/main Translation-en                                        
Réception de : 14 http://fr.archive.ubuntu.com wily-updates/multiverse Sources [1,923 B]                    
Atteint http://security.ubuntu.com wily-security/multiverse Translation-en                                  
Réception de : 15 http://fr.archive.ubuntu.com wily-updates/universe Sources [12.8 kB]                      
Atteint http://security.ubuntu.com wily-security/restricted Translation-en                                
Atteint http://security.ubuntu.com wily-security/universe Translation-en                                    
Réception de : 16 http://fr.archive.ubuntu.com wily-updates/main i386 Packages [125 kB]
Atteint http://ppa.launchpad.net vivid/main i386 Packages                                    
Réception de : 17 http://fr.archive.ubuntu.com wily-updates/restricted i386 Packages [13.4 kB]  
Réception de : 18 http://fr.archive.ubuntu.com wily-updates/universe i386 Packages [52.4 kB]    
Réception de : 19 http://fr.archive.ubuntu.com wily-updates/multiverse i386 Packages [6,076 B]  
Atteint http://fr.archive.ubuntu.com wily/main Sources                                          
Atteint http://fr.archive.ubuntu.com wily-backports/restricted Sources                
Err http://ppa.launchpad.net wily/main i386 Packages  404  Not Found

Ign http://ppa.launchpad.net wily/main Translation-fr_FR                                  
Atteint http://fr.archive.ubuntu.com wily-backports/multiverse Sources                    
Ign http://ppa.launchpad.net wily/main Translation-fr                                      
Ign http://ppa.launchpad.net wily/main Translation-en_GB                                  
Atteint http://fr.archive.ubuntu.com wily-backports/restricted i386 Packages              
Ign http://ppa.launchpad.net wily/main Translation-en                                      
Ign http://ppa.launchpad.net vivid/main Translation-fr_FR                                  
Atteint http://fr.archive.ubuntu.com wily-backports/multiverse i386 Packages              
Ign http://ppa.launchpad.net vivid/main Translation-fr                                    
Ign http://ppa.launchpad.net vivid/main Translation-en_GB                                  
Atteint http://fr.archive.ubuntu.com wily-backports/multiverse Translation-en              
Atteint http://fr.archive.ubuntu.com wily-backports/restricted Translation-en
Atteint http://fr.archive.ubuntu.com wily/restricted Sources
Atteint http://fr.archive.ubuntu.com wily/multiverse Sources
Atteint http://fr.archive.ubuntu.com wily/universe Sources
Atteint http://fr.archive.ubuntu.com wily/main i386 Packages
...
Atteint http://fr.archive.ubuntu.com wily-backports/main Translation-en                                    
Atteint http://fr.archive.ubuntu.com wily-backports/universe Translation-en                                
440 ko réceptionnés en 21s (20.6 ko/s)                                                                      
W: Erreur de GPG : http://ppa.launchpad.net vivid Release : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 005EAE8119BB5BCA
W: Impossible de récupérer http://www.openfoam.org/download/ubuntu/dists/wily/main/source/Sources  404  Not Found

W: Impossible de récupérer http://ppa.launchpad.net/openrave/release/ubuntu/dists/wily/main/binary-i386/Packages  404  Not Found

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.
cs@cs-Aspire-5520:~$ sudo apt-get install openrave
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Aucune version du paquet openrave n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « openrave » n'a pas de version susceptible d'être installée
cs@cs-Aspire-5520:~$
-----------------------------------------------------------------------
12