Quantcast

collade loading error

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

collade loading error

taylor
This post was updated on .
half_arm1.daeHi rosen,
when I try to load the COLLADA files generated from Google Sketchup, openrave says

[colladareader.cpp:3218] COLLADA error:
Trying to load an invalid COLLADA version for this DOM build!

What does this error mean?

my COLLADA version is 1.4.1

Thanks
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: collade loading error

Praveen

OpenRave does not support collada 1.4 .
If it is one rigid body, you can convert the version just by changing the first line to
<COLLADA xmlns="http://www.collada.org/2008/03/COLLADASchema" version="1.5.0">
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: collade loading error

taylor
Thank you for the answer.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: collade loading error

taylor
In reply to this post by Praveen
Hi Praveen,
I've change the version by hand to 1.5.0. But openrave still give the same error message.

I've attached my small robot xml file to the problem. If you have time, you can check it and maybe give some advises.

Thanks
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: collade loading error

taylor
In reply to this post by Praveen
aha! I have already solved it. Thank you again
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: collade loading error

strikedp
Hi Taylor! Can you tell me how you solved it? Had you load a SW file in openrave?
Loading...